High Bandwidth Memory (HBM2) Interface Intel® FPGA IP User Guide

Download
ID 683189
Date 9/27/2021
Public
Document Table of Contents

5.2. Simulating High Bandwidth Memory (HBM2) Interface Intel® FPGA IP with ModelSim* and Questa*

  1. Launch the ModelSim simulator.
  2. Select File > Change Directoryand navigate to: project_directory/sim/ed_sim/sim/mentor
  3. Verify that the Transcript window is visible; if it is not, display it by selecting View > Transcript.
  4. In the Transcript window, run source msim_setup.tcl at the bottom of the ModelSim tool screen.
  5. After the Tcl script finishes running, run ld_debug in the Transcript window. This command compiles the design files and elaborates the top-level design.
  6. After ld_debug finishes running, the Objects window appears. In the Objects window, select the signals to simulate by right-clicking and selecting Add Wave from the context menu.
    For example, if you want to see the HBM2 interface signals, select the module mem0_0 from the Instance window. With mem0_0 selected, go to the Objects window and select the signals that you want to see. (If the Objects window is not visible, you can display it by selecting View > Objects.
  7. To run the HBM2 simulation, type run -all.
    If the simulation is not visible, select View > Wave. With the Wave window open, select File > Save Format. Click OK to capture your selected waveforms in a wave.do file. To display the waveforms, type do wave.do, and then type run -all.
    Whenever you make changes to the design or to the wave.do, you must repeat step 7 of this procedure. Alternatively, you can combine the instructions into a script and run that script instead. The following example illustrates a run.do script containing the necessary commands:
    if {[file exists msim_setup.tcl]} {
            source msim_setup.tcl
           ld_debug
            do wave.do
           run -all } else {        error "The msim_setup.tcl script does not exist. 
    Please generate the example design RTL and simulation scripts. See ../../README.txt 
    for help." }
    
    Save the run.do script in the same directory as the msim_setup.tcl file. Type do run.do to run this script from the Transcript window.
  8. Upon completion of the simulation, the Transcript window displays efficiency data and other useful information.

Did you find the information on this page useful?

Characters remaining:

Feedback Message