Intel® Quartus® Prime Pro Edition User Guide: Design Optimization

ID 683641
Date 12/04/2023
Public
Document Table of Contents
Give Feedback

6.3.1. The Logic Lock Regions Window

Use the Logic Lock Regions window GUI to view, define, and modify the attributes of Logic Lock regions in your project.
Figure 108.  Logic Lock Regions Window


The Logic Lock Regions window organizes the constraints into the following two tabs:

Table 40.   Logic Lock Regions Window Tabs
Logic Lock Regions Window Tab Description
Assignment Regions Displays the properties of all Logic Lock regions that you define in the current project (saved in the .qsf). Modify Logic Lock region properties in this tab.
Compilation Regions Displays the properties of any Logic Lock region contained in a .qdb file in the project. Tab is read-only because you must edit imported Logic Lock region properties in the original project.

Open the Logic Lock Regions window by clicking:

  • Assignments > Logic Lock Window.
  • View > Logic Lock Window in the Chip Planner.
  • Right-click Logic Lock Region > Logic Lock Regions Window in Project Navigator.

You can customize the appearance of Logic Lock Regions window by dragging the columns to change their order and showing or hiding optional columns by right-clicking any column.