Intel® Quartus® Prime Pro Edition User Guide: Getting Started

ID 683463
Date 3/28/2022
Public

A newer version of this document is available. Customers should click here to go to the newest version.

Document Table of Contents

2.2. Intel® Quartus® Prime Project Contents

The Intel® Quartus® Prime software organizes your design work within a project. You can create and compare multiple revisions of your project, to experiment with settings that achieve your design goals. When you create a new project in the GUI, the Intel® Quartus® Prime software automatically creates an Intel® Quartus® Prime Project File (.qpf) for that project. The .qpf references the Intel® Quartus® Prime Settings File (.qsf). The .qsf lists the project's design, constraint, and IP files, and stores project-wide and entity-specific settings that you specify in the GUI. You do not need to edit the text-based .qpf or .qsf files directly. The Intel® Quartus® Prime software creates and updates these files automatically as you make changes in the GUI.
Table 3.   Intel® Quartus® Prime Project Files
File Type Contains To Edit Format
Project file Project and revision name File > New Project Wizard Intel® Quartus® Prime Project File (.qpf)
Settings file Lists design files, entity settings, target device, synthesis directives, placement constraints Assignments > Settings Intel® Quartus® Prime Settings File (.qsf)
Quartus database Project compilation results Project > Export Design Quartus Database File (.qdb)
Partition database Partition compilation results Project > Export Design Partition Partition Database File (.qdb)
Timing constraints Clock properties, exceptions, setup/hold Tools > Timing Analyzer Synopsys Design Constraints File (.sdc)
Logic design files RTL and other design source files File > New All supported HDL files
Programming files Device programming image and information Tools > Programmer

SRAM Object File (.sof)

Programmer Object File (.pof)

IP core files IP core variation parameterization Tools > IP Catalog Intel® Quartus® Prime IP File (.ip)
Platform Designer system files System definition Tools > Platform Designer Platform Designer System File (.qsys)
EDA tool files Scripts for third-party EDA tools Assignments > Settings > EDA Tool Settings Verilog Output File (.vo)

VHDL Output File (.vho)

Verilog Quartus Mapping File (.vqm)

Archive files Complete project as single compressed file Project > Archive Project Intel® Quartus® Prime Archive File (.qar)

Did you find the information on this page useful?

Characters remaining:

Feedback Message