Intel® FPGA Power and Thermal Calculator User Guide

ID 683445
Date 6/26/2023
Public

A newer version of this document is available. Customers should click here to go to the newest version.

Document Table of Contents
Give Feedback

3.2. Estimating Power While Creating the FPGA Design

If your FPGA design is partially complete, you can import a .qptc file (<revision name>.qptc) generated by the Intel® Quartus® Prime software into the Intel® FPGA Power and Thermal Calculator. After importing the information from the .qptc file into the Intel® FPGA PTC, you can edit the Intel® FPGA PTC data to reflect the device resource estimates for your final design.

If you have run the Intel® Quartus® Prime Power Analyzer (QPA), it produces a .qptc file. (See the Processing > Start > Start Power Analyzer menu in the Intel® Quartus® Prime software.)

By default, this file has a name that matches the project revision name. If you want to specify a custom name for the .qptc file, you can do so either through the Intel® Quartus® Prime software (see Assignments > Settings > Power Analyzer Settings > Power and Thermal Calculator export file name) or use the following assignment in the .qsf file:
set_global_assignment -name POWER_AND_THERMAL_CALCULATOR_EXPORT_FILE <filename>

When you open the Intel® FPGA PTC with an Intel® Quartus® Prime project (either from the Tools menu, or if you specified a project on the quartus_ptc command line) the PTC looks for this .qptc file and attempts to open it. If the .qptc file is not found, an error message occurs. After dismissing the error message, you are free to use the Intel® FPGA PTC to enter design information manually.

Table 3.  Advantages and Constraints of Power Estimation if your FPGA Design is Partially Complete
Advantage Constraint
  • You can perform power estimation early in the FPGA design cycle.
  • You can adjust design resources and parameters and see how those changes affect total power consumption.
  • Provides the flexibility to automatically populate the Intel® FPGA PTC based on the Intel® Quartus® Prime software compilation results.
  • Accuracy depends on your inputs and your estimate of the device resources; where this information may change (during or after your design is complete). Your power estimation results may be less accurate.
  • Unlike the Power Analyzer, which has access to the full design details, the Intel® FPGA PTC uses averages and not the actual design implementation. For example, the Intel® FPGA PTC uses average values for ALM configuration, while the Power Analyzer uses an exact configuration for each ALM.

Importing a File

Importing a .qptc file saves you time and effort otherwise spent on manually entering all the information into the Intel® FPGA PTC. You can also manually change any of the values after importing a file. You can create a .qptc file for an Intel Agilex® 7-based or Intel® Stratix® 10-based design, by running the Intel® Quartus® Prime Power Analyzer (see the Processing > Start > Start Power Analyzer menu in the Intel® Quartus® Prime software).

Importing Data into the Intel® FPGA Power and Thermal Calculator

You must import the .qptc file into the Intel® FPGA PTC before modifying any information. Also, you must verify all your information after importing a file. Importing a file from the Intel® Quartus® Prime software populates all input values based on your design and design settings that were specified in the Intel® Quartus® Prime software. Alternatively, you can import values exported from an earlier version of the Intel® FPGA PTC.

To import data into the Intel® FPGA PTC, follow these steps:

  1. On the File menu, click Open and then Browse to an existing Intel® FPGA .qptc file generated by the current or earlier version of the Intel® FPGA PTC or the Intel® Quartus® Prime software. Click Open.
  2. After the file is imported into the Intel® FPGA PTC, the cursor changes from busy to normal. If a problem occurs during import, the Intel® FPGA PTC displays the PTC Import Warnings dialog box. Analyze each unexpected warning to understand the cause. Manually modify the corresponding fields in the Intel® FPGA PTC after the import completes.

Importing .qptc Data for Intel® Stratix® 10 Devices into the Intel® FPGA Power and Thermal Calculator for Intel Agilex® 7 Devices

If you want to import a data file originally exported from the Intel® Quartus® Prime software for a design targeting Intel® Stratix® 10 devices, for use in the Intel Agilex® 7 version of the Intel® FPGA Power and Thermal Calculator, follow these steps:

  1. In the Intel® Stratix® 10 version of the Power and Thermal Calculator, open the existing .qptc file generated by the Intel® Quartus® Prime software based on a design targeting an Intel® Stratix® 10 device.
  2. Save the file as a .ptc file, and exit the Intel® Stratix® 10 Power and Thermal Calculator.
  3. Launch the Power and Thermal Calculator, select Open an existing PTC design file, navigate to the .ptc file created in step 2, and click the Override family in design file..
    Figure 2. Override Device Selection
  4. Select the appropriate Intel Agilex® 7 device and modify resources and other settings to reflect your planned design targeting the Intel Agilex® 7 device.

Importing an Early Power Estimator file from an Earlier Version to the Intel® FPGA Power and Thermal Calculator (For Intel® Stratix® 10 devices only)

If you want to import a .csv file originally exported from the Intel® Quartus® Prime software version 19.4, or from the Early Power Estimator spreadsheet version 19.4, for a design targeting an Intel® Stratix® 10 device, for use in the Intel® Stratix® 10 version of the Power and Thermal Calculator version 20.3 or later, follow these steps:

  1. Open the Early Power Estimator .csv file exported from the 19.4 version of the Intel® Quartus® Prime software or Early Power Estimator spreadsheet in the Intel® Stratix® 10 version of the Power and Thermal Calculator.
  2. Save the file as a .ptc file, and exit the Intel® Stratix® 10 Power and Thermal Calculator.

Appending an Imported .ptc or .qptc File to An Existing Design in the Intel® FPGA Power and Thermal Calculator

With a design open in the PTC, you can use the File > Import Design command to import an external .ptc or .qptc file and append the imported content to the current file.

Unlike the File > Open command, File > Import Design does not overwrite existing content; rather, imported rows are appended as new rows in the relevant tables.

Tables that cannot have multiple rows are not affected, even if they are specified in the imported profile; the PTC displays a warning message if a single-value row in the imported profile is different from the value in the PTC before the Import Design operation was performed.

Note:

Some general guidelines about the import process:

  • A .qptc file created for an Intel Agilex® 7 or Intel® Stratix® 10 design, can always be imported into the Intel® FPGA PTC for use with the same device family.
  • A .ptc file created for an Intel® Stratix® 10 design can be imported into the Intel® FPGA PTC for use with the similar design targeting an Intel Agilex® 7 device.
  • A .qptc file created for an Intel Agilex® 7 design, cannot be imported into the Intel® FPGA PTC for use with an Intel® Stratix® 10 design.
  • Some power-consuming resources — such as transceivers — of an original Intel® Stratix® 10 design might not be carried through the import process.