Intel® FPGA Software Installation and Licensing

ID 683472
Date 3/28/2022
Public

A newer version of this document is available. Customers should click here to go to the newest version.

Document Table of Contents

2.3.2. Intel® High Level Synthesis Compiler Software Requirements

The Intel® HLS Compiler Pro Edition is part of the Intel® Quartus® Prime Pro Edition Design Suite. You can install the Intel® HLS Compiler as part of your Intel® Quartus® Prime software installation or install it separately. It requires Intel® Quartus® Prime and additional software to use.

The Intel HLS Compiler requires the C++ Compiler and Siemens EDA* Questa* Software in addition to Intel® Quartus® Prime:

C++ Compiler

On Linux, Intel® HLS Compiler requires GCC 9.3.0 including the GNU C++ library and binary utilities (binutils).

This version of GCC is provided as part of your Intel® HLS Compiler installation. After installing the Intel® HLS Compiler, GCC 9.3.0 is available in <installdir>/gcc.

Important: The Intel® HLS Compiler uses the <installdir>/gcc directory as its toolchain directory. Use this installation of GCC for all your HLS-related design work.
For Windows, install one of the following versions of Microsoft* Visual Studio* Professional:
  • Microsoft* Visual Studio* 2017 Professional
  • Microsoft* Visual Studio* 2017 Community
Important: The Intel® HLS Compiler software does not support versions of Microsoft* Visual Studio* other than those specified for the edition of the software.

For Questa*-Intel® FPGA Edition software requirements, refer to Questa*-Intel FPGA Edition Software Requirements

Did you find the information on this page useful?

Characters remaining:

Feedback Message