AN 630: Real-Time ISP and ISP Clamp for Intel® MAX® Series Devices

ID 683786
Date 5/27/2022
Public

Creating an .ips

To create an .ips, follow these steps:

  1. On the Tools menu, click Programmer to open the Intel® Quartus® Prime Programmer window. Alternatively, you can click Programmer on the toolbar.
  2. In the Intel® Quartus® Prime Programmer window, click Add File to add the programming file (.pof, .jam, or .jbc) into the programmer window.
  3. Select the programming file in the list. Then, on the Edit menu, click ISP CLAMP State Editor.
  4. Specify the states of the pins in your design using the ISP Clamp State Editor. There are four clamp states available—tri-state, high, low, and sample and sustain. By default, all pins are set to tri-state.
  5. Save the .ips after making the modifications.

Note: Alternatively, to open the ISP Clamp State Editor to create a new .ips, on the File menu, point to Create/Update and click Create/Update IPS File.

Did you find the information on this page useful?

Characters remaining:

Feedback Message