Introduction to DSP Builder for Intel FPGAs

ID 683697
Date 10/20/2019
Public
Download

3.1. System Requirements

DSP Builder for Intel® FPGAs integrates with MathWorks MATLAB and Simulink tools and with the Intel® Quartus® Prime software.

Ensure at least one version of The MathWorks MATLAB and Simulink tool is available on your workstation before you install DSP Builder for Intel® FPGAs. You should use the same version of the Intel® Quartus® Prime software and DSP Builder for Intel® FPGAs. DSP Builder for Intel® FPGAs only supports 64-bit versions of MATLAB.

From v18.0, DSP Builder for Intel® FPGAs advanced blockset is available for Intel® Quartus® Prime Pro Edition and Intel® Quartus® Prime Standard Edition. DSP Builder for Intel® FPGAs standard blockset is only available for Intel® Quartus® Prime Standard Edition.

Table 1.   DSP Builder for Intel® FPGAs MATLAB Dependencies
Version MATLAB Supported Versions
DSP Builder Standard Blockset DSP Builder Advanced Blockset
Intel® Quartus® Prime Standard Edition Intel® Quartus® Prime Pro Edition
19.3

Not available

R2019a

R2018b

R2018a

R2017b

R2017a

R2016b

19.1 Not supported

R2013a

R2018b

R2018a

R2017b

R2017a

R2016b

18.1 R2013a

R2013a

R2018a

R2017b

R2017a

R2016b

18.0 R2013a

R2013a

R2017b

R2017a

R2016b

R2016a

R2015b

17.1 R2013a R2013a

R2016a

R2015b

R2015a

R2014b

R2014a

R2013b

Note: The DSP Builder for Intel® FPGAs advanced blockset uses Simulink fixed-point types for all operations and requires licensed versions of Simulink Fixed Point. Intel also recommends the DSP System Toolbox and the Communications System Toolbox, which some design examples use.

Did you find the information on this page useful?

Characters remaining:

Feedback Message