Intel® FPGA SDK for OpenCL™ Pro Edition: Getting Started Guide

ID 683188
Date 12/19/2022
Public
Document Table of Contents
Give Feedback

1.1. Prerequisites for the Intel® FPGA SDK for OpenCL™ Pro Edition

To install the Intel® FPGA SDK for OpenCL™ Pro Edition and create an OpenCL* application for an Intel FPGA Preferred Board for OpenCL, your system must meet certain hardware, target platform, and software requirements.

Hardware Requirements

Accelerator boards requirements:

  • Acquire a Reference Platform from Intel® , or a Custom Platform from an Intel® preferred board vendor.

    For more information, refer to the Intel FPGA SDK for OpenCL FPGA Platforms page on the Intel® FPGA website.

Development system requirements:

  • You must have administrator, root, or sudo privileges on the development system to install the necessary packages and drivers.
  • The development system has at least 85 gigabytes (GB) of free disk space for software installation.
  • For RAM requirements on the deployment system, follow these instructions:
    1. Visit the FPGA Software Download Center.
    2. Select the desired software product from the collection.
    3. Within the selected software product landing page, see System Requirements section. For additional memory recommendations, refer to the latest Intel® Quartus® Prime Pro Edition release notes.
    Tip: Refer to board vendor's documentation on the recommended system storage size.

  • For PCI Express* ( PCIe* ) accelerator boards, the host machine motherboard must have an available PCIe* port slot that is at least the same width (that is, the same number of PCIe* lanes) as the board.

The host system must run on one of the following supported operating systems:

  • For a list of supported Windows and Linux operating systems, refer to the Operating System Support page on the Intel® FPGA website.

Software Prerequisites

Develop your host application using one of the following Intel® FPGA SDK for OpenCL™ - and Intel® Quartus® Prime software-compatible C compiler or software development environment:

  • For Windows systems, use Microsoft Visual Studio Professional and Microsoft Visual C++ versions 2015 or later.
    Note: Intel® FPGA SDK for OpenCL™ plug-ins support Windows* 10 and Windows* Server 2016 systems, with installed Microsoft Visual Studio* 2017 or 2019 version. For correct working of Visual Studio plug-ins, you should have installed extensions for C/C++ Development, for example, Desktop development with C++ and Microsoft .Net Framework 4.5 or higher. For more information about the IDE workflow on Microsoft Visual Studio, refer to FPGA Workflows in Microsoft Visual Studio.
  • For Linux systems, use Eclipse 2019-12 or later and GCC 7.2.0. For more information about GCC, refer to GCC Requirement.
    Note: For correct working of Eclipse extensions, you should have installed C/C++ Development Tools and Java SE 11 or higher. For more information about the IDE workflow on Eclipse, refer to FPGA Workflows in Eclipse.

Linux systems require the Perl command version 5 or later. Include the path to the Perl command in your PATH system environment variable setting.

For Intel® FPGA SDK for OpenCL™ packages that include Intel Code Builder, Intel Code Builder requires Java SE version 1.8.71 or later to run.