Intel® High Level Synthesis Compiler Pro Edition: Version 22.2 Release Notes

ID 683682
Date 6/20/2022
Public

A newer version of this document is available. Customers should click here to go to the newest version.

1.3. Intel® High Level Synthesis Compiler Pro Edition Prerequisites

The Intel® HLS Compiler Pro Edition is part of the Intel® Quartus® Prime Pro Edition Design Suite. You can install the Intel® HLS Compiler as part of your Intel® Quartus® Prime software installation or install it separately. It requires Intel® Quartus® Prime and additional software to use.

For detailed instructions about installing Intel® Quartus® Prime Pro Edition software, including system requirements, prerequisites, and licensing requirements, see Intel® FPGA Software Installation and Licensing .

The Intel® HLS Compiler requires the following software in addition to Intel® Quartus® Prime:

C++ Compiler

On Linux, Intel® HLS Compiler requires GCC 9.3.0 including the GNU C++ library and binary utilities (binutils).

This version of GCC is provided as part of your Intel® HLS Compiler installation. After installing the Intel® HLS Compiler, GCC 9.3.0 is available in <quartus_installdir>/gcc.

Important: The Intel® HLS Compiler uses the <quartus_installdir>/gcc directory as its toolchain directory. Use this installation of GCC for all your HLS-related design work.
For Windows, install one of the following versions of Microsoft* Visual Studio* Professional:
  • Microsoft* Visual Studio* 2017 Professional
  • Microsoft* Visual Studio* 2017 Community
For the most up-to-date C++17 support, ensure that you are using the latest version of Visual Studio 2017.
Important: The Intel® HLS Compiler software does not support versions of Microsoft* Visual Studio* other than those specified for the edition of the software.

Siemens* EDA Questa® Simulation Software

On Windows and RedHat Linux systems, you can install the Questa® simulation software from the Intel® Quartus® Prime software installer. The available options are as follows:
  • Questa* Intel® FPGA Edition
  • Questa* Intel® FPGA Starter Edition

Both Questa* Intel® FPGA Edition and Questa* Intel® FPGA Starter Edition require licenses. The license for Questa* Intel® FPGA Starter Edition is free. For details, refer to Intel FPGA Software Installation and Licensing .

Alternatively, you can use your own licensed version of Siemens* EDA ModelSim* SE or Siemens* EDA Questa* Advanced Simulator software.

On Linux systems, Questa® - Intel FPGA Edition and Questa® - Intel FPGA Starter Edition require the Red Hat* development tools packages.

For information about all the ModelSim* and Questa® software versions that the Intel® software supports, refer to the EDA Interface Information section in the Software and Device Support Release Notes for your edition of Intel® Quartus® Prime Pro Edition.

Did you find the information on this page useful?

Characters remaining:

Feedback Message