Configuring VXLAN with Intel® Ethernet Converged Network Adapters on VMware® ESXi® 5.5/5.1

Technical Brief

Networking Division (ND)

December 2013
## Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>December 2013</td>
<td>Initial release (Intel Public)</td>
</tr>
</tbody>
</table>
NOTE: This page intentionally left blank.
Contents

1.0 Introduction ........................................................................................................................................ 1
  1.1 Hardware Requirements .................................................................................................................... 1
  1.2 Software Requirements ...................................................................................................................... 1
    1.2.1 Supported Guest Configurations .......................................................................................... 1

2.0 Installation and Configuration ........................................................................................................... 2
  2.1 Host Server Enablement and Operating System Installation ............................................................. 2
  2.2 VXLAN Prerequisites ........................................................................................................................ 2
    2.2.1 Creating a Cluster ..................................................................................................................... 3
    2.2.2 Creating a Distributed Switch .................................................................................................. 4
    2.2.3 Installing vShield Manager Appliance .................................................................................... 7
  2.3 VXLAN Configuration ......................................................................................................................... 12
  2.4 Performance Optimization for Intel® Converged Network Adapters .............................................. 20

3.0 Summary ............................................................................................................................................. 22

4.0 Customer Support .............................................................................................................................. 22

5.0 For Product Information ..................................................................................................................... 22
1.0 Introduction

With the rise of Cloud computing, software-defined networking and network virtualization have become key components in network management. Network virtualization provides network administrators the ability to scale resources and handle workloads dynamically without the need to reconfigure physical infrastructure. Virtual eXtensible Local Area Network (VXLAN) is an overlay technology used for network virtualization that improves network scalability and addresses segmentation limitations. In VMware ESXi 5.1/5.5, VXLAN provides software-defined networking functionality by overcoming layer 2 boundaries, enabling the creation and management of logical networks on demand and ultimately providing greater network flexibility.

VXLAN allows for the creation of logical networks for virtual machines across different physical networks by encapsulating Ethernet frames in a UDP VXLAN header. By encapsulating layer 2 packets, VXLAN effectively allows for the creation of layer 2 networks on top of layer 3 networks. In addition, VXLAN is capable of supporting 16 million layer 2 networks as opposed to only 4096 using VLAN.

This document provides an example configuration for VXLAN networks with the Intel® Ethernet Converged Network Adapter (CNA) X540 and X520 in a VMware ESXi* 5.5/5.1 environment. Also refer to VMware's VXLAN deployment guide:


1.1 Hardware Requirements

A server platform that meets the following requirements:

- Compatibility with the VMware* ESXi* release
- Support for Intel® Virtualization Technology for Directed I/O (Intel® VT-d)
- An available PCI Express* v2.0 (5.0GT/s) x8 Lanes with ARI and ACS support slot
- An Intel® Ethernet Converged Network Adapter X520/X540

**Note:** To verify compatibility of physical hosts and Network Interface Cards (NICs) with ESXi releases, refer to the VMware Compatibility Guide.

1.2 Software Requirements

- VMware ESXi 5.5/5.1
- VMware vSphere* 5.5/5.1
- VMware vCenter 5.5/5.1 Server
- VMware vCloud Networking and Security 5.5/5.1

1.2.1 Supported Guest Configurations

- Red Hat® Enterprise Linux 6.x
- Windows® Server 2008 R2 with SP2
- Windows® Server 2012
- Windows® Server 2012 R2
2.0 Installation and Configuration

2.1 Host Server Enablement and Operating System Installation

1. Install the Intel Ethernet CNA in an available PCI-Express* (PCIe*) x8 slot. Make sure that the x8 slot is electrically connected as an x8. Some slots are physically x8 but electrically support x4 only. Verify this, and that the slot connects to a PCI Root Complex Supporting ACS and ARI, with your server manufacturer or system documentation.

2. Power up the server.

3. Enter the server’s BIOS setup and make sure the virtualization technology, Intel® VT-d, is enabled on the server.

4. Install VMware ESXi 5.5 or 5.1 on the server.

**Note:** ESXi 5.5/5.1 host inbox drivers support VXLAN, and are generally the recommended drivers for VXLAN. Consult VMware's documentation for driver compatibility information.

5. Configure vCenter server and/or vSphere client to connect to the ESXi host for GUI management.

2.2 VXLAN Prerequisites

In order to configure VXLAN networking, first create a cluster and a VMware vSphere Distributed Switch (VDS). Also install the VMware vShield Manager Appliance, a component of VMware vCloud Networking and Security 5.5/5.1, on your vCenter 5.5/5.1 Server. Configuration for each of these components using VMware ESXi 5.5 is described in the sections that follow. For some features, use of the VMware web interface might be preferable. For our example we use VMware ESXi 5.5, but most instructions should apply to 5.1 as well. Also, a DHCP server is assumed to be functional on the network. An example configuration is shown in Figure 1.

![VXLAN Example Configuration](image-url)
2.2.1 Creating a Cluster

1. Login to your vCenter Server via the vSphere Client. For more information on installing and configuring vSphere Client and vCenter Server, refer to the official VMware documentation.

2. From vSphere Client, click **View > Inventory > Hosts and Clusters.**

3. Right-click on your datacenter and click **New Cluster...**
4. Enter a name for the cluster and click **Next**.

5. Complete the rest of the setup wizard in accordance to your preferences. Upon completing the wizard, the new cluster appears in the inventory pane. Drag your host(s) to the new cluster to add them.

6. Create as many clusters as needed in your environment. The example presented is a setup with two clusters of a single host each.

### 2.2.2 Creating a Distributed Switch

The vSphere distributed switch is a key component of VXLAN networking that centralizes virtual switch management by enabling multiple ESXi hosts to access the same virtual switch. Network configuration is centralized to the vCenter server instead of each individual host, providing a unified management interface for the user. In addition, the vSphere distributed switch allows for the sub-division of VLANs through the use of Private VLANs (pVLANs) and provides additional features for security and traffic control.
1. From vSphere Client, click **View > Inventory > Networking**.

2. Right-click on your datacenter and select **New vSphere Distributed Switch....**

3. In the setup wizard, select your desired switch version. Click **Next**.

4. Select an appropriate number of uplinks for your setup. The number of uplinks should be proportional to the number of network adapters you want to use for each host. You can use more than one network adapter per host for redundancy if needed. After setting this value, click **Next**.
5. Select the hosts that you want to include in your VXLAN network and select which network adapters to use for each host. The following example selects two hosts, each using an Intel® Ethernet CNA X520. Click Next.
6. Click **Finish** to create the distributed virtual switch. The switch appears in the inventory panel.

### 2.2.3 Installing vShield Manager Appliance

1. Before installing the vShield Manager Appliance, make sure that the .OVA installation file is stored on the vCenter Server.

2. To install the vShield Manager Appliance, from the vShield Client, click **File > Deploy OVF Template**.
3. In the setup wizard, browse your file system and select the .OVA file for the vShield Manager Appliance.

4. Complete the remaining steps in the wizard to install the vShield Manager Appliance to a location of your choosing. After finishing the setup wizard, a new vShield Manager VM should appear in your Hosts and Clusters inventory window.
5. Right-click on the new vShield Manager VM and click **Open Console**.

6. Power on the virtual machine and login using the following default credentials:
Username: admin
Password: default

7. After logging in, type `Enable` into the command line. Enter the same default credentials to authenticate.

8. Type `setup` and configure the vShield Manager VM networking information.

9. After configuring the vShield Manager Appliance, open up a web browser and navigate to:

http://<ip_address_of_vShield_Manager>/

Where `<ip_address_of_vShield_Manager>` is the IP address that you assigned to the vShield Manager Appliance during setup. Login using the same default credentials.
10. To link the vShield Manager to your vCenter server, navigate to **Settings & Reports** on the left pane. Under the **Configuration** tab on the right pane, edit the information listed under **vCenter Server** to match your vCenter Server’s network configuration.
2.3 VXLAN Configuration

1. To setup a VXLAN network, login to vShield Manager via a web browser and select your datacenter in the left pane. On the right pane, navigate to the Network Virtualization tab.

2. Press the Preparation link and then Edit to add the cClusters you want to participate in VXLAN networking. For each of the clusters added, select which distributed switch you want to transport the VXLAN traffic and configure the VXLAN transport VLAN. The VXLAN transport VLAN is the VLAN ID under which all VXLAN traffic is transported. After choosing a distributed switch and setting the VLAN, click Next.
3. Set the desired teaming policy and set the MTU to 1600. Note that if setting up a LACP LAG both the VDS and the port channel on the physical switch need to use L4 for the load-balance hashing.

4. Click **Finish** to begin preparing your hosts for VXLAN networking.
5. You’ll now see your newly added clusters in the preparations list which begins to undergo an initialization process. During this process, VXLAN Tunnel Endpoints (VTEPs) are configured and the VIB package for VXLAN networking is downloaded from the vCenter Server to your hosts. VTEPS transport VM traffic over the physical network, connecting VDSs and enabling cross-host communication.

**Note:** If your clusters continue to show Not ready or Has issues statuses after initialization, it is likely that the VIB package did not correctly download to your hosts. If this is the case, you’ll see the following error message in the vSphere event log:

This might be an issue with your DNS name resolution. To rectify, verify that the hostname for your vCenter server resolves to the IP set on the appliance. Re-add your clusters as described in steps 1 through 4.

6. If the VIB package for VXLAN networking installs on your hosts correctly, you’ll see the following message in the vSphere event log:
7. After successfully preparing your clusters for VXLAN networking, click the Segment ID button and then press Edit. There are two parameters that you need to set: the segment ID pool and the multicast address range. The segment ID pool is the range of assignable VXLAN Network Identifiers (VNIs) and essentially dictates the number of logical networks that you can create. In addition, you’ll want to set the multicast address range. Ideally, each multicast group address should be associated with one logical network, though this is not always possible. After setting the segment ID pool and multicast address range, click Ok.

8. Click the Network Scopes link and press the + Add symbol.
9. Give the network scope a name and description and select the clusters you want to participate in this network scope. Click **Ok** to create the network scope.

![Add Network Scope](image1.png)

10. Click the **Networks** link and press the **+ Add** symbol.

![Networks](image2.png)

11. Give the VXLAN network a name and description and assign it to the network scope that you previously created. Click **Ok** to create the network.
12. Click on your newly created VXLAN network in the network list.
13. Click the **Virtual Machines** button and press the **+ Add** symbol.

14. Use the search function to select the network adapters you want to add to this VXLAN network. Press **Next** then **Finish** to add the network adapters and their associated virtual machines.

15. Depending on your desired network setup, you can repeat the previous steps to create multiple network scopes and VXLAN networks and assign different combinations of virtual machines to each network. In addition to the vShield Manager web-based GUI, you can see your VXLAN Network(s) from the vSphere Client under **View > Inventory > Networking**.
Here you can drag and drop virtual machines to and from each VXLAN network for easy VXLAN network management.
2.4 Performance Optimization for Intel® Converged Network Adapters

To take full advantage of the Intel® Converged Network Adapter's capabilities, enable Receive Side Scaling (RSS) in the ESXi host to balance the CPU load across multiple cores. Refer to the VMware performance paper *VXLAN Performance Evaluation on VMware vSphere® 5.1* for performance results with Intel® Converged Network Adapter X520 with RSS enabled:


1. To enable RSS, you need access to ESXi shell. Consult your VMware documentation for more details on shell enablement.
2. Log into ESXi shell.
3. Run the following command and take note of the names of the attached network adapters:

```bash
~# esxcfg-nics-l
```

Example:
4. The commands to enable RSS depend on the version of the ixgbe driver that is installed on the ESXi host. Using the network adapter name, you can check which version of the ixgbe driver you have using the following command:

```
~# ethtool -i vmnic_name
```

Example:

![Ethtool Output](image.png)

5. Enter the following commands to unload the ixgbe driver module and reload it with RSS enabled on the host.

If your ixgbe driver version is the inbox driver version:

```
~# esxcfg-module -u ixgbe
~# vmkload_mod ixgbe RSS="4"
```

To enable RSS on multiple network adapters, add a comma-separated 4 for each additional network adapter. For example, to enable RSS on two adapters:

```
~# vmkload_mod ixgbe RSS="4,4"
```

If your ixgbe driver version is a newer, asynchronous driver version (from VMware's website):

```
~# esxcfg-module -u ixgbe
~# vmkload_mod ixgbe RSS="1"
```

Similarly, to enable RSS on multiple network adapters, add a comma-separated 1 for each additional network adapter. For example, to enable RSS on two adapters:

```
~# vmkload_mod ixgbe RSS="1,1"
```

6. To verify that RSS is working as intended, you can monitor the RSS queues using the following command:

```
ethtool -S vmnic_name
```

You can also verify to see if RSS was successfully enabled by checking the vmkernel log with the following command or by running ALT+F12 from the console.

```
tail -n 100 /var/log/vmkernel.log
```

Example:

![Vmkernel Log](image.png)
3.0 Summary

VMware network virtualization solutions with Intel Ethernet CNAs can provide businesses with greater flexibility and control over their networks.

In addition, Intel Ethernet CNA support for RSS in the host VMware ESXi operating system can increase network performance compared to non-RSS enabled solutions. Intel Ethernet CNA support for VXLAN technology in VMware ESXi 5.5/5.1 is part of Intel's continuing efforts to enable network virtualization in the datacenter, providing the tools that are needed for network flexibility and manageability in rapidly evolving cloud and enterprise environments.

4.0 Customer Support

Intel Customer Support offers a broad selection of programs including phone support and warranty service. For more information, contact us at:

support.intel.com/support/go/network/adapter/home.htm

Note: Service and availability can vary by country.

5.0 For Product Information

To speak to a customer service representative regarding Intel products, please call:
1-800-538-3373 (U.S. and Canada) or visit:

support.intel.com/support/go/network/contact.htm for the telephone number in your area.