Article ID: 000081826 Content Type: Troubleshooting Last Reviewed: 10/30/2018

Why does bwmonitor show ERROR Item not found: could not open device 0?

Environment

  • Intel® Quartus® Prime Pro Edition
  • BUILT IN - ARTICLE INTRO SECOND COMPONENT
    Description

    When using the bwmonitor tool with the Intel® Programmable Acceleration Card (PAC) with Intel® Arria® 10 GX FPGA, you may use the following command to see available devices:

    $ bwconfig --list

    ------------------------------------------------------------------------------

    Name           Number ID      Location                    Status

    ------------------------------------------------------------------------------

    A10SA4         0      202315  Local USB Device            Installed

     

    Based on this output, you may think device 0 is present and can be read, however, using bwmonitor the following error is encountered:

     

    $ bwmonitor --device=0 --read --type=Sensor

    ERROR Item not found: could not open device 0

     

    Resolution

    The command:

     

    $ bwconfig --list 

     

    Provides a listing of all devices that are currently mapped in the system, even if the device is not currently in the system.

    To correct this issue, do the following:

     

    $ bwconfig --scan=usb

     

    This will show currently connected cards.  If the --scan list does not match --list results, then you will need to use

     

    $ bwconfig --remove=<number of device that does not match>

     

    And:

    $ bwconfig --add=usb

     

    To add the currently connected devices.  Making this change enables bwmonitor to work properly.

    Related Products

    This article applies to 2 products

    Intel® Arria® 10 GX FPGA
    Intel® PAC with Intel® Arria® 10 GX FPGA

    Disclaimer

    1

    All postings and use of the content on this site are subject to Intel.com Terms of Use.