Intel® Integrated Performance Primitives (Intel® IPP) 2017 System Requirements

Published: 02/29/2016  

Last Updated: 08/25/2016

By Chao Yu

Please see the following links available online for the latest information regarding the Intel® Integrated Performance Primitives (Intel® IPP):

System Requirements

Depending on the software distribution that you received Intel IPP with, the Intel® IPP 2017 supports the following processor types:

  • Intel® Core™ processors
  • Intel® Xeon® processors
  • Intel® Xeon Phi™ processors
  • Intel® Atom™ processors
  • Intel® Quark™ microprocessors

Supported operating systems

The lists below pertain only to the system requirements necessary to support developing applications with Intel® IPP. Please review your compiler (GCC*, Microsoft* Visual Studio* or Intel® Compiler, CLANG) hardware and software system requirements, in the documentation provided with that product, to determine the minimum development system requirements necessary to support your compiler product.

      Microsoft* Windows* OS:

  • Windows 10* (IA-32/Intel® 64)
  • Windows 8.1* (IA-32/Intel® 64)
  • Windows 8* (IA-32/Intel® 64)
  • Windows 7* (IA-32/Intel® 64) - Note: SP1 is required for use of Intel® AVX instructions
  • Windows Server 2016*
  • Windows Server 2012* R2
  • Windows Server 2008* R2 SP1 and SP2 (IA-32/Intel® 64)
  • Windows HPC Server 2008* R2
  • Windows 10* IoT
  • Windows Embedded 8*,
  • Windows Embedded 7*
  • Required free disk space: 2 GB for a 32- or 64-bit install.  For both 4 GB are required

       Linux* OS distributions:

  • Red Hat* Enterprise Linux* 6, 7 and 7.5
  • Fedora* 24 and 25
  • SUSE* Linux* Enterprise Server (SLES) 11 and 12
  • openSUSE* 13.2
  • Ubuntu* 14.04 LTS,15.04,15.10 and 16.0.4
  • Debian* 7.0 and 8.0
  • CentOS* 7.1
  • Wind River* Linux* 6 and 7
  • Yocto Project* 1.7 and 1.8
  • Tizen* 3.0
  • Snappy Ubuntu* 15.04
  • Required free disk space: 2 GB (for a 32 -or- 64 bit install.  For both 4 GB are required)

       OS X*:

  • OS X* 10.12, and OS X* 10.11
  • Required free disk space: 4 for install.

      Android* OS:

  • Android* 5.x, 6.0

Note: Intel® IPP is expected to work on many more Linux distributions as well. Let us know if you have trouble with the distribution you use.


Supported compilers

     Microsoft* Windows* OS:

  • Intel® C++ Compiler: version 2016 and above
  • Microsoft Visual Studio* 2015 - help file and environment integration
  • Microsoft Visual Studio* 2013 - help file and environment integration
  • Microsoft Visual Studio* 2012 - help file and environment integration

     Linux* and Android* OS:

  • Intel® C++ Compiler: version 2016 and above
  • GNU Compilers 4.1 and later.
  • Glibc version 2.4 or higher is required

      OS X* OS:

  • Intel® C++ Compiler:version 2016 and above
  • XCode 6.x, XCode 7.x

Other tools supported for use with example source code:

  • Zlib example: zlib version 1.2.5.3, 1.2.6.1, 1.2.7.3 and 1.2.8

Product and Performance Information

1

Performance varies by use, configuration and other factors. Learn more at www.Intel.com/PerformanceIndex.