Intel® Data Analytics Acceleration Library 2018 System Requirements

Published: 03/16/2017  

Last Updated: 09/07/2017

Please see the following links to the online resources and documents for the latest information regarding Intel DAAL:

·         Intel® DAAL Product Page

·         Intel® DAAL 2018 Release Notes

·         Intel® DAAL 2018 Installation Guide

System Requirements

The Intel® DAAL supports the IA-32 and Intel® 64 architectures. For a complete explanation of these architecture names please read the following article:
Intel Architecture Platform Terminology for Development Tools.

The lists below pertain only to the system requirements necessary to support application development with Intel® DAAL. Please review your compiler (gcc*, Microsoft Visual Studio* or Intel® C++ Compiler ) hardware and software system requirements, in the documentation provided with that product to determine the minimum development system requirements necessary to support your compiler product.

Supported Operating Systems

  • Windows 10* 
  • Windows 8*
  • Windows 8.1* 
  • Windows 7* - Note: SP1 is required for use of Intel® AVX instructions
  • Windows Server* 2012 
  • Windows Server* 2016
  • Red Hat* Enterprise Linux* 6 
  • Red Hat* Enterprise Linux* 7 
  • Red Hat Fedora* 25
  • SUSE Linux Enterprise Server* 12
  • SUSE Linux Enterprise Server* 12 SP1
  • Debian* GNU/Linux 8 
  • Ubuntu* 16.04 
  • Ubuntu* 16.10 
  • macOS* 10.12
  • macOS* 10.13

Note: Intel® DAAL is expected to work on many more Linux distributions as well. Let us know if you have trouble with the distribution you use.

Supported C/C++* compilers for Windows* OS:

  • Intel® C++ Compiler 16.0 for Windows* OS
  • Intel® C++ Compiler 17.0 for Windows* OS
  • Intel® C++ Compiler 18.0 for Windows* OS
  • Microsoft Visual Studio* 2013 - help file and environment integration
  • Microsoft Visual Studio* 2015 - help file and environment integration
  • Microsoft Visual Studio* 2017 - help file and environment integration

Supported C/C++* compilers for Linux* OS:

  • Intel® C++ Compiler 16.0 for Linux* OS
  • Intel® C++ Compiler 17.0 for Linux* OS
  • Intel® C++ Compiler 18.0 for Linux* OS
  • GNU Compiler Collection 5.0 and later

Supported C/C++* compilers for macOS*:

  • Intel® C++ Compiler 16.0 for macOS*
  • Intel® C++ Compiler 17.0 for macOS*
  • Intel® C++ Compiler 18.0 for macOS*
  • Xcode* 8
  • Xcode* 9

Supported Java* compilers:

  • Java* SE 7 from Sun Microsystems, Inc.
  • Java* SE 8 from Sun Microsystems, Inc.

Supported Python versions:

  • Intel® Distribution for Python 3.5 (64-bit) for Windows* OS
  • Intel® Distribution for Python 2.7 (64-bit) for Linux* OS
  • Intel® Distribution for Python 3.5 (64-bit) for Linux* OS
  • Intel® Distribution for Python 2.7 (64-bit) for macOS*
  • Intel® Distribution for Python 3.5 (64-bit) for macOS*
  • Python* 2.7 (64-bit) for Linux* OS
  • Python* 3.5 (64-bit) for Linux* OS
  • Python* 2.7 (64-bit) for macOS*
  • Python* 3.5 (64-bit) for macOS*

MPI implementations that Intel® DAAL for Windows* OS has been validated against:

MPI implementations that Intel® DAAL for Linux* OS has been validated against:

Database

  • MySQL 5.x
  • KDB+ 3.4

Hadoop* implementations that Intel® DAAL has been validated against:

  • Hadoop* 2.6 and above

Note: Intel® DAAL is expected to work on many more Hadoop* distributions as well. Let us know if you have trouble with the distribution you use.

Spark* implementations that Intel® DAAL has been validated against:

  • Spark* 2.0

Note: Intel® DAAL is expected to work on many more Spark* distributions as well. Let us know if you have trouble with the distribution you use.

Product and Performance Information

1

Performance varies by use, configuration and other factors. Learn more at www.Intel.com/PerformanceIndex.