Intel® FPGA Software License Troubleshooter

How to Get a New License File

Use the "Web License Update" feature to automatically download and install your most up-to-date license file. Click Web License Update in the License setup dialog box (Tools menu).

If you still need help, check the license file set up section "How to check the license file setup" on this page for your software.

You need to get a license file from Intel and set it up to use the Intel® Quartus® development software.
If you are using Intel Quartus development software version 3.0 and do not have a license file set up, you can request a license file when you start the software.
You can also request a license file from the Intel FPGA Licensing Center.
The license file is sent as an e-mail attachment. Save the license file on your hard drive. Intel recommends saving the license file in the same directory as the software you are using.

If you still have a problem, verifiy that the Intel® Quartus® development software is configured to point to a valid license file in order to run. For detail on how to check the license file set up, please refer to the section "How to check the license set up" on this page.

How to Check the License File Setup

Is your software licensed with a network card ID or a hard disk ID?

Network card ID: Open the License Setup window in the Intel® Quartus® development software (Tools menu -> License Setup). Check to see whether the network interface card (NIC) ID section of the System Info box matches the NIC ID specified in your license file.

Hard disk ID: Following are some other resources you can use to help solve the issue you may be experiencing with Intel® FPGA products.

Search for solutions in the Knowledge Base.

Browse documentation.

Intel FPGA Software Installation and Licensing (PDF)

DSP Builder Handbook (PDF)

Submit a service request to mySupport, Intel's technical online support system.

To find out whether your software is licensed with a network interface card (NIC) ID or hard disk ID, open your license file in a text editor.

If it includes the word HOSTID followed by a 12-digit hexadecimal number, the software is licensed with a NIC ID.
Example: HOSTID=00C04FA0B182 is licensed with a NIC ID.

Licensing problems with T-Guards can occur if the T-Guard is not recognized by the software. This can happen if the parallel port on your computer is not configured for ECP mode.
Verify in the BIOS that the parallel port is set to ECP mode.

Is your software licensed with a network card ID or a hard disk ID?

Check BIOS Setting: The Sentinel Driver must be enabled for the parallel port into which you plugged the T-Guard. Run the setupx86.exe program in the \drivers directory.
Choose Configure Sentinel Driver from the File menu.
Make sure that the Use? Column is set to Yes for your parallel port.
Exit the Sentinel Driver program and restart your computer.

Different BIOS versions have different procedures to make this setting. Consult your computer vendor for help.

Open the License Setup window in the Intel® Quartus® development software (Tools menu -> License Setup).
Check to see whether the network interface card (NIC) ID section of the System Info box matches the NIC ID specified in your license file. Verifiy your NIC ID appear properly.

If you need further help, you may be able to fix this problem by adding a key in the Windows registry. Use the Registry Editor (regedt32.exe) to view the following key in the registry: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

Add the following registry value:

Value Name DisableDHCPMediaSense
Data Type REG_DWORD -Boolean
Value 1

Reboot your computer for the change to take effect.

Set DisableDHCPMediaSense Registry Key

Problems with floating licenses can occur due to configuration problems on the license server.
Run the command lmutil lmstat -a -c port@host where port@host is the port number and hostname of the license server (1800@server1, for example).
Examine the output of the command. The license manager and Intel FPGA daemon should report UP.
The Intel Quartus® development software version 3.0 requires the license manager and Intel FPGA daemon versions to be higher than 8.0.

If the license server status is OK, it is possible there is a configuration problem on the client computer.
Verify that the LM_LICENSE_FILE environment variable is set properly on the client computer.

Check the LM_LICENSE_FILE environment variable.

On UNIX*, type env |grep LM_LICENSE_FILE and make sure the value matches the location of the license file.
On Windows*, type set | find "LM_LICENSE_FILE" and make sure the value matches the location of the license file.
For information about setting the LM_LICENSE_FILE environment variable, check the AN 340: Intel FPGA Software Licensing Application Note.

If the license manager and atlered versions are lower than 8.0, Intel recommends using the latest versions of the license manager (lmgrd) and vendor daemon (Intel FPGA), which are included with the Intel® Quartus® development software.

Updated versions of the files are also available for download at the License Daemon Downloads page.
Restart the license manager after updating the files.

Which Software Are You Having Difficulties Licensing?

Intel® Quartus® Development Software

Depending on when your license file expires, you may need a new license file to use the new version of the software. Your license file may have expired.

To get a new license file for Quarterus development softawre version 4.0 or later, use the "Web License Update" feature to automatically download and install your most up-to-date license file.

Click Web License Update in the License setup dialog box (Tools menu). Also refer to the section "How to get a new license file" and select "Intel Quartus development software version 4.0 or later".

To get a license file for version 3.0 or earlier, you will need to get a license file from Intel and set it up to use the Intel® Quartus® development software.

If you are using Intel Quartus development software version 3.0 and do not have a license file set up, you can request a license file when you start the software.
You can also request a license file from the Intel FPGA Licensing Center.
The license file is sent as an e-mail attachment. Save the license file on your hard drive. Intel recommends saving the license file in the same directory as the software you are using. You can also refer to the section "How to get a new license file" and select "Intel Quartus development software version 3.0 or earlier".

If you already installed a new license file, check that the Intel® Quartus® development software is configured to point to a valid license file in order to run.

To check the License file set up, refer to the section "How to check the license file set up" and select one the the software listed below.

  • Intel® Quartus® Lite Edition
  • Intel Quartus development software with a T-Guard
  • Intel Quartus development software included with a development kit
  • Intel Quartus development software with a floating license server

A T-Guard is a hardware key or dongle that plugs into the parallel port of your computer.

If you are still need help, following the steps below.

Open the License Setup window (Tools menu -> License Setup). The License file field must have the path to your license file or a port@host license server specified. If you need to browse to a license file, click the [. . .] button and select the license file on your hard drive.

Examples of valid License file field values:

Path to license file: c:\quartus\license.dat

port@host: 1800@server1

You must set up a license file to use the Intel® Quartus® development software. You can request a license file from the Intel website if you don't have one already.

To get new license file, please refer to the section "How to get a new license file" on this page.

 If you already installed a license file, check if the Intel® Quartus® development software is configured to point to a valid license file in order to run. For how to check a license file setup, plese refer to the section "How to check the license file setup" on this page.

Your software will stop working if your license file expires.

Your license file may have expired. Please get a new license file discussed in the previous section "How to get a new license file".

If the license file hasn't expired, please verify that the Intel® Quartus® development software is configured to point to a valid license file in order to run. Veirfy the software is pointed to the license. For how to please refer to the section "How to check the license file setup".

If you still have a probelm, follow the steps below:.

Open the License Setup window (Tools menu -> License Setup). The License file field must have the path to your license file or a port@host license server specified.
If you need to browse to a license file, click the [. . .] button and select the license file on your hard drive.

Examples of valid License file field values:

Path to license file: c:\quartus\license.dat

port@host: 1800@server1

ModelSim*-Intel FPGA

Select one of Quartus software below you are using for detail:

Intel Quartus Prime Pro and Standard Edition software

The ModelSim*-Intel FPGA license is time limited. Your license file may have expired. In this case, you need to renew your software subscription with Intel. You can do this through the Intel eStore.

If the license server status checks out, there may be a configuration problem on the client computer. Verify that the LM_LICENSE_FILE environment variable is set properly on the client computer.

On UNIX type: env |grep LM_LICENSE_FILE. Make sure the value matches the location of the license file.
On Windows type: set | find "LM_LICENSE_FILE". Make sure the value matches the location of the license file.
For information about setting the LM_LICENSE_FILE environment variable, check AN 340: Intel FPGA Software Licensing Application Note).

Intel Quartus Prime Lite Edition software

The ModelSim*- Intel FPGA software is not included with the Intel® Quartus® Prime Lite Edition or with development boards. You need to purchase a full Intel® FPGA software subscription in order to get the ModelSim*-Intel FPGA license. You can purchase the full subscription in the Intel eStore.

Intel Quartus development software with a development kit

The ModelSim*- Intel FPGA software is not included with the Intel® Quartus® Prime Lite Edition or with development boards. You need to purchase a full Intel® FPGA software subscription in order to get the ModelSim*-Intel FPGA license. You can purchase the full subscription in the Intel eStore.

You have reached the end of this troubleshooter:

Following are some other resources you can use to help solve the issue you may be experiencing with Intel FPGA products.

Search for solutions in the Knowledge Base.

Browse documentation.

Intel FPGA Software Installation and Licensing (PDF)

DSP Builder Handbook (PDF)

Submit a service request to mySupport, Intel's technical online support system.

Intel can provide a ModelSim*-Intel® FPGA license for either Verilog or VHDL.

In your license file, check which language your license is for.

If the language you use to simulate in ModelSim*-Intel FPGA doesn't match your licensed language, please contact Intel customer service through mySupport.

Following are some other resources you can use to help solve the issue you may be experiencing with Intel FPGA products.

Search for solutions in the Knowledge Base.

Browse documentation.

Intel FPGA Software Installation and Licensing (PDF)

DSP Builder Handbook (PDF)

Submit a service request to mySupport, Intel's technical online support system.

To check your licensed language, open the license.dat file that Intel sent you. Look for the INCREMENT alteramtivsim or INCREMENT alteramtivlog. The first indicates a VHDL license and the latter indicates a Verilog license. For more information on the license file format, go to the License File Format section of AN 340: Intel FPGA Software Licensing (PDF).

Both ModelSim-Intel FPGA and Intel Quartus Development Software

Depending on when your license file expires, you may need a new license file to use the new version of the software.

Your license file may have expired.

To get a new license file for Quarterus development softawre version 4.0 or later, use the "Web License Update" feature to automatically download and install your most up-to-date license file.

Click Web License Update in the License setup dialog box (Tools menu). Also refer to the section "How to get a new license file" and select "Intel Quartus development software version 4.0 or later".

To get a license file for version 3.0 or earlier, you will need to get a license file from Intel and set it up to use the Intel® Quartus® development software.

If you are using Intel Quartus development software version 3.0 and do not have a license file set up, you can request a license file when you start the software.
You can also request a license file from the Intel FPGA Licensing Center.
The license file is sent as an e-mail attachment. Save the license file on your hard drive. Intel recommends saving the license file in the same directory as the software you are using. You can also refer to the section "How to get a new license file" and select "Intel Quartus development software version 3.0 or earlier".

If you already installed a new license file, check that the Intel® Quartus® development software is configured to point to a valid license file in order to run.

To check the License file set up, refer to the section "How to check the license file set up" and select one the the software listed below.

    Intel® Quartus® Lite Edition

    Intel Quartus development software with a T-Guard

    Intel Quartus development software included with a development kit

    Intel Quartus development software with a floating license server

A T-Guard is a hardware key or dongle that plugs into the parallel port of your computer.

If you are still need help, following the steps below.

Open the License Setup window (Tools menu -> License Setup). The License file field must have the path to your license file or a port@host license server specified. If you need to browse to a license file, click the [. . .] button and select the license file on your hard drive.

Examples of valid License file field values:

Path to license file: c:\quartus\license.dat

port@host: 1800@server1

You must set up a license file to use the Intel® Quartus® development software. You can request a license file from the Intel website if you don't have one already.

To get new license file, please refer to the previous section.

If you already installed a license file, check if the Intel® Quartus® development software is configured to point to a valid license file in order to run.

To check the license file setup, select software below and find out detail.

Intel® Quartus® Lite Edition

Intel Quartus development software with a T-Guard

Intel Quartus development software included with a development kit

Intel Quartus development software with a floating license server

A T-Guard is a hardware key or dongle that plugs into the parallel port of your computer.

If you are still need help, following the steps below.

Open the License Setup window (Tools menu -> License Setup). The License file field must have the path to your license file or a port@host license server specified.

If you need to browse to a license file, click the [. . .] button and select the license file on your hard drive.

Examples of valid License file field values:

Path to license file: c:\quartus\license.dat

port@host: 1800@server1

Your software will stop working if your license file expires and your license file may have expired. 

Please get a new license file discussed in the section "How to get a new license file".

If the license file hasn't expired, please verify that the Intel® Quartus® development software is configured to point to a valid license file in order to run. Veirfy the software is pointed to the license or refer to the section "How to check the license file setup" on this page.

If you still have a probelm, follow the steps below:.

Open the License Setup window (Tools menu -> License Setup). The License file field must have the path to your license file or a port@host license server specified. If you need to browse to a license file, click the [. . .] button and select the license file on your hard drive.

Examples of valid License file field values:

Path to license file: c:\quartus\license.dat

port@host: 1800@server1

DSP Builder for Intel FPGAs

Depending on when your license file expires, you may need a new license file to use the new version of the software.

Please refer to the section "How to get a new license file" on this page.

As part of the license setup process, you need to specify the location of the license file using the LM_LICENSE_FILE system variable.

Verify that your license file enables support for DSP Builder for Intel FPGAs. You can find what software your license enables by checking in the license file - lines beginning with FEATURE or INCREMENT list the software enabled by the license. For DSP Builder for Intel FPGAs, the FEATURE line required begins with C4D5_512A. The following figure shows an example license.dat file that includes the DSP Builder for Intel FPGAs FEATURE line (highlighted).

Your license file should contain the FEATURE line to enable support for DSP Builder.

If you still need help, follow the steps below:

Open the License Setup window (Tools menu -> License Setup). The License file field must have the path to your license file or a port@host license server specified. If you need to browse to a license file, click the [. . .] button and select the license file on your hard drive.

Examples of valid License file field values:

Path to license file: c:\quartus\license.dat

port@host: 1800@server1

Check the license file setup. Please refer to the section "How to check the license file setup" for detail.

You must set up a license file to use the DSP Builder for Intel FPGAs. You can request a license file from Intel's website if you don't have one already.

As part of the license setup process, you need to specify the location of the license file using the LM_LICENSE_FILE system variable.

Verify that your license file enables support for DSP Builder for Intel FPGAs. You can find what software your license enables by checking in the license file - lines beginning with FEATURE or INCREMENT list the software enabled by the license. For DSP Builder for Intel FPGAs, the FEATURE line required begins with C4D5_512A. The following figure shows an example license.dat file that includes the DSP Builder for Intel FPGAs FEATURE line (highlighted).

Verify your license file contain the FEATURE line to enable support for DSP Builder. If you don't see it, please contact Intel customer service to obtain the appropriate feature line for DSP Builder for Intel FPGAs and reissue a license.

If you need to get a new license file, you need to request a license file from Intel and set it up in order to use the DSP Builder for Intel® FPGAs. If you have purchased a DSP Development Kit, which includes the DSP Builder for Intel FPGAs, select the appropriate licensing link based on the development kit on the Intel FPGA Software Licensing web page. If you would like to request an evaluation license for the DSP Builder for Intel FPGAs or update your DSP Builder for Intel FPGAs license (new PC, transfer to a colleague, etc.), submit a mySupport service request. You will find instructions about how to set up your DSP Builder for Intel FPGAs license in the Set Up Licensing section of the DSP Builder Release Notes.

If you still have a problem, verify that the LM_LICENSE_FILE environment variable must point to the location of the license.dat file. The setup of the environment variable depends on the OS on your PC.

Windows* NT: Specify the license file location using LM_LICENSE_FILE in Windows NT.
Set the environment variable in the Windows system control panel.
1. Choose Settings -> Control Panel from the Windows Start menu.
2. Double-click the System icon in the Control Panel window.
3. Click the Environment tab in the System Properties dialog box.
4. Click the System variable list to highlight it.
5. Type LM_LICENSE_FILE in the Variable box.
6. Type \license.dat or @ in the value box.
7. Click Set, then click OK.
If more than one application uses this environment variable, modify the existing LM_LICENSE_FILE variable and separate the different paths with a semicolon (;), as shown in the following example:
c:\flexlm\license.dat; 1800@myserver

Set LM_LICENSE_FILE in Windows NT

Windows 2000 or Windows XP: pecify the license file location using LM_LICENSE_FILE in Windows 2000 or Windows XP Classic Control Panel view.

Set the environment variable in the Windows system control panel.
1. Choose Settings -> Control Panel from the Windows Start menu.
2. Double-click the System icon in the Control Panel window.
3. Click the Advanced tab in the System Properties dialog box.
4. Click Environment Variables.
5. Click the System Variable list to highlight it.
6. If LM_LICENSE_FILE already exists, select Edit. Otherwise, select New and type LM_LICENSE_FILE.
7. Type \license.dat or @ in the value box.
8. Click OK.
If more than one application uses this environment variable, modify the existing LM_LICENSE_FILE variable and separate the different paths with a semicolon (;), as shown in the following example:
c:\flexlm\license.dat; 1800@myserver

Set LM_LICENSE_FILE in Windows 2000 or Windows XP

Your software will stop working if your license file expires. Your license file may have expired.

You need to request a license file from Intel and set it up in order to use the DSP Builder for Intel® FPGAs. If you have purchased a DSP Development Kit, which includes the DSP Builder for Intel FPGAs, select the appropriate licensing link based on the development kit on the Intel FPGA Software Licensing web page. If you would like to request an evaluation license for the DSP Builder for Intel FPGAs or update your DSP Builder for Intel FPGAs license (new PC, transfer to a colleague, etc.), submit a mySupport service request. You will find instructions about how to set up your DSP Builder for Intel FPGAs license in the Set Up Licensing section of the DSP Builder Release Notes.

As part of the license setup process, you need to specify the location of the license file using the LM_LICENSE_FILE system variable.

Verify that your license file enables support for DSP Builder for Intel FPGAs. You can find what software your license enables by checking in the license file - lines beginning with FEATURE or INCREMENT list the software enabled by the license. For DSP Builder for Intel FPGAs, the FEATURE line required begins with C4D5_512A. The following figure shows an example license.dat file that includes the DSP Builder for Intel FPGAs FEATURE line (highlighted).

Verify your license file contain the FEATURE line to enable support for DSP Builder.

If you still have a problem, verify that the LM_LICENSE_FILE environment variable must point to the location of the license.dat file. The setup of the environment variable depends on the OS on your PC.

Windows* NT: Specify the license file location using LM_LICENSE_FILE in Windows NT.
Set the environment variable in the Windows system control panel.
1. Choose Settings -> Control Panel from the Windows Start menu.
2. Double-click the System icon in the Control Panel window.
3. Click the Environment tab in the System Properties dialog box.
4. Click the System variable list to highlight it.
5. Type LM_LICENSE_FILE in the Variable box.
6. Type \license.dat or @ in the value box.
7. Click Set, then click OK.
If more than one application uses this environment variable, modify the existing LM_LICENSE_FILE variable and separate the different paths with a semicolon (;), as shown in the following example:
c:\flexlm\license.dat; 1800@myserver

Set LM_LICENSE_FILE in Windows NT

Windows 2000 or Windows XP: pecify the license file location using LM_LICENSE_FILE in Windows 2000 or Windows XP Classic Control Panel view.

Set the environment variable in the Windows system control panel.
1. Choose Settings -> Control Panel from the Windows Start menu.
2. Double-click the System icon in the Control Panel window.
3. Click the Advanced tab in the System Properties dialog box.
4. Click Environment Variables.
5. Click the System Variable list to highlight it.
6. If LM_LICENSE_FILE already exists, select Edit. Otherwise, select New and type LM_LICENSE_FILE.
7. Type \license.dat or @ in the value box.
8. Click OK.
If more than one application uses this environment variable, modify the existing LM_LICENSE_FILE variable and separate the different paths with a semicolon (;), as shown in the following example:
c:\flexlm\license.dat; 1800@myserver

Set LM_LICENSE_FILE in Windows 2000 or Windows XP