Article ID: 000084777 Content Type: Troubleshooting Last Reviewed: 08/21/2012

Why do I get an error message when compiling my design targeting Arria V Hard IP for PCI Express in Quartus II software versions 11.1 and 11.1 SP1?

Environment

  • Quartus® II Subscription Edition
  • BUILT IN - ARTICLE INTRO SECOND COMPONENT

    Critical Issue

    Description

    Due to a problem in the Quartus® II software versions 11.1 and 11.1 SP1, when implementing a design with an Arria® V Hard IP for PCI Express® core with the BAR1 set to 32-bit in the Megawizard™, you may see an error message similar to the one below.

    Error: Hard IP parameter \'hd_altpe2_hip_top_bar1_prefetchable_0\' is set to an illegal value of \'false\' on node \'top:inst|altpcie_av_hip_ast_hwtcl:top_inst|altpcie_av_hip_128bit_atom:altpcie_av_hip_128bit_atom|g_pcie_hip.arriav_hd_altpe2_hip_top\'.
           Info: No legal values found

    Resolution

    To work around this problem, download and install the appropriate patch from the links below:

    For the Quartus II software version 11.1
    Download the version 11.1 Patch 0.19 for Windows (.exe) 
    Download the version 11.1 Patch 0.19 for Linux (.tar)
    Download the Readme file for Quartus II software version 11.1 Patch 0.19 (.txt)

    For the Quartus II software version 11.1 SP1
    Download the version 11.1 SP1 Patch 1.07 for Windows (.exe)
    Download the version 11.1 SP1 Patch 1.07 for Linux (.tar)
    Download the Readme file for Quartus II software version 11.1 SP1 Patch 1.07 (.txt)

    This problem is scheduled to be fixed in a future version of the Quartus II software.

    Related Products

    This article applies to 1 products

    Arria® V GX FPGA

    Disclaimer

    1

    All postings and use of the content on this site are subject to Intel.com Terms of Use.