Article ID: 000081915 Content Type: Troubleshooting Last Reviewed: 12/01/2017

IP Upgrade tool erroneously reports that your current IP core must be updated

Environment

  • Quartus® II Subscription Edition
  • PCI Express
  • BUILT IN - ARTICLE INTRO SECOND COMPONENT

    Critical Issue

    Description

    The Quartus II software version 14.1 requires that you specify a device if your IP core targets the Arria 10 device family.

    If you generate your IP core outside of a Quartus II software project (such as through the command line using qsys-edit, or within the Quartus II GUI), and you did not specify your target Arria 10 device, when you add your IP variation to your project, the IP Upgrade tool reports that version 14.1 of your IP core is out-of-date and must be updated to version 14.1.

    This issue affects several IP cores, including, but not limited to:

    • Arria 10 Hard IP for PCI Express
    • 50G Interlaken Megacore function
    • 100G Interlaken Megacore function
    • Arria 10 1G/10GBE and 10GBASE-KR PHY
    • RapidIO Megacore function
    • RapidIO II Megacore function
    • SerialLite III Streaming MegaCore function for Arria 10
    Resolution

    If you do not specify a device and you generate your IP core outside a Quartus II software project, when you add your IP variation to your project, upgrade your IP variation when prompted by the IP Upgrade dialog box.

    Related Products

    This article applies to 1 products

    Intel® Arria® 10 FPGAs and SoC FPGAs

    Disclaimer

    1

    All postings and use of the content on this site are subject to Intel.com Terms of Use.