Article ID: 000078403 Content Type: Error Messages Last Reviewed: 01/01/2015

Internal Error: Sub-system: FHSSI, File: / quartus/fitter/fhssi/fhssi_dprio.cpp, Line: 1222 m_tx_pma_inclk_regs[i] != 0

Environment

  • Stratix® IV GX FPGA
  • Quartus® II Subscription Edition
  • BUILT IN - ARTICLE INTRO SECOND COMPONENT
    Description

     

    For Stratix® IV GX and Stratix® IV GT devices, the Quartus® II software verison 9.0 generates this error if there are multiple ALTGX_RECONFIG instantiations which are controlled by the same user logic in a design.

     

    Some designs may not show the above error and pass compilation. However during run time, the dynamic reconfiguration on some transceiver channels may be affected. This issue does not show up in functional simulation. To Fix this issue, Altera recommends you to install Patch 0.19 for the Quartus II software version 9.0. Install the appropriate patch from the link below and compile your design.

    For Windows:

    Patch 0.19 for Quartus II 9.0 Windows.zip

     

    For Linux:

    Patch 0.19 for Quartus II 9.0 Linux.tar
    Patch 0.19 for Quartus II 9.0 Linux (readme.txt)

     

     

    Alternatively, you can work around this issue by using a single ALTGX_RECONFIG block.

    This problem is scheduled to be fixed in a future version of the Quartus II software.

     

     

    Disclaimer

    1

    All postings and use of the content on this site are subject to Intel.com Terms of Use.