Article ID: 000076786 Content Type: Troubleshooting Last Reviewed: 07/07/2017

Why does my PCIe Stratix 10 L-tile ES2 component display "Please select a valid device to generate the IP" upon generation?

Environment

  • Intel® Stratix® 10 FPGAs and SoC FPGAs
  • Intel® Quartus® Prime Pro Edition
  • Avalon-MM Intel® Stratix® 10 Hard IP for PCI Express
  • Avalon-ST Intel® Stratix® 10 Hard IP for PCI Express
  • BUILT IN - ARTICLE INTRO SECOND COMPONENT

    Critical Issue

    Description

    Due to a problem with the Intel® Quartus® Prime Pro v17.1 Stratix® 10 ES software Editions, when you try to generate a Stratix 10 ES2 PCI Express* IP core you will see this message:

    Error: phy_<your speed and lane width>.altera_xcvr_pcie_hip_channel_s10_ch<your channel>: The current selected device "<your device>S2" is not supported by the IP. Please select a valid device to generate the IP.

     

    Resolution

    To work around this problem ensure you are using the latest release of ES Software Edition and install one of the patches below:

    Windows

    Linux

    Readme

    This problem has been fixed starting in Quartus Prime Pro software version 17.1 production release.

    Disclaimer

    1

    All postings and use of the content on this site are subject to Intel.com Terms of Use.