Article ID: 000073857 Content Type: Error Messages Last Reviewed: 08/14/2019

Error: aoc: The Intel®  Kernel Builder for OpenCL™ compiler (ioc64) can not be found

Environment

  • Intel® Arria® 10 FPGAs and SoC FPGAs
  • Intel® Stratix® 10 FPGAs and SoC FPGAs
  • Intel® Quartus® Prime Pro Edition
  • Intel® FPGA SDK for OpenCL™
  • BUILT IN - ARTICLE INTRO SECOND COMPONENT
    Description

    Due to a problem in version 19.1 and 19.2 of the Intel® FPGA SDK for OpenCL™, if you compile your OpenCL project for emulation by adding -fast-emulator, Errors may occur as following:
    Error: aoc: The Intel® Kernel Builder for OpenCL™ compiler (ioc64) can not be found

    This is because for fast emulator support, the "Intel SDK for OpenCL Applications" must also be installed. It is separate from the Intel® FPGA SDK for OpenCL™.
     

    Resolution

    To work around this problem, you must download and install the correct version of the "Intel SDK forOpenCL Applications"

    You may be required to log into your account during this process.

    1.     Go to the following link

            http://fpgasoftware.intel.com/

    2.     Select your Quartus software version in the dropdown menu

    3.     Select Linux or Windows

    4.     Select Akamai DLM3 Download Manager or Direct Download

    5.     Click the Additional Software tab

    6.     Download and install “Intel SDK for OpenCL Applications (for Intel Code Builder for OpenCL API) “

     

    Disclaimer

    1

    All postings and use of the content on this site are subject to Intel.com Terms of Use.