Article ID: 000059056 Content Type: Install & Setup Last Reviewed: 03/18/2022

Unable to Install Flask-PyMongo Package on Edge Software Hub

BUILT IN - ARTICLE INTRO SECOND COMPONENT
Summary

Quick steps to install Flask-PyMongo package on Edge Software Hub.

Description
  • Added the following line to the requirements.txt file
    • Flask-PyMongo==2.3.0
       
  • Rebuilt the image and ran into the following error:

    ERROR: Service 'ia_web_visualizer' failed to build: The command '/bin/sh -c pip3 instlal -r requirements.txt' returned a non-zero code: 1
Resolution

Adding a new package requires an Internet Connection. If there is no internet connection any changes to the requirements.txt file will be reverted and the image will build from cache.

To install a new package:

  1. Establish an Internet Connection
  2. Ensure the proxy has been setup in the ~/.docker/config.json file
  3. Add the package name and version to the requirements.txt file
  4. Rebuilt the image

Related Products

This article applies to 1 products