Device Family: Arria® II, Arria® V, Cyclone® IV, Cyclone® V, Intel® MAX® 10, MAX® V, Stratix® IV, Stratix® V

Intel Software: Quartus Prime Lite, Quartus Prime Standard

Type: Answers

Area: Tools


Last Modified: November 28, 2018
Version Found: v17.1
Bug ID: FB: 411675;

Error: No spd files are included in quartus project

Description

In the Intel® Quartus® Prime Standard Edition software version 17.1, the error message above may be seen while executing the ip-setup-simulation script on a project targeting a device that doesn't belong to the Intel® Arria® 10, Intel® Stratix® 10 or Intel® Cyclone® 10 families.

The ip-setup-simulation script requires an Intel® Arria® 10, Intel® Stratix® 10 or Intel® Cyclone® 10 Platform Designer folder structure to work properly.

Workaround/Fix

To work around this problem, switch from using the ip-setup-simulation script to the ip-make-simscript script. For more information on the ip-make-simscript script usage, please consult the Intel® Quartus® Prime Standard Edition Handbook Volume 1 Design and Synthesis, page 255.