Intel® Quartus® Prime Pro Edition User Guide: Scripting

ID 683432
Date 12/13/2021
Public

A newer version of this document is available. Customers should click here to go to the newest version.

Document Table of Contents

3.1.20.11. load_package (::quartus::misc)

The following table displays information for the load_package Tcl command:

Tcl Package and Version

Belongs to ::quartus::misc

Syntax load_package [-h | -help] [-long_help] [-version <version number> ] <package name>
Arguments -h | -help Short help
-long_help Long help with examples and possible return values
-version <version number> Option to specify the Quartus Prime Tcl package version to load
<package name> Name of Quartus Prime Tcl package to load
Description
Loads the specified Quartus Prime Tcl package with the specified
version number. If you do not specify the "-version" option, the
latest version is loaded by default.

The Quartus Prime Tcl package names have the "::quartus::" prefix, such
as "::quartus::project". For convenience, you can omit the
"::quartus::" prefix when you use the <package name> argument.

This command is similar to the "package require" command.  The
advantage of using "load_package" is that you can alternate freely
between different versions of the same package.

For example, if you loaded version 2.0, and now want to load version
1.0, you can type:

"load_package -version 1.0 <package name>". 
Example Usage
# Load version 1.0 of the ::quartus::project package
load_package project -version 1.0

# Load version 2.0 of the ::quartus::project package
load_package project -version 2.0
Return Value Code Name Code String Return
TCL_OK 0 INFO: Operation successful
TCL_ERROR 1 ERROR: Tcl package <string> does not exist. Specify an available Quartus Prime Tcl package. Type help for a list of available Quartus Prime Tcl packages.
TCL_ERROR 1 ERROR: Tcl package <string> version <string> does not exist. Specify an available Quartus Prime Tcl package. Type help for a list of available Quartus Prime Tcl packages.
TCL_ERROR 1 ERROR: Tcl package <string> is only available in Quartus Pro Edition
TCL_ERROR 1 ERROR: Tcl package <string> is only available in Quartus Standard Edition

Did you find the information on this page useful?

Characters remaining:

Feedback Message