Developer Guide

Libfabric* Support

The Intel® MPI Library switched from the Open Fabrics Alliance* (OFA) framework to the Open Fabrics Interfaces* (OFI) framework and currently supports libfabric*.

Enabling Libfabric Support

By default, the script that sets the environmental variables (
vars.bat
) sets the environment to libfabric shipped with the Intel MPI Library.  
To disable this, use the
I_MPI_OFI_LIBRARY_INTERNAL
environment variable or the
-i_mpi_ofi_internal
option passed to the script:
# Do not set the environment to libfabric from the Intel MPI Library. > call <install-dir>\env\vars.bat -i_mpi_ofi_internal=0 # Set the environment to libfabric from the Intel MPI Library. > call <install-dir>\env\vars.bat -i_mpi_ofi_internal=1
Set the
I_MPI_DEBUG
environment variable to 1 before running an MPI application to see the libfabric version and provider.
Example
> set I_MPI_DEBUG=1 > mpiexec -n 2 IMB-MPI1 pingpong [0] MPI startup(): libfabric version: 1.5.3-impi [0] MPI startup(): libfabric provider: sockets ...

Supported Providers

  • libfabric.dll

See Also

Product and Performance Information

1

Performance varies by use, configuration and other factors. Learn more at www.Intel.com/PerformanceIndex.