## Contents

1 Quick Start Guide............................................................................................................. 3  
   1.1 Directory Structure.................................................................................................... 4  
   1.2 Design Components for the Avalon®-MM Endpoint.................................................. 4  
   1.3 Generating the Design............................................................................................. 4  
   1.4 Simulating the Design............................................................................................. 5  
   1.5 Compiling and Testing the Design in Hardware......................................................... 6  

2 Design Example Description........................................................................................... 10  
   2.1 Creating a Signal Tap Debug File to Match Your Design Hierarchy ....................... 10  
   2.2 Intel Arria 10 or Intel Cyclone 10 Development Kit Conduit Interface...................... 11  

A Document Revision History for Intel Arria 10 and Intel Cyclone 10 Avalon-ST Hard IP for PCIe Design Example User Guide................................................................. 12
1 Quick Start Guide

The Intel® Arria® 10 or Intel Cyclone® 10 Hard IP for PCI Express® IP core includes a programmed I/O (PIO) design example to help you understand usage. The PIO example transfers memory from a host processor to a target device. It is appropriate for low-bandwidth applications. The design example includes an Avalon-ST to Avalon-MM Bridge. This component translates the TLPs received on the PCIe* link to Avalon-MM memory reads and writes to the on-chip memory.

This design example automatically creates the files necessary to simulate and compile in the Quartus® Prime software. You can download the compiled design to the Intel Arria 10 GX FPGA Development Kit. The design examples cover a wide range of parameters. However, the automatically generated design examples do not cover all possible parameterizations of the PCIe IP Core. If you select an unsupported parameter set, generations fails and provides an error message.

Note: Intel Cyclone 10 GX development kits are not yet available.

In addition, many static design examples for simulation are only available in the <install_dir>/ip/altera/altera_pcie/altera_pcie_a10_ed/example_design/a10 and <install_dir>/ip/altera/altera_pcie/altera_pcie_a10_ed/example_design/c10 directories.

Figure 1. Development Steps for the Design Example

Design Example Generation ➔ Compilation (Simulator) ➔ Functional Simulation

Compilation (Quartus Prime) ➔ Hardware Testing

ISO 9001:2008 Registered
1.1 Directory Structure

Figure 2. Directory Structure for the Generated Design Example

```
<pcie_a10_hip_0_example_design>
  pcie_example_design
  pcie_example_design.qpf
  Altera_PCIe_Interop_test.zip
  Readme_Altera_PCIe_interop_Test.txt
```

```
<design component>
  synth
  ...
  ...
  ...
  ...
  ...
  sim
  ...
  ...
  ...
  ...
  ...
  pcie_example_design_tb
  ...
  ...
  ...
  ...
  ...
  pcie_example_design_tb
  ...
  ...
  ...
  ...
  ...
  software
  windows
  interop
  ...
  ...
  ...
  ...
  ...
  pcie_example_design.qsf
  pcie_example_design.sdc
  pcie_example_design.qsys
  (Quartus Prime Standard, only)
  pcie_example_design.ip
  (Quartus Prime Pro, only)
```

1.2 Design Components for the Avalon®-MM Endpoint

Figure 3. Block Diagram for the Platform Designer PIO Design Example Simulation Testbench

1.3 Generating the Design

1. Launch Platform Designer. The Open System dialog box appears.
2. Click New to specify a Quartus Prime project name and custom IP variation name for your design. Then, click Create.
3. In the IP Catalog, locate and select Intel Arria 10 or Intel Cyclone 10 Hard IP for PCI Express. The parameter editor appears.
4. On the IP Settings tabs, specify the parameters for your IP variation.
5. In the Connections panel, make the following dummy connections:
   a. coreclkout_hip to refclk.
   b. rxm_bar0 to txs slave interface.
These dummy connection are removed when you generate the design example. They are necessary because Platform Designer system validation requires the refclk to be connected. Platform Designer also determines the size of the Avalon®-MM BAR master from its connection to an Avalon-MM slave device. When you generate the example design, these connections are removed.

6. Remove the clock_in and reset_in components that were instantiated by default.

7. On the Example Design tab, the PIO design is available for your IP variation.

8. For Example Design Files, select the Simulation and Synthesis options.

9. For Generated HDL Format, only Verilog is available.

10. For Intel Arria 10 Target Development Kit select the FPGA Development Kit option.

   Note: Intel Cyclone 10 GX FPGA development kits are not available at this time.

11. Click Generate Example Design. The software generates all files necessary to run simulations and hardware tests on the Intel Arria 10 FPGA Development Kit.

### 1.4 Simulating the Design

**Figure 4. Procedure**

1. Change to the testbench simulation directory.
2. Run the simulation script for the simulator of your choice. Refer to the table below.
3. Analyze the results.

**Table 1. Steps to Run Simulation**

<table>
<thead>
<tr>
<th>Simulator</th>
<th>Working Directory</th>
<th>Instructions</th>
</tr>
</thead>
</table>
| ModelSim* | <example_design>/ | 1. do msim_setup.tcl  
|           | pcie_example_design_tb/ | 2. ld_debug  
|           | pcie_example_design_tb/sim/mentor/ | 3. run -all  
|           |                      | 4. A successful simulation ends with the following message, "Simulation stopped due to successful completion!" |
| VCS*      | <example_design>/ | 1. sh vcs_setup.sh  
|           | pcie_example_design_tb/ | USER_DEFINED_SIM_OPTIONS=""  
|           | pcie_example_design_tb/sim/ | 2. A successful simulation ends with the following message, "Simulation stopped due to successful completion!" |
|           | synopsys/vcs       | 3. run -all |
| NCSim*    | <example_design>/ | 1. sh ncsim_setup.sh  
|           | pcie_example_design_tb/ | USER_DEFINED_SIM_OPTIONS=""  
|           | pcie_example_design_tb/sim/cadence | 2. A successful simulation ends with the following message, "Simulation stopped due to successful completion!" |
Figure 5. Partial Transcript from Successful Avalon-ST PIO Simulation Testbench

INFO: 60504 ns New Link Speed: 0.000/s
INFO: 60576 ns RP PCI Express Link Control Register (0040):
INFO: 60576 ns Common Clock Config: System Reference Clock Used
INFO: 61640 ns RP PCI Express Link Capabilities Register (01604800):
INFO: 61640 ns Maximum Link Width: 8
INFO: 61640 ns Support Link Speeds: 0.000/s or 5.000/s or 2.000/s
INFO: 61640 ns L0s Entry: Supported
INFO: 61640 ns L1 Entry: Not Supported
INFO: 61640 ns L0s Exit Latency: 2 us to 4 us
INFO: 61640 ns L1 Exit Latency: Less Than 1 us
INFO: 61640 ns Port Number: 01
INFO: 61768 ns RP PCI Express Device Control Register (5010):
INFO: 61768 ns Error Reporting Enables: 0
INFO: 61768 ns Relaxed Ordering: Enabled
INFO: 61768 ns Max Payload: 128 bytes
INFO: 61768 ns Extended Tag: Disabled
INFO: 61768 ns Max Read Requests: 4kBytes
INFO: 61768 ns RP PCI Express Device Status Register (0000):
INFO: 62096 ns Configuring Bus 000, Device 000, Function 00
INFO: 62096 ns RP Read Only Configuration Registers:
INFO: 62096 ns Vendor ID: 1172
INFO: 62096 ns Device ID: 8001
INFO: 62096 ns Revision ID: 01
INFO: 62096 ns Class Code: 0000
INFO: 62096 ns Interrupt Pins: INTA# used
INFO: 62794 ns BAR Address Assignments:
INFO: 62794 ns BAR Size Assigned Address Type
INFO: 62794 ns BAR0 Disabled
INFO: 62794 ns BAR1 Disabled
INFO: 62794 ns ExpROM Disabled
INFO: 66680 ns Completed configuration of Endpoint BARs.
INFO: 67728 ns TASK:downstream_loop
INFO: 68584 ns Passed: 0004 same bytes in BMP mem addr 0x00000040 and 0x00000040
INFO: 69448 ns Passed: 0004 same bytes in BMP mem addr 0x00000040 and 0x00000040
INFO: 70296 ns Passed: 0004 same bytes in BMP mem addr 0x00000040 and 0x00000040
INFO: 71140 ns Passed: 0004 same bytes in BMP mem addr 0x00000040 and 0x00000040
INFO: 72088 ns Passed: 0004 same bytes in BMP mem addr 0x00000040 and 0x00000040
INFO: 72936 ns Passed: 0004 same bytes in BMP mem addr 0x00000040 and 0x00000040
INFO: 73784 ns Passed: 0004 same bytes in BMP mem addr 0x00000040 and 0x00000040
INFO: 74632 ns Passed: 0004 same bytes in BMP mem addr 0x00000040 and 0x00000040
INFO: 75480 ns Passed: 0004 same bytes in BMP mem addr 0x00000040 and 0x00000040
INFO: 76328 ns Passed: 0004 same bytes in BMP mem addr 0x00000040 and 0x00000040
SUCCESS: Simulation stopped due to successful completion!

1.5 Compiling and Testing the Design in Hardware

Figure 6. Procedure

- Compile Design in Quartus Prime Software
- Set up Hardware
- Program Device
- Test Design in Hardware
The software application to test the PCI Express Design Example on the Intel Arria 10 GX FPGA Development Kit is available on both 32- and 64-bit Windows platforms. This program performs the following tasks:

1. Prints the Configuration Space, lane rate, and lane width.
2. Writes 0x00000000 to the specified BAR at offset 0x00000000 to initialize the memory and read it back.
3. Writes 0xABCD1234 at offset 0x00000000 of the specified BAR. Reads it back and compares.

If successful, the test program displays the message 'PASSED'

Follow these steps to compile the design example in the Quartus Prime software:

1. Launch the Quartus Prime software and open <example_design>/pcie_example_design.qpf.

2. On the Processing > menu, select Start Compilation.

   The timing constraints for the design example and the design components are automatically loaded during compilation.

Follow these steps to test the design example in hardware:

1. In the <example_design>/software/windows/interop directory, unzip Altera_PCIeInterop_Test.zip.
2. Install the Intel FPGA Windows Demo Driver for PCIe on the Windows host machine, using `altera_pcie_win_driver.inf`.

   *Note:* If you modified the default Vendor ID or Device ID specified in the component GUI, you must also modify them in `altera_pcie_win_driver.inf`.

   a. In the `<example_design>` directory, launch the Quartus Prime software and compile the design (Processing > Start Compilation).

   b. Connect the development board to the host computer.

   c. Configure the FPGA on the development board using the generated `.sof` file (Tools > Programmer).

   d. Open the Windows Device Manager and scan for hardware changes.

   e. Select the Intel FPGA listed as an unknown PCI device and point to the appropriate 32- or 64-bit driver (`altera_pcie_win_driver.inf`) in the `Windows_driver` directory.

   f. After the driver loads successfully, a new device named *Altera PCI API Device* appears in the Windows Device Manager.

   g. Determine the bus, device, and function number for the *Altera PCI API Device* listed in the Windows Device Manager.

      i. Expand the tab, *Altera PCI API Driver* under the devices.

      ii. Right click on *Altera PCI API Device* and select Properties.

      iii. Note the bus, device, and function number for the device. The following figure shows one example.
3. In the `<example_design>/software/windows/interop/Altera_PCIe_Interop_Test/Interop_software` directory, click `Alt_Test.exe`.

4. When prompted, type the bus, device, and function numbers and select the BAR number (0-5) you specified when parameterizing the IP core.
   
   *Note:* The bus, device, and function numbers for your hardware setup may be different.

5. The test displays the message, PASSED, if the test is successful.

*Note:* Intel Cyclone 10 GX FPGA development kits are not available at this time.

**Related Links**

Intel Arria 10 GX FPGA Development Kit
2 Design Example Description

2.1 Creating a Signal Tap Debug File to Match Your Design Hierarchy

For Intel Arria 10 and Intel Cyclone 10 GX devices, the Intel Quartus Prime software generates two files, build_stp.tcl and <ip_core_name>.xml. You can use these files to generate a Signal Tap file with probe points matching your design hierarchy.

The Intel Quartus Prime software stores these files in the <IP core directory>/synth/debug/stp/ directory.

Synthesize your design using the Intel Quartus Prime software.

1. To open the Tcl console, click View ➤ Utility Windows ➤ Tcl Console.
2. Type the following command in the Tcl console: source <IP core directory>/synth/debug/stp/build_stp.tcl
3. To generate the STP file, type the following command:.main -stp_file <output stp file name>.stp -xml_file <input xml_file name>.xml -mode build
4. To add this Signal Tap file (.stp) to your project, select Project ➤ Add/Remove Files in Project. Then, compile your design.
5. To program the FPGA, click Tools ➤ Programmer.
6. To start the Signal Tap Logic Analyzer, click Quartus Prime ➤ Tools ➤ Signal Tap Logic Analyzer.
   The software generation script may not assign the Signal Tap acquisition clock in <output stp file name>.stp. Consequently, the Intel Quartus Prime software automatically creates a clock pin called auto_stp_external_clock. You may need to manually substitute the appropriate clock signal as the Signal Tap sampling clock for each STP instance.
7. Recompile your design.
8. To observe the state of your IP core, click Run Analysis.
   You may see signals or Signal Tap instances that are red, indicating they are not available in your design. In most cases, you can safely ignore these signals and instances. They are present because software generates wider buses and some instances that your design does not include.
## 2.2 Intel Arria 10 or Intel Cyclone 10 Development Kit Conduit Interface

The Intel Arria 10 or Intel Cyclone 10 Development Kit conduit interface signals are optional signals that allow you to connect your design to the Intel Arria 10 or Intel Cyclone 10 FPGA Development Kit. Enable this interface by selecting Enable Intel Arria 10 FPGA Development Kit connection on the Configuration, Debug, and Extension Options tab of the component GUI. The devkit_status output port includes signals useful for debugging. Intel Cyclone 10 GX development kits are not currently available.

### Table 2. The Intel Arria 10 or Intel Cyclone 10 Development Kit Conduit Interface

<table>
<thead>
<tr>
<th>Signal Name</th>
<th>Direction</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>devkit_status[255:0]</td>
<td>Output</td>
<td>The devkit_status[255:0] bus comprises the following status signals:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[1:0]: current_speed</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[2]: derr_cor_ext_rcv</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[3]: derr_cor_ext_rpl</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[4]: derr_err</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[5]: rx_par_err</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[7:6]: tx_par_err</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[8]: cfg_par_err</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[9]: dlup</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[10]: dlup_exit</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[11]: evl28ns</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[12]: evlus</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[13]: hotrst_exit</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[17:14]: int_status[3:0]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[18]: 12_exit</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[22:19]: lane_act[3:0]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[27:23]: ltssmstate[4:0]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[35:28]: ko_cpl_spcl_header[7:0]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[47:36]: ko_cpl_spcl_data[11:0]</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[48]: rxfc_cplbuf_ovf</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[49]: reset_status</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_status[255:50]: Reserved</td>
</tr>
<tr>
<td>devkit_ctrl[255:0]</td>
<td>Input</td>
<td>The devkit_ctrl[255:0] bus comprises the following status signals. You can</td>
</tr>
<tr>
<td></td>
<td></td>
<td>optionally connect these pins to an on-board switch for PCI-SIG compliance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>testing, such as bypass compliance testing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_ctrl[0]: test_in[0] is typically set to 1'b0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_ctrl[4:1]: test_in[4:1] is typically set to 4'b100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_ctrl[6:5]: test_in[6:5] is typically set to 2'b01</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_ctrl[31:7]: test_in[31:7] is typically set to 25'h3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_ctrl[63:32]: is typically set to 32'b0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• devkit_ctrl[255:64]: is typically set to 192'b0</td>
</tr>
</tbody>
</table>
A Document Revision History for Intel Arria 10 and Intel Cyclone 10 Avalon-ST Hard IP for PCIe Design Example User Guide

<table>
<thead>
<tr>
<th>Date</th>
<th>Version</th>
<th>Changes Made</th>
</tr>
</thead>
</table>
| 2017.11.06| 17.1    | Made the following changes:  
|           |         | • Added support for Intel Cyclone 10 GX devices.  
|           |         | • Added explanation for the dummy connections made in the Generating the Design topic. |
| 2017.03.15| 16.1.1  | Rebranded as Intel.                                                           |
| 2016.10.31| 16.1    | Initial release.                                                              |