High Bandwidth Memory (HBM2) Interface Intel® FPGA IP Design Example User Guide

Updated for Intel® Quartus® Prime Design Suite: 18.1.1
# High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example Quick Start Guide

1. Creating an Intel® Quartus® Prime Project for Your HBM2 System
2. Configuring the High Bandwidth Memory (HBM2) Interface Intel FPGA IP
3. IP Parameter Editor Pro Guidelines for High Bandwidth Memory (HBM2) Interface Intel FPGA IP
4. Generating the Synthesizable High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example
5. Generating the High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example for Simulation
6. Regenerating the High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example After Modification

# High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example Description

1. High Bandwidth Memory (HBM2) Interface Intel FPGA IP Synthesis Design Example
2. High Bandwidth Memory (HBM2) Interface Intel FPGA IP Simulation Design Example

# Document Revision History for the High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example User Guide

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>01/01/20</td>
<td>Initial release</td>
</tr>
<tr>
<td>2</td>
<td>02/02/20</td>
<td>Bug fix for parameter editor</td>
</tr>
<tr>
<td>3</td>
<td>03/03/20</td>
<td>Add support for simulation design example</td>
</tr>
</tbody>
</table>

---

**Send Feedback**
1. High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example Quick Start Guide

An automated design example flow is available for the High Bandwidth Memory (HBM2) Interface Intel FPGA IP.

You can use the Example Designs tab and the Generate Example Designs button in the IP Parameter Editor Pro window to specify and generate synthesis and simulation example design file sets with which you can validate your HBM2 IP.

The generated design example reflects the parameterization that you set in the IP Parameter Editor Pro window. You can generate a design example to specifically match an Intel FPGA development kit for your evaluation. Or you can generate a design example to match your own actual system requirements, as a starting point for creating your own system.

Figure 1. General Design Example Flow

1.1. Creating an Intel® Quartus® Prime Project for Your HBM2 System

To create a new IP variation, you must have an open Intel® Quartus® Prime project with a valid device part. If you do not already have an appropriate Intel Quartus Prime project, follow these steps to create an Intel Quartus Prime project targeting a device that supports High Bandwidth Memory (HBM2) Interface Intel FPGA IP.

1. Launch the Intel Quartus Prime software and select File ➤ New Project Wizard. Click Next.
2. Specify a directory name (<user project directory>), a name for the Intel Quartus Prime project (<user project name>), and a top-level design entity name (<user top-level instance name>) that you want to create. Click Next.

3. Verify that Empty Project is selected. Click Next two times.
4. In the **Device Family** section of the dialog box, select Intel Stratix® 10 for the **Family** and Stratix 10 MX for the **Device**. Alternatively, if you already know the specific part number of the device that you want to use, type that device part number in the **Name filter** field.

*Note:* The generated HBM2 IP targets the specific Intel Stratix 10 MX device that you specify. Because different Intel Stratix 10 MX part numbers may identify devices with differing numbers of HBM2 devices and differing HBM2 device locations, as well as differing stack count, height, and density properties, it is important that you specify the correct Intel Stratix 10 MX device part number before proceeding to the next step.

5. Select the appropriate device under **Available Devices**.
6. Click **Finish**. The system creates the `<user project directory>`.qpf and `<user project directory>`.qsf files within the `<user project directory>`.

**Figure 2.** Generated Intel Quartus Prime Project and Settings File

- `<user project directory>` - Your Intel Quartus Prime project directory
- `<user instance name>.qpf` and `<user instance name>.qsf` - Generated Intel Quartus Prime project and settings files

### 1.2. Configuring the High Bandwidth Memory (HBM2) Interface Intel FPGA IP

The following steps illustrate the IP Catalog (standalone) configuration flow. The Platform Designer (standalone) flow is generally similar.

1. Verify that the **IP Catalog** window is visible. If the **IP Catalog** window is not visible, select **View ➤ Utility Windows ➤ IP Catalog**.

2. In the **IP Catalog** window, select **Installed IP ➤ Library ➤ Memory Interfaces and Controllers ➤ High Bandwidth Memory (HBM2) Interface Intel FPGA IP**.

3. In the **New IP Variant** window, type a name `<user instance name>` for your HBM2 IP in the **File Name** field. Click **Create**.
4. In the IP Parameter Editor Pro window, configure the parameters on each tab to reflect your Intel FPGA development kit requirement or your actual HBM2 interface and system requirement. For information on individual parameters, refer to the Parameterizing the High Bandwidth Memory (HBM2) Interface Intel FPGA IP section in the High Bandwidth Memory (HBM2) Interface Intel FPGA IP User Guide.

Related Information
Parameterizing the High Bandwidth Memory (HBM2) Interface Intel FPGA IP

1.3. IP Parameter Editor Pro Guidelines for High Bandwidth Memory (HBM2) Interface Intel FPGA IP

The following table provides high-level guidance for parameterizing each of the tabs in the HBM2 IP parameter editor.
For detailed guidance on individual parameters, refer to the Parameter Description section in the High Bandwidth Memory (HBM2) Interface Intel FPGA IP User Guide.

Note: For the Intel Stratix 10 MX development kit, you may leave most of the High Bandwidth Memory (HBM2) Interface Intel FPGA IP settings at their default values.

Table 1. Tab Parameterization Guidelines

<table>
<thead>
<tr>
<th>Parameter Editor Tab</th>
<th>Guideline</th>
</tr>
</thead>
</table>
| **General**          | Correctly enter the following parameters to reflect your Intel FPGA development kit requirement or your HBM2 interface and system requirement:  
• The Speed grade for the device. The displayed speed grade should match with the selected device in Intel Quartus Prime Project for User.  
• The desired HBM location.  
• The desired number of HBM channels. The number of Traffic Generator pairs is based on this.  
• The desired HBM2 memory clock frequency.  
• The PLL reference clock frequency. This reference clock is for the High Bandwidth Memory (HBM2) Interface Intel FPGA IP subsystem and should match with the PLL reference clock frequency that you will supply to hbm_0_example_design_pll_ref_clk_clk pin.  
• The Reference clock frequency for example design core clock PLL. This reference clock is for the core clock PLL that will only be instantiated in example design file as an example external clock that feed the ext_core_clock port of the High Bandwidth Memory (HBM2) Interface Intel FPGA IP. The value should match with the PLL reference clock frequency that you will supply to core_clk_iopll_ref_clk_clk pin.  
• The desired Core clock frequency. The value will determine the output clock of the core clock PLL that will only be instantiated in example design file as an example external clock that feed the ext_core_clock port of the High Bandwidth Memory (HBM2) Interface Intel FPGA IP. The clock will eventually clock the Traffic Generator and any other components that clock by the wmc_clk_0_clk clock of the High Bandwidth Memory (HBM2) Interface Intel FPGA IP. |
| **Controller #**     | Set the parameters to reflect your actual HBM2 interface and system requirement for the controller. |
| **Diagnostic**       | For initial project investigations, you may use the default settings on Diagnostic tab.  
For hardware testing using synthesizable design example, ensure Enable In-System-Sources-and-Probes being checked to allow you to easily control and monitor the High Bandwidth Memory (HBM2) Interface Intel FPGA IP example design system through the Intel Quartus Prime software.  
For simulation, if you want the simulation to report the efficiency number for each HBM channel that you have enabled, check the Enable Efficiency Monitor checkbox. (For hardware testing using the synthesizable example design project, it is recommended to not enable the Efficiency Monitor, as this feature reduces the frequency at which the interface will close timing in the core clock domain.)  
You can also use the other parameters on the Diagnostics tab to assist you in evaluating, verifying and debugging the High Bandwidth Memory (HBM2) Interface Intel FPGA IP. |
| **Example Designs**  | To get the correct design example filessets, ensure that the Simulation and/or the Synthesis checkbox under Example Design Files section being checked. The generated design example is a complete HBM2 system consisting of the High Bandwidth Memory (HBM2) Interface Intel FPGA IP and a driver that generates random traffic to validate the memory interface. |

1.4. Generating the Synthesizable High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example

For the Intel Stratix 10 MX development kit, you may leave most of the High Bandwidth Memory (HBM2) Interface Intel FPGA IP settings at their default values. To generate the synthesizable design example, follow these additional steps.
1. On the **Diagnostics** tab, select **Example Design ➤ Enable In-System-Sources-and-Probes** to provide access to the available debugging features which are integrated in the design example.

2. Ensure that the **Synthesis** checkbox is checked under **Example Design Files** on the **Example Designs** tab.
Note: By default, both the Simulation and Synthesis checkboxes are checked.

3. Click File ➤ Save. The system creates and saves the current settings in the user IP variation file (<user instance name>.ip), within the <user project directory> that you specified.

4. Click Generate Example Design in the top-right corner of the window.

5. Specify a directory for the generated design example (<design example directory>) and click OK. The system creates the following design example file sets within the specified directory:
6. To exit the **IP Parameter Editor Pro** window, click **File ➤ Exit**.

### 1.5. Generating the High Bandwidth Memory (HBM2) Interface

**Intel FPGA IP Design Example for Simulation**

For the Intel Stratix 10 MX development kit, you may leave most of the High Bandwidth Memory (HBM2) Interface Intel FPGA IP settings at their default values. To generate the design example for simulation, follow these additional steps.

1. On the Diagnostics tab, click **Performance ➤ Enable Efficiency Monitor** to gather and report statistics on the efficiency of the interface during simulation.

   **Note:** If you enable In-System-Sources-and-Probes, it is instantiated only if synthesized by the Intel Quartus Prime software. For simulation, the corresponding signal is tied to either ground or Vcc.
2. Ensure that the **Simulation** checkbox is checked under **Example Design Files** on the **Example Designs** tab.

   **Note:** By default, both the **Simulation** and **Synthesis** checkboxes are checked.

3. Click **File ➤ Save**. The system creates and saves the current settings in the user IP variation file (`<user instance name>.ip`), within the `<user project directory>` that you specified.
4. Click **Generate Example Design** in the top-right corner of the window.

5. Specify a directory for the generated design example (<design example directory>) and click **OK**. The system creates the following design example file sets within the specified directory:
6. To exit the **IP Parameter Editor Pro** window, click **File ➤ Exit**.

### 1.6. Regenerating the High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example After Modification

If you modify the IP variation files or Platform Designer files in the post-generation synthesis folder, you can let the Intel Quartus Prime software regenerate the design example files through the integrated IP regeneration process during the Intel Quartus Prime compilation. Alternatively, you can use the design example's prepregeneration files to view, modify, generate, or regenerate the design example files. The design
example's pregeneration scripts are generated when you click the **Generate Example Design** button in the IP Parameter Editor Pro window. The pregeneration scripts are generated regardless of whether you select the **Simulation** or **Synthesis** checkbox.

1. To generate or regenerate the synthesis or simulation file sets, run one of the following scripts:
   - To create a project for compilation, run the `quartus_sh -t make_qii_design.tcl` script in the destination directory.
   - To create a project for simulation, run the `quartus_sh -t make_sim_design.tcl` script in the destination directory.
2. High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example Description

When you parameterize the High Bandwidth Memory (HBM2) Interface Intel FPGA IP, you can have the system generate simulation and synthesis file sets, by selecting Simulation or Synthesis under Example Design Files on the Example Designs tab.

The system creates a complete file set for simulation or for synthesis, in accordance with your selection.

2.1. High Bandwidth Memory (HBM2) Interface Intel FPGA IP Synthesis Design Example

The synthesis design example contains the following major blocks.

- An instance of the High Bandwidth Memory (HBM2) Interface Intel FPGA IP that manages the read, write, and other operations to the HBM2 device.
- Two independent traffic generators for every HBM channel enabled (one traffic generator for each HBM Pseudo-channel). The traffic generator is a synthesizable AXI-4 type example driver that implements a pseudo-random pattern of reads and writes to a parameterized number of addresses. The traffic generator also monitors the data read from the memory to ensure it matches the written data and asserts a failure otherwise.
- An I/O PLL to emulate the external core clock that feeds the ext_core_clock port of the HBM2 IP. The clock eventually clocks the Traffic Generator and any other components that are clocked by the wmc_clk_0_clk clock of the HBM2 IP.

Figure 3. Synthesis Design Example
If you enable more than one HBM channel, the synthesis design example includes an additional pair of traffic generators based on how many HBM channels are enabled. Because each HBM channel and HBM pseudo-channel are independent, each of the additional traffic generators are also independent from one another, although connected to a single High Bandwidth Memory (HBM2) Interface Intel FPGA IP. The following figure shows an example with HBM channels enabled.

**Figure 4. Synthesis Design Example with Three HBM Channels Enabled**

![Synthesis Design Example with Three HBM Channels Enabled](image)

**Table 2. Top-Level Signals of the HBM2 Design Example**

<table>
<thead>
<tr>
<th>Signal Group</th>
<th>Signal Name</th>
<th>Direction</th>
<th>Width</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLL Ref clk Inputs</td>
<td><code>core_clk_iopll_ref_clk_clk</code></td>
<td>Input</td>
<td>1</td>
<td>LVDS differential reference clock used by the I/O PLL to generate the fabric core clock. The design example automatically instantiates the I/O PLL that generates the core clock.</td>
</tr>
<tr>
<td></td>
<td><code>hbm_0_example_design_pll_ref_clk_clk</code></td>
<td>Input</td>
<td>1</td>
<td>LVDS differential reference clock used by the UIB PLL. The design example automatically instantiates the UIB</td>
</tr>
</tbody>
</table>

*continued...*
### Signal Group

<table>
<thead>
<tr>
<th>Signal Group</th>
<th>Signal Name</th>
<th>Direction</th>
<th>Width</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Resets</strong></td>
<td>core_clk_iopll_reset_reset</td>
<td>Input</td>
<td>1</td>
<td>PLL that generates the clock for the UIB subsystem.</td>
</tr>
<tr>
<td></td>
<td>hbm_0_example_design_wmcrst_n_in_reset_n</td>
<td>Input</td>
<td>1</td>
<td>Reset input for the core clock I/O PLL. The reset polarity is active high.</td>
</tr>
<tr>
<td></td>
<td>hbm_only_reset_in_reset</td>
<td>Input</td>
<td>1</td>
<td>General core logic reset; active low.</td>
</tr>
<tr>
<td><strong>Boundary Scan</strong></td>
<td>m2u_bridge_cattrip</td>
<td>Input</td>
<td>1</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td></td>
<td>m2u_bridge_temp</td>
<td>Input</td>
<td>3</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td></td>
<td>m2u_bridge_wso</td>
<td>Input</td>
<td>8</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td></td>
<td>m2u_bridge_reset_n</td>
<td>Output</td>
<td>1</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td></td>
<td>m2u_bridge_wrst_n</td>
<td>Output</td>
<td>1</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td></td>
<td>m2u_bridge_wrck</td>
<td>Output</td>
<td>1</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td></td>
<td>m2u_bridge_shiftwr</td>
<td>Output</td>
<td>1</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td></td>
<td>m2u_bridge_capturewr</td>
<td>Output</td>
<td>1</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td></td>
<td>m2u_bridge_updatewr</td>
<td>Output</td>
<td>1</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td></td>
<td>m2u_bridge_selectwr</td>
<td>Output</td>
<td>1</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td></td>
<td>m2u_bridge_wsi</td>
<td>Output</td>
<td>1</td>
<td>HBM2 boundary signals that are not driven by the traffic generator.</td>
</tr>
<tr>
<td><strong>Traffic Generator</strong></td>
<td>tgx_0_status_traffic_gen_pass</td>
<td>Output</td>
<td>1</td>
<td>Traffic generator status signals (Pass, Fail and Timeout) for Pseudo Channel 0, per Channel.</td>
</tr>
<tr>
<td></td>
<td>tgx_0_status_traffic_gen_fail</td>
<td>Output</td>
<td>1</td>
<td>Traffic generator status signals (Pass, Fail and Timeout) for Pseudo Channel 0, per Channel.</td>
</tr>
<tr>
<td></td>
<td>tgx_0_status_traffic_gen_timeout</td>
<td>Output</td>
<td>1</td>
<td>Traffic generator status signals (Pass, Fail and Timeout) for Pseudo Channel 0, per Channel.</td>
</tr>
</tbody>
</table>

*continued...*
Using the Design Example in a Project with Multiple HBM2 Interfaces

Do not instantiate an HBM2 design example in a project multiple times, because a Fitter error may occur.

To create a project with two HBM2 interfaces, create two instances of the HBM2 IP, one with HBM location = Top and one with HBM2 location = bottom. Generate the design example projects for each IP and then instantiate them in the multiple HBM2 interface project.

Related Information
Intel Stratix 10 Device Datasheet

2.2. High Bandwidth Memory (HBM2) Interface Intel FPGA IP Simulation Design Example

The simulation design example contains the following major blocks.

- The simulation example includes all the major blocks that exist in the synthesis design example, including a traffic generator pair, and an instance of the High Bandwidth Memory (HBM2) Interface Intel FPGA IP and external core clock I/O PLL. These blocks default to abstract simulation models where appropriate for rapid simulation. The design example may also include an Efficiency Monitor block for every HBM channel that you have enabled. The Efficiency Monitor block reports the efficiency number for the particular HBM channel at the end of simulation.

- An HBM2 memory model, which acts as a generic model that conforms to the HBM2 protocol specifications. Frequently, HBM2 vendors provide simulation models for their specific HBM2 components that you can download from their websites.

- A simulation checker, which monitors the status signals from the HBM2 IP and the traffic generator, to signal an overall pass or fail condition.

- The clock source and reset source instances which are the Bus Functional Model (BFM) that generates the reference clock and reset signal.
Note: Unlike other styles of memory interface where the testbench normally wraps the synthesis example design top-level file, for the High Bandwidth Memory (HBM2) Interface Intel FPGA IP, the Traffic Generator and other non-High Bandwidth Memory (HBM2) Interface Intel FPGA IP components are instantiated in the top-level testbench file.

2.3. High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example Interface tab

You can use the Example Designs tab in the parameter editor to parameterize and generate your design examples.
3. Document Revision History for the High Bandwidth Memory (HBM2) Interface Intel FPGA IP Design Example User Guide

<table>
<thead>
<tr>
<th>Document Version</th>
<th>Intel Quartus Prime Version</th>
<th>Changes</th>
</tr>
</thead>
</table>