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[bookmark: _Toc534202560]Objective
This course introduces the user to video and video interfaces by building a VGA controller on a FPGA to display to a monitor. Upon completion of the lab, the user will be able to understand the concepts of video such as refresh rate, display resolutions, video interface timings, and digital representation of color.
[bookmark: _Toc534202561]Prerequisites
1. Familiar with basics of logic and digital design
1. Familiar with Verilog/VHDL constructs
[bookmark: _Toc534202562]Materials
1. DE10 Lite board
1. Monitor with VGA connection
1. VGA Cable (Male to Male)
1. User must have Quartus Prime Lite/Standard
5. Quartus Prime Lite/Standard version 18.0 and up is preferred but not required
[bookmark: _Toc534202563]Downloading Quartus
To download Quartus Prime Lite, follow the instructions:
1. Visit the site: http://fpgasoftware.intel.com/?edition=lite. Select the version and your PC’s operating system
2. For smallest installation, and quick download enter only the entries below.
[image: ]
[bookmark: _Ref534198234][bookmark: _Toc513456622][bookmark: _Toc535533891]Figure 1: Download Quartus Prime Lite
3. Follow the instructions to download the design tools and you will have the Quartus Prime Lite version up and running.
[bookmark: _Toc534202564]Setting up DE10-Lite Drivers
1. To download your completed FPGA design into the device, connect the USB Blaster cable between your PC USB port and the USB Blaster port on your development kit. Don’t forget to also plug the kit into power using the wall adapter. Upon plugging in your device, you should see flashing LEDs and 7-segment displays counting in hexadecimal, or other lit up LEDs and 7-segments depending on previous projects that have been downloaded to the development kit. 
2. To use the USB Blaster to program your device, you need to install the USB Blaster driver. To begin, open your Device Manager by hitting the Windows Key and typing Device Manager. Click the appropriate tile labeled Device Manager that appears. 
3. Navigate to the Other Devices section of the Device Manager and expand the section below. [image: ]
[bookmark: _Toc535533892]Figure 2: Device Manager with uninstalled USB Blaster Driver
4. Right click the USB Blaster device and select Update Driver Software. 
5. Choose to browse your computer for driver software and navigate to the path shown below:
a. C:\intelFPGA_lite\<quartus_version>\quartus\drivers
6. Once you have the proper file path selected, click on Next and the driver for the USB Blaster should be installed
[bookmark: _Toc534202565]Background
Video consists of three part: video display, video interface, and the video data itself. The display is the physical way of seeing the video data. The main factors that describe a display are color, physical dimensions, aspect ratio and refresh rate. Video interfaces provide a standardized mean of communicating from hardware (such as CPU, GPU or FPGA) to a monitor. There are various interfaces to perform this such as DisplayPort, HDMI, DVI, and VGA. Finally, the video data can be generated by hardware or software and sent to the display via the video interface.
In this workshop, the focus is going to be on VGA. Video Graphics Array or VGA was created by IBM in the 1980’s to interface with a computer monitor. In order to interface to a display with VGA, five signals are need: Horizontal Sync, Vertical Sync, Red, Green, and Blue. At the VGA connector, the sync signals are digital signals while the color signals are analog. The MAX 10 FPGA doesn’t have the means to generate analog signals so the digital signals are converted externally. A monitor (which is made up of picture elements or pixels) receives these signals and toggles the pixels accordingly. A pixel is the smallest controllable element of a picture represented on the screen. The way the monitor reads and displays pixels is similar to the way as a book is read. The monitor displays the pixels from the left to right, top to bottom. The sync signals are intended to control what horizontal and vertical line and page that is being read. The color signals control the color of the data being display similar to the content of the word being read. 
[bookmark: _Toc534202566]Video Display
This section explains the how the displays display, color, the physical dimensions, and refresh rate.
[bookmark: _Toc534202567]How Video Displays Display
There are two different scanning methods to draw pixels onto a display: interlaced and progressive. Interlaced scanning draws all the odd lines of pixels on display (from left to right), then all the even lines, and repeats at a set frequency. Progressive scanning draws the whole display from left to right, top to bottom and repeats again at a set frequency. Most modern displays use progressive scanning.
[image: Image result for interlaced vs progressive scanning tv]
[bookmark: _Toc535533893]Figure 3: Interlaced vs. Progressive Scanning on Displays
[bookmark: _Toc534202568]Color
The display’s color that can be shown closely coincide the video interface it uses. Overall, there are two elements of color that the user should be aware of: color depth and color space. Color depth is the number of shades or range of colors that a color can have. The color space is the total quantity of colors that can be shown on a display.
For VGA, according to the industry standard (set by Video Electronics Standards Association [VESA]), the red, green, and blue each have a color depth of 16 (or 4-bit color) at 640 x 480 at 60 Hz. This leads to color space of 4096 different colors. However, since VGA needs analog signals for its color, a digital-to-analog converter (DAC) is needed to do the conversion. On the DE10 Lite development board used for this lab, a resistor network is implemented as a DAC (shown in Figure 4) to convert the signals.
[image: ]
[bookmark: _Ref534189538][bookmark: _Ref534189527][bookmark: _Toc535533894]Figure 4: MAX 10 FPGA connection to VGA Connector Schematic View

To find the output voltage at VGA_X (where X is R (red), G (green), or B (blue)) given the bit voltage, b_0 to b_n (n is the location of the highest bit for the given color), apply Kirchhoff’s Current Law on VGA_X node. (Note in this case R= 500 ohms)

[bookmark: _Ref526866112][bookmark: _Ref526866106][bookmark: _Toc534202618]Equation 1: VGA "DAC" Input/Output Relationship
In Equation 1, note that there is no dependence on resistance R but their values must be factors of 2 apart. 
[bookmark: _Toc534202569]Test Your Knowledge: DE10 – Lite DAC
What would the 4-bit value would make the output color 2/3 of its full intensity? 1010




[bookmark: _Toc534202570]Physical Dimensions
The primary specifications of monitor are its physical size, aspect ratio and resolution. The physical size of a display is measure corner to corner across the display. Common sizes are 21”, 24”, and 32”. The aspect ratio is the ratio between the number of pixels on the width and the number of pixels on the height. Common aspect ratios are 5:4, 4:3, and 16:9. The resolution is the number of pixels in the width and height. Common resolutions are 640 x 480 (or 480p), 1280 x 720 (or 720p), and 1920 x 1080 (or 1080p). The higher the resolution, the better the video quality and less distortion through what is called “aliasing” (where curved lines look like a series of straight lines).
[bookmark: _Toc534202571]Refresh Rate
The refresh rate is rate at which the number of images or frames are displayed per second. Common refresh rates are 30 Hz, 60 Hz, and 120 Hz. The higher the refresh rate, the smoother looking and feeling the video will appear on a display.
[bookmark: _Toc534202572]VGA Interface
[bookmark: _Toc534202573]Display Timings
The display timing is broken down into two parts: the active interval and the blanking interval.
The active interval is the duration of time that video data you want is being displayed on the screen. The blanking interval breaks down further into three sections: the front porch, the sync pulse, and the back porch. The front and back porch are the duration of time before and after the sync pulse, respectively. The sync pulse is the duration of time for the monitor to sync up timing with the display controller. This timing is relevant in the horizontal and vertical directions. This cycle repeats every line for the horizontal and for every frame in the vertical.
[image: ]
[bookmark: _Toc535533895]Figure 5: VGA Display Timing (Display View)
[image: ]
[bookmark: _Toc535533896]Figure 6: VGA Display Timing (Static Timing View)
To better understand this concept, think of this as reading a book. The back porch is the time looking at the left or top margin, the active video is the time reading the word or line on a page, the front porch is the time looking at the right or bottom margin, and the sync pulse is the time to go to the next line or page, in the horizontal and vertical direction respectively.
Since the VGA standard was created in the 80’s, the porches were needed due to CRT displays being the only display technology at the time. CRT’s needed temporal and spatial buffer the before and after drawing a horizontal line (hence the porches) and when transitioning between horizontal lines (hence the sync pulse).
In addition, as display technology advanced, VESA set specific timing lengths for each section at different refresh rates and resolutions for each video interface. Therefore, the pixel clock (number of pixels drawn per second) varies based on each use case. 
[bookmark: _Toc534202574]Lab
Objective:
· Understand the IP catalog feature of the Quartus FPGA Development tool
· Research and apply video timing standards according to the needs of the design
· Learn about color depth, color space, and resolution




This lab exercise consists of a Phase Locked Loop (PLL), ROM, VGA controller, and pattern generator. The PLL is used to convert the onboard 50 MHz input clock into the FPGA to the pixel clock specified by the VESA VGA industry standard for 480p and 1080p display resolutions. A ROM is used to hold the VGA timing and pattern generator parameters. The VGA controller generates the horizontal sync and vertical sync signals to display video on a monitor with resolution of 640x480 at 60 Hz and 1920x1080 at 60 Hz. The pattern generator generates the individual pixel 12 bit values as color gradients for red, green, blue, and grayscale to display on the monitor.

[image: ]
[bookmark: _Toc535533897]Figure 7: Block Diagram of Lab
[bookmark: _Toc534202575]Lab Setup
[bookmark: _Toc534202576]Download Project Files
Go to the link below and download the project called video_lab.
[bookmark: _GoBack]https://fpgawiki.intel.com/wiki/File:Video_lab.qar
[bookmark: _Toc534202577]Open Project
Method 1: Double Click Method
1. Double click the video_lab.qar file to open it in Quartus (Quartus will automatically unarchive the project and open the project)
2. All ready to go and move on to VGA Timing section
Method 2: GUI Method
1. Open Quartus
2. Go to File -> Open Project…
3. Locate and open the video_lab.qar file and the Restore Archived Project Window will appear
4. Click OK and the project will open
5. The project is ready to use
[bookmark: _Toc534202578]VGA Timings
This lab section will walk through the getting the FPGA to display to a monitor. Here are the steps with in this lab section:
1. Find the Pixel Clock Frequency
2. Test your knowledge: Pixel Clock Frequency
3. Open the Project
4. Generate a PLL
5. Generate a ROM
6. Compile the Project and Program the FPGA
7. Monitor Output
[bookmark: _Toc534202579]Find the Pixel Clock Frequency
Go to TinyVGA (http://tinyvga.com/vga-timing/640x480@60Hz) to get the pixel clock frequency needed to display 640 x 480 at 59.94 Hz (or about 60 Hz). The pixel clock frequency is simply the product of the total number of pixels per frame and the refresh rate (unit is in frames per second). (Note: you may round down the pixel clock to the nearest integer)

[bookmark: _Toc534202619]Equation 2: Pixel Clock Frequency
The total number of pixels is the product of the number of pixel per line and the number of lines per frame.

[bookmark: _Toc534202620]Equation 3: Calculate the Total Pixel Count
To find the pixels per line is the sum of the active video (AV), front porch (FP), Sync Pulse (SYNC), and back porch (BP) where each term is in term of pixels in the horizontal direction.

[bookmark: _Toc534202621]Equation 4: Calculate the number of Pixels per Line
Then, to find the lines per frame is the sum of the active video, front porch, Sync Pulse, and back porch where each term is in term of lines in the vertical direction.

[bookmark: _Toc534202622]Equation 5: Calculate the number of Lines per Frame


[bookmark: _Toc534202580]Test Your Knowledge: Pixel Clock Frequency
What is the pixel clock frequency needed to display 1920 x 1080 at 60 Hz? 148.5



[bookmark: _Toc534202581]Generate a PLL
1. Go to IP catalog and search for PLL
a. If IP catalog is no shown, go to View -> Utility Window -> IP Catalog to unveil it.
 [image: ]
[bookmark: _Toc535533898]Figure 8: Go to IP Catalog in Quartus
2. Double click ALTPLL. The “Save IP Variation” window will appear. Type in the name of pll as “vga_pll” and click OK. The MegaWizard window for the ALTPLL will appear.
[image: ]
[bookmark: _Toc535533899]Figure 9: Selecting ALTPLL in IP Catalog
3. In the Parameter Settings Tab, set the input clock frequency of PLL to 50 MHz.
[image: ]
[bookmark: _Toc535533900]Figure 10: Setting PLL input clock frequency
4. Go the third tab called “Output Clocks”. Click on circular checkbox to “Enter output clock frequency” and set output clock to the pixel clock frequency (found in the Tiny VGA link in the previous section) into the requested settings.
a. Note: the frequency in actual settings field may not have the correct clock and that is okay. This is due the way the PLL’s frequencies get divided by a ratio of integer numbers.
[image: ]
[bookmark: _Toc535533901]Figure 11: Setting PLL output clock frequency
5. Click Finish and it will take you to the Summary Tab. Keep the default settings and click Finish again.
a. Quartus may automatically add the PLL qip files to the project
b. If Quartus asks if you would like it to add the qip files to the project, click Yes
c. If not, the qip file needs to be added manually. Here are the steps to do it:
i. Go to Files -> Add/Remove Files in Project…
ii. Click on the …, next to the File name text box
iii. Navigate to the “vga_pll.qip” and click Open
iv. Click Ok and “vga_pll.qip” should appear in the Project Navigator
[bookmark: _Toc534202582]Generate a ROM
In this lab, a read-only memory or ROM is used to hold the VGA timing parameters and parameters for the pattern generator (discussed in further detail later in this lab). The ROM and a tool within Quartus called the In-System Memory Content Editor (or Memory Editor for short) are used in conjunction to reduce the total compile time throughout the lab. The Memory Editor allows the user to make modifications to the contents of the memory in real-time without having to recompile design to see any changes made. This allows some level of trial and error without waiting ~2-3 minutes per Quartus compilation to complete. Let’s insert a ROM into the project:
1. Go to IP catalog and search for ROM
2. Double click ROM 1-Port. The “Save IP Variation” window will appear. Type in the name of ROM as “ROM” and click OK. The MegaWizard window for the ROM 1-Port will appear.
[image: ]
[bookmark: _Toc535533902]Figure 12: Selecting the ROM: 1-PORT IP from IP Catalog

3. In the Parameter Settings Tab under General, set width of the output bus, q, to 12 and the number of words to 32.
[image: ]
[bookmark: _Toc535533903]Figure 13: Setting ROM Bus and Word Size Parameters

4. Click the Mem Init section, enable checkbox to “Allow the In-System Memory Content Editor…” (More details on this later). Click Browse… button and select the vga_rom_init.mif file (A mif file is a memory initialization file and is designed to hold the initial contents of a memory). Set the Instance ID to “VGAM”.
[image: ]
[bookmark: _Toc535533904]Figure 14: Assign mif, Memory Editor Access, and Instance ID for ROM
6. Click Finish and it will take you to the Summary Tab. Keep the default settings and click Finish again.
d. If Quartus asks if you would like it to add the qip files to the project, then click Yes
e. If not, the qip files need to be added manually. Here are the steps to do it:
i. Go to Files -> Add/Remove Files in Project…
ii. Click on the …, next to the File name text box
iii. Navigate to the “ROM.qip” and click Open
iv. Click Ok and “ROM.qip” should appear in the Project Navigator

[bookmark: _Toc534202583]Compile the Project & Program the FPGA
1. Click the Blue “play button”( [image: ]) near top of Quartus or go to Processing -> Start Compilation to compile the project (should take around ~2-3 mins)
2. Plug in DE10-Lite Dev Kit (if not done already) and connect the VGA cable between the monitor and the DE10-Lite.
3. Go to Tools -> Programmer
4. Click on Hardware Setup…
5. Click the dropdown menu next to Currently selected hardware and select the USB-Blaster [USB-X] (where X is a number). Click Close.
6. Click Add File…. Navigate to the video_lab.sof and click Open
7. Put all switches on the DE10-Lite in the OFF position (OFF position is down while the VGA connector on the right side when looking at the DE10-Lite)
8. Select the Program/Configure checkbox to program and click Start
9. Once progress bar read “100% Successful”, the FGPA is programmed and should be outputting display to the monitor.
[bookmark: _Toc534202584]Monitor Output
To have the lab section work on your first try would be too easy! The display should have three wide dark red, green and blue stripes in the upper right portion of the display.

[bookmark: _Toc535533905]Figure 15: Broken Default Pattern Generator Output to Monitor at 480p
The problem is that the timings in the sync_generator Verilog module used to generate the VGA sync are not correct. But rather than change the VGA timings in directly in the Verilog code, we are going to utilize the Memory Editor to make any fixes in real time and save them for later. This technique will save you from continuously recompiling each time you change the VGA timing parameters.
1. Go to TinyVGA (http://tinyvga.com/vga-timing/640x480@60Hz), find timing lengths (in pixels) for active video (or visible area in the Tiny VGA link), front porch, sync pulse, back porch and whole line length in the horizontal and vertical directions and fill them into the VGA ROM Memory Map worksheet. (Note: this is in last page of this lab manual)
a. Ignore the numerator for each color region (red, green, blue, and greyscale), the denominator for each color region and the Number of regions (More detail on this later)
2. Next, open up the Memory Editor in Quartus by navigating to Tools -> In-System Memory Content Editor. The Memory Editor will appear.
[image: ]
[bookmark: _Toc535533906]Figure 16: Opening In-System Memory Content Editor in Quartus

3. Select the ROM instance by clicking it in the Instance Manager section.
a. If a ROM instance in the Instance Manager doesn’t show up. Reprogram the FPGA using the JTAG Chain Configuration inside the Memory Editor (same process as using programmer).
[image: ]
[bookmark: _Toc535533907]Figure 17: Select ROM in Memory Content Editor
4. Read the ROM by going to Processing -> Read Data from In-System Memory or hitting F5. A list of numbers should appear in the instance window called “Instance 0: VGAM” and that is the contents of the ROM. 
a. How to read the ROM contents within the instance window
i. The left most value (“000000” in Figure 16) tells you the address of the first element in that line in HEX ( Must be in HEX)
ii. The location of the value in a line is the address in the ROM
iii. The value at a particular location is the value (in HEX) at that address in the ROM
iv. Ex (using Figure 16)
1. 280 is located at address 0
2. 002 is located at address 1
3. 09C is located at address 2
4. Etc.
[image: ]
[bookmark: _Ref534198244][bookmark: _Toc535533908]Figure 18: Viewing ROM Contents in Memory Editor
5. Insert the correct VGA timings (in terms of pixels) as HEX numbers from the Tiny VGA link (shows values in decimal) into correct location in the instance window of the Memory Editor
a. The calculator within Windows contains a programmer mode that works great for converting numbers from decimal to hexadecimal or you can use google
[image: ]
[bookmark: _Toc535533909]Figure 19: Window Calculator in Programmer Mode
6. Once finished, write the timings to the ROM by navigating to Processing -> Write Data to In-System Memory or hitting F7. Now, you should see the display have a red, green and blue region (going from left to right). 

[bookmark: _Toc535533910]Figure 20: Working Default Pattern Generator Output at 480p
7. Now that we have a working VGA controller, we can save this ROM configuration into the mif file so that we don’t have to re-set up the ROM again. To save it, navigate to Edit -> Export Data to File… , locate the vga_rom_init.mif and save it. 
8. To enable these changes, the project needs to be recompiled in Quartus and the FPGA needs to be reprogrammed in the Memory Editor. Visit previous sections in lab manual for a reminder on how to compile a project and program the FPGA.
9. The ROM should have the same correct configuration as before and the display should have the same red, blue and green regions.
[bookmark: _Toc534202585]Pattern Generator
The pattern generator (in this lab) is a Verilog module that generates a color gradient for each region for the color in that region. The purpose of it is to show all the possible colors that can be generated for red, green and blue on the DE10-Lite. 
· Enable the pattern generator by switching on SW4 on the DE10-Lite. (Note: Switch numbers start from 0 on the right)
Currently, the FPGA is only displaying 13 and a tiny bit of the 14th color of the possible 16 colors and only three regions. The pattern generator has the capability to generate a fourth region of grayscale. The way grayscale is generated is by having equal parts of red, green, and blue. Grayscale is commonly used for image processing in training and inferencing with AI. The grayscale is already set up but it needs to be enabled.
1. In the Memory Editor, click the ROM instance in interface manager and read the ROM data.
2. Write a “004” to the “Number of Region” address. This unveils the fourth region with grayscale. 
Note how the pattern generator only generates 10 different shades of color for each region. The way the color in each region is generated is using an 8 bit counter. The counter simply counts up until it hits a border or a transition between colors and once it does, the counter resets. But, we want to show full color depth per region. Therefore, the counter needs to be scaled in order to fit the full color depth. 
Each region’s color is calculated by:

[bookmark: _Toc534202623]Equation 6: Generated Color by Pattern Generator per Region
As shown in the ROM memory map, each color region has a corresponding numerator and denominator value that can be edited using the Memory Editor to scale the counter for that region.
Task for user
Show the full 16 color depth for each region by setting the numerator and denominator using the Memory Editor.
· Hint #1 (Counter)
· What is the width (in pixels) of each individual stripe generated within each region?
· Hint #2 (Color_deno)
· How wide is each region in pixels?
· Hint #3 (Color_num)
· How many possible numbers can be produced with the counter?

[bookmark: _Toc535533911]Figure 21: Properly Scaled Pattern Generator at 480p
[bookmark: _Toc534202586]VGA Resolution
This lab section will walk through enhancing the FPGA’s output resolution.
If the monitor can handle 1920x1080 @ 60 fps, continue on with lab. Else, skip this section.
Go to https://timetoexplore.net/blog/video-timings-vga-720p-1080p to find the VESA VGA Standard Timings and pixel clock frequency for 1080p. 
The first enhancement that needs to be done is to change the PLL’s frequency to the 1080p pixel clock.
1. Change the dropdown menu in the project navigator to IP Components
[image: ]
[bookmark: _Toc535533912]Figure 22: Changing View in Project Navigator to see IP Components
2. Double click vga_pll. The megawizard for the PLL will pop up
[image: ]
[bookmark: _Toc535533913]Figure 23: Locating ALTPLL IP
3. Jump to the output clocks tab and insert the new pixel clock frequency in the requested settings text field
a. Note: the actual settings field will not have the exact clock frequency and that is okay. This is due to the way the PLL’s frequencies get divided.
[image: ]
[bookmark: _Toc535533914]Figure 24: Changing Pixel Clock Frequency in ALTPLL IP for 1080p
4. Click Finish and it will direct you to the summary tab of the PLL. Click Finish again to finalize the files need. Finally, click OK to overwrite the current files. Quartus will notify you to upgrade the other IP’s in the design. The upgrades are not needed but you may do them to eliminate the messages.
5. Recompile the project (should take about ~2-3 min)
6. In the Memory Editor, go to the JTAG Chain Configuration section and select the “…” button. Locate the video_lab.sof and open it. Program the FPGA by pressing the [image: ] button. This is another way of invoking the programmer.
7. The display should appear to be blank/black or report a monitor warning/note because the timings in the ROM are for displaying at 480p and not 1080p. Therefore, this needs to be fixed.
8. Read the ROM’s current values by go to Processing -> Read Data from In-System Memory or hitting F7
9. Using the VGA timings for 1080p that you looked up earlier, insert them into the ROM using the Memory Editor
a. Reminder: the VGA timings need to be in HEX
10. Write the new ROM’s values back by go to Processing -> Write Data to In-System Memory or hitting F7
There should be a red, green, and blue region, respectively, with each region having 2.5 full color depth gradients per region.
[bookmark: _Toc534202587]Pattern Generator (1080p)
Similar to the previous pattern generator section where we added a fourth region and scaled the counter in the pattern generator, we are going to make similar changes to this section. We still want to add the fourth section. But, since we have about 6.75 times the resolution as before, we want to try and take advantage of it.
Task for User
· Enable the fourth region in the ROM using the Memory Content
· Set the color_num and color_deno in each region to show two sets of the full 16 color depth
· Note:
· The two color gradients appear due to the overflow of the internal 8 bit counter within the region (red, green, blue or greyscale)
· The default value for the numerator and denominator are not the correct results
[image: C:\Users\aarenas\AppData\Local\Microsoft\Windows\INetCache\Content.Word\20181219_014439.jpg]
[bookmark: _Toc535533915]Figure 25: Properly Scaled Pattern Generator at 1080p
[bookmark: _Toc534202588]Pong
Pong is a classic game from 1975 that plays similar to soccer. Due to its simplicity, it makes a great game to replicate and show off the capabilities and application of VGA. The section serves more as a demo but can be modified on your own (more detail later).
[bookmark: _Toc534202589]Download the Pong Project
Go to the link below and download the project called pong.
https://fpgawiki.intel.com/wiki/File:Pong.qar#file
[bookmark: _Toc534202590]Open the Pong Project
Method 1: Double Click Method
1. Double click the pong.qar file to open it in Quartus (Quartus will automatically unarchive the project and open the project)
2. All ready to go and move on to VGA Timing section
Method 2: GUI Method
1. Open Quartus
2. Go to File -> Open Project…
3. Locate and open the pong.qar file and the Restore Archived Project Window will appear
4. Click OK and the project will open
5. The project is ready to use
[bookmark: _Toc534202591]Compile the Pong Project & Program the FPGA
1. Click the Blue “play button” near top of Quartus or go to Processing -> Start Compilation to compile the project
2. Plug in DE10-Lite Dev Kit if not done already
3. Go to Tools -> Programmer
4. Click on Hardware Setup…
5. Click the dropdown menu next to Currently selected hardware and select the USB-Blaster [USB-X] (where X is a number). Click Close.
6. Click Add File…. Navigate to the pong.sof and click Open
7. Select the Program/Configure checkbox to program and click Start
Once progress bar read “100% Successful”, the FGPA is programmed and it should be outputting display to the monitor
[bookmark: _Toc534202592]How to play Pong on the DE10-Lite development board
The pong demo is built on top of the 480p pattern generator. Here are the controls to enable the pong demo and play pong:
· SW4 enables the pattern generator
· SW5 enables the pong demo
· KEY0 resets the entire demo
· KEY1 resets the pong demo (paddles, ball and score)
· With SW5 and the pong demo enabled,
· SW9 moves the left paddle up and down when the switch is on or off, respectively
· SW0 moves the right paddle up and down when the switch is on or off, respectively
· Additionally, the left most and right most seven segment displays shows the score of their respective players (score goes up when hit the ball past the opposite player)
[bookmark: _Toc534202593]Adjusting Pong Game Parameters
If you like to challenge yourself on FPGA video applications and make the pong game more interesting, you can make modifications to the game parameters in the pong.v file. Here are the recommend parameters to adjust:
· Paddle length
· Paddle speed
· Ball diameter
· Ball speed
· Background Color (Advanced)
· Hint: located on bottom of file

Have fun playing!

[bookmark: _Toc534202594]Further Learnings
If you would like to learn more about video applications on FPGAs, take a look at the Video and Image Processing (VIP) Suite Intel FPGA IP:
· https://www.intel.com/content/www/us/en/programmable/products/intellectual-property/ip/dsp/m-alt-vipsuite.html
This IP contains more advance features like filtering and color correction that are the basis of image processing 


Test Your Knowledge Answers:
1. Voltage Divider
a. 1010
2. 1080p Pixel Clock Frequency
a. 148.5 MHz
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    Table  1 : VGA ROM Memory Map  

Name  ROM  Address  (Decimal)  480p  1080p  

Data in  Decimal  Data in  HEX  Data in Decimal  Data in HEX  

Horizontal Active Video  0      

Horizontal Front Porch  1      

Horizontal Sync Pulse  2      

Horizontal  Back Porch  3      

Horizontal Whole Line  4      

Vertical Active Video  5      

Vertical Front Porch  6      

Vertical Sync Pulse  7      

Vertical Back Porch  8      

Vertical Whole Line  9      

Red Numerator  10      

Red Denominator  11      

Green Numerator  12      

Green Denominator  13      

Blue Numerator  14      

Blue Denominator  15      

Grayscale Numerator  16      

Grayscale Denominator  17      

Number of Regions  18      
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Table 1: VGA ROM Memory Map

		Name

		ROM Address (Decimal)

		480p

		1080p



		

		

		Data in Decimal

		Data in HEX

		Data in Decimal

		Data in HEX



		Horizontal Active Video

		0

		

		

		

		



		Horizontal Front Porch

		1

		

		

		

		



		Horizontal Sync Pulse

		2

		

		

		

		



		Horizontal Back Porch

		3

		

		

		

		



		Horizontal Whole Line

		4

		

		

		

		



		Vertical Active Video

		5

		

		

		

		



		Vertical Front Porch

		6

		

		

		

		



		Vertical Sync Pulse

		7

		

		

		

		



		Vertical Back Porch

		8

		

		

		

		



		Vertical Whole Line

		9

		

		

		

		



		Red Numerator

		10

		

		

		

		



		Red Denominator

		11

		

		

		

		



		Green Numerator

		12

		

		

		

		



		Green Denominator

		13

		

		

		

		



		Blue Numerator

		14

		

		

		

		



		Blue Denominator

		15

		

		

		

		



		Grayscale Numerator

		16

		

		

		

		



		Grayscale Denominator

		17

		

		

		

		



		Number of Regions

		18
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