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1 About this document 

This document introduces cross development environment with Intel® System 

Studio 2018. 

This document is organized as the following. 

Chapter 2. Introduction 

Chapter 3. Project for building in a container and running on Linux 

Chapter 4. Project to cross compile for Linux and Android targets 
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2 Introduction 

Intel® System Studio 2018 introduces two new functionalities to help developers 

to cross build their code for Linux/Android target system. As shown in the 

following figure, there are two types of new project: 

1. Project for building in a container and running on Linux 

This new project type takes advantage of the popular technique – Docker. 

This is to create remote Linux applications using a preconfigured toolchain 

in a Docker container that matches remote Linux target. 

2. Project to cross compile for Linux and Android targets 

This is to create Linux and native Android applications using local 

development system’s compiler and tools. 

  

 



 

   

6 

3 Project for building in a container 

and running on Linux 

Developers can use this functionality to cross-develop their applications for Linux 

machines. The built binary can be run via network connection on the remote 

Linux target. Alternatively, it can be copied to the remote Linux target and run 

there. 

3.1 Install Docker 

3.1.1 On Linux 

Installing Docker on Linux is very straightforward. Ubuntu 16.04 is used in this 

tutorial. Please refer to 

https://docs.docker.com/engine/installation/linux/docker-ce/ to learn more 

about installation steps. Ubuntu, Debian, CentOS and Fedora are supported 

officially by docker.com. 

3.1.2 On Windows 

Docker for Windows is a Docker Community Edition application running on 

Windows. It can be downloaded via 

https://store.docker.com/editions/community/docker-ce-desktop-windows. 

Please follow the following steps to install and configure Docker for Windows. 

1. Download and install Docker for Windows 

Installation of Docker for Windows is straight-forward.  

2. Start Docker for Windows 

Docker for Windows can be called from Windows Start menu. While it is 

running, it will create a whale-like icon on status bar, like the following 

figure. 

 

https://docs.docker.com/engine/installation/linux/docker-ce/
https://store.docker.com/editions/community/docker-ce-desktop-windows
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A Welcome dialog will prompt out if it is the first time to run Docker for 

Windows, shown as the following figure. 

 

3. Confirm and change settings of Docker for Windows 

Docker for Windows opens a daemon which monitors tcp://localhost:2375 

on its running. Intel® System Studio 2018 communicates with it via this 

port. Unfortunately, Docker for Windows would like communicates to be 

encrypted by TLS, but Intel® System Studio 2018 does not. Thus, the 

“Expose daemon on tcp://localhost:2375 without TLS” check box should 



 

   

8 

be checked in the Settings window of Docker for Windows, like the 

following figure. 

 

Also, please select the check box shown in the following figure to add C 

drive to the shared drivers of Docker for Windows. 
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3.2 Hyper-V Virtualization 

This project type takes advantage of Docker technology. Docker technology is 

dependent to virtualization technology of processor. Thus, please DO confirm that 

the Hyper-V virtualization has been enabled. Otherwise, error illustrated in the 

following figure occurs. 
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3.3 Steps to take advantage of the new feature 

1. Run Intel® System Studio IDE 

To correctly run Intel® System Studio IDE, there are several environment 

variables that needed to be set. 

On Linux, a bash file, iss_ide_eclipse-launcher.sh, is provided to setup all 

necessary environment variables and then run Intel® System Studio IDE. 

It is under /opt/intel/system_studio_2018. 

On Windows running Intel® System Studio IDE from Windows Start menu 

will invoke a script to setup all necessary environment variables 

automatically. 

2. Select Project for building in a container and running on Linux in new 

project wizard 

When Intel® System Studio IDE is started, click File->New->Project… and 

choose Project for building in a container and running on Linux under 

Application Development. 

The wizard on Linux is shown as the following figure. 
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The wizard on Windows is shown as the following figure. 
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3. Select a Docker toolchain that matches the target system and confirm 

network connection 

Clicking Next in the previous step leads to the next step of Docker 

toolchain selection. In this step the following dialog will prompt out for 

Internet connection check. 

 

For those who are behind firewall and need proxy server for external 

access, please click the Change network settings button to set proper 

proxy servers. 
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If the Internet connection check succeeds, the Docker toolchain can be 

selected in the following list. 

 

4. Select a project type 
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5. Type a project name and finalize the configuration 

Upon clicking the Finish button, the project will be created and the 

corresponding Docker image will be downloaded to local hard disk. 
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6. Create a new connection to the target 

The new connection setting dialog can be called out by linking the New 

Connection… combo box, as the following figure. By default, Connection 

for building in a container and running on Linux had been selected. 
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7. Type in connection name and IP address of remote Linux target 

 

8. Waiting for establishment of the new connection 
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The wizard will automatically try to connect to remote target once the 

Finish button is pressed. 

 

The following dialog will prompt out for username and password input, or 

the public key path setting. 
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The Connecting status in the connection window will change to Connected 

once the connection is established. 

 

9. Build and run your code 

Building messages will be printed out in the Console window. The following 

is a sample. 

17:22:40 **** Rebuild of configuration Debug for project Hello_World **** 

Info: Internal Builder is used for build 

docker exec -i 

81d1d85bd4b67e37b834317b99e57b6142cd2b3d51c5715005ea0f9112346133 /bin/bash -c 

"[ -d /workspace/Hello_World/Debug/src ] || mkdir -p 

/workspace/Hello_World/Debug/src && cd /workspace/Hello_World/Debug && 

x86_64-linux-gnu-g++ -I/usr/include -I/usr/include/c++ -I/usr/include/c++/5 -

I/usr/include/c++/5/backward -I/usr/include/mraa -I/usr/include/upm -

I/usr/include/x86_64-linux-gnu -I/usr/include/x86_64-linux-gnu/c++/5 -

I/usr/lib/gcc/x86_64-linux-gnu/5/include -I/usr/lib/gcc/x86_64-linux-

gnu/5/include-fixed -I/usr/local/include -O0 -g3 -Wall -c -fmessage-length=0 
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--sysroot= -m64 -march=corei7 -c -ffunction-sections -fdata-sections -o 

src/main.o ../src/main.cpp"  

docker exec -i 

81d1d85bd4b67e37b834317b99e57b6142cd2b3d51c5715005ea0f9112346133 /bin/bash -c 

"[ -d /workspace/Hello_World/Debug/src ] || mkdir -p 

/workspace/Hello_World/Debug/src && cd /workspace/Hello_World/Debug && 

x86_64-linux-gnu-g++ --sysroot= -o Hello_World src/main.o"  

17:22:41 Build Finished (took 527ms) 

From this build log, it is clear that the compiling is called inside Docker 

against Linux targets. 

Once binary is executed, it will direct its standard console output into the 

Console window. 
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4 Project to cross compile for Linux 

and Android targets 

This functionality enables developers to cross compile their applications for 

Linux/Android targets. One of most used examples is development for Yocto 

Project. Cross compiling for Yocto Project Linux OS will be set as the example in 

this tutorial. 

4.1 Build toolchain with target system directories for 
Yocto Project Linux OS 

Like all cross compiling, a toolchain with target system directories is needed as 

well. Thus, at first we need to build a toolchain for Yocto Project. 

4.1.1 Toolchain for Linux 

Yocto Project provides a tool, bitbake, to build the target OS image and toolchain. 

1. Download poky from Github to local machine 

“pyro” in the following commands refers to version of poky. Users can 

choose the one which meets their needs. 

$ git clone –b pyro git://git.yoctoproject.org/poky.git 

2. Enable Yocto Project development environment and modify settings in the 

local.conf 

$ source poky/oe-init-build-env 

$ [TEXTEDITOR] conf/local.conf 

  # MACHINE ??= “qemux86-64” 

3. Build the toolchain 

$ bitbake core-image-minimal –c populate_sdk 

4. Confirm existence of toolchain and installation 
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Once the compilation finished, a bash file, poky-glibc-x86_64-core-image-

minimal-core2-64-toolchain-2.3.2.sh, appears under [poky 

Path]/build/tmp/deploy/sdk. Running this bash file will install the toolchain. 

Tree structure of the toolchain is shown below. 
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Toolchain binaries are located in folders under [toolchain 

Path]/sysroots/x86_64-pokysdk-linux/usr/bin. x86_64-poky-linux is used 

in this tutorial. 

Sysroot of the target is [toolchain Path]/sysroots/core2-64-poky-linux. 

4.1.2 Toolchain for Windows 

Please be noted that Yocto Project Linux OS and corresponding toolchains can 

ONLY be built on Linux machines. All the following steps should be conducted on 

a Linux environment. 

1. Download poky and meta-mingw from Github to local machine. 

Meta-mingw is the toolchain recipe for Windows. “pyro” in the following 

commands refers to version of poky and meta-mingw. Users can choose 

the one which meets their needs. 

$ git clone –b pyro git://git.yoctoproject.org/poky.git 

$ git clone –b pyro git://git.yoctoproject.org/meta-mingw 

2. Enable Yocto Project development environment and modify settings in the 

local.conf 

$ source poky/oe-init-build-env 

$ [TEXTEDITOR] conf/local.conf 

  # MACHINE ??= “qemux86-64” 

  # SDKMACHINE ?= “x86_64-mingw32” 

3. Add meta-mingw to bblayer.conf 

4. Build the toolchain 

$ bitbake meta-toolchain 

5. Confirm poky-glibc-x86_64-meta-toolchain-core2-64-toolchain-2.3.1.ta 

r.xz is under [poky Path]/build/tmp/deploy/sdk 

6. Copy the tar.xz file and extract the file on Windows 

The tree structure of the toolchain directories is similar to that on Linux. 
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4.2 Steps to take advantage of the new feature 

1. Run Intel® System Studio IDE 

To correctly run Intel® System Studio IDE, there are several environment 

variables that needed to be set. 

On Linux, a bash file, iss_ide_eclipse-launcher.sh, is provided to setup all 

necessary environment variables and then run Intel® System Studio IDE. 

It is under /opt/intel/system_studio_2018. 

On Windows running Intel® System Studio IDE from Windows Start menu 

will invoke a script to setup all necessary environment variables 

automatically. 

2. Select Project for building in a container and running on Linux in new 

project wizard 

When Intel® System Studio IDE is started, click File->New->Project… and 

choose Project for building in a container and running on Linux under 

Application Development. 

The wizard on Linux is shown as the following figure. 
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The wizard on Windows is shown as the following figure. 
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3. Fill in path and prefix of the extracted toolchain, as well as sysroot path 

As mentioned in 4.1, for Linux, [toolchain Paht]/sysroots/ x86_64-

pokysdk-linux/usr/bin/x86_64-poky-linux is the GNU toolchain binary 

directory. 

For Windows, it is [toolchain Paht]/sysroots/ x86_64-pokysdk-

mingw32/usr/bin/x86_64-poky-linux. 

GNU prefix is x86_64-poky-linux-, while sysroot directory is [toolchain 

Path]/sysroots/core2-64-poky-linux. 
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4. Type the project name and create the project 
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Once the project is created, source code will be opened and compilation 

will be invoked automatically, as shown in the following figure. 
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5. Click Project->Build project to build the application 

Intel® C++ compiler will be invoked for compilation by default. 


