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1. Introduction 

This example is a web-based board update portal (BUP) which contains a NIOS® II processor 

and a Triple Speed Ethernet media access control (MAC) MegaCore® function. The design 

example implements a basic remote configuration features in Nios II-based systems utilizing 

EPCQ flash memory for Arria 10 GX FPGA device. The design can obtain an IP address from 

any DHCP server and serve a web page from the flash on the board to any host computer on 

the same network. Furthermore, this design supports a static IP address, where the developer 

must insert the required design manually before loading the design into EPCQ flash. The web 

page allows you to upload new design images for both user hardware and user software. 

Furthermore, you can trigger reconfiguration from factory image to user image through the web 

page. 

 

2. Prerequisite 

You are required to have knowledge in instantiating and developing a system with a Nios II 

processor. Altera recommends that you go through the online tutorials and training materials 

provided on Altera's website before using this design example. 

 

Related information: 

 AN736: Nios II Processor Booting From Altera Serial Flash (EPCQ) 

 Quad-Serial Configuration (EPCQ) Devices Datasheet 

 Altera Remote Update IP Core User Guide 

 Nios II Gen2 Software Developer’s Handbook 

 

3. Requirements 

The hardware and software requirements for the design example are: 

 Altera Arria 10 GX Development Kit 

 Altera Quartus Prime version 16.1 with Nios II EDS 

 USB cable for programming the device 

 Ethernet cable 

 Any binary/hexadecimal file editor. 

 

https://www.altera.com/content/dam/altera-www/global/en_US/pdfs/literature/an/an736.pdf
https://www.altera.com/content/dam/altera-www/global/en_US/pdfs/literature/hb/cfg/cfg_cf52012.pdf
https://www.altera.com/content/dam/altera-www/global/en_US/pdfs/literature/ug/ug_altremote.pdf
https://www.altera.com/en_US/pdfs/literature/hb/nios2/n2sw_nii5v2gen2.pdf


4 
 

4. Design Example Files 

This design example consists of one Factory image and two Application images with Nios II 

software. The Application hardware and software images include simple design to show 

different LEDs pattern. 

 

File Name Description 

factory_image\a10_fpga_bup_top.v the top level file of the factory Image 
a10_fpga_bup.qsys The qsys file of the factory image 
APP1_top.v Top-Level file of application 1 
APP2_top.v Top-Level file of application 2 

APP1.qsys, APP2.qsys Qsys files for Application 1 and Application 
2 respectively 

factory_image/A10_BUP_DESIGN.sof Factory image SOF file 
factory_image/Factory_sw.hex Factory NIOS II application 
factory_image/html.zip HTML zip folder 

 

5. Block Diagram 
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Figure 1: Board Update Portal Design Diagram 
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Figure 1 shows the various IP blocks within the web-server design example. Details of the 

connection between each IP blocks can be found in the included Qsys file for this design 

example. From Figure 1, three main steps can be summarized: 

1- The board receives the hardware/software image through the Ethernet IP. 

2- The NIOS II processor will write the incoming new image to EPCQ flash. 

3- The host will trigger the FPGA reconfiguration to factory or new image. 

  

6. Experimental Setup 

Before you start, make sure all the jumpers and switches on the Arria 10 GX FPGA 

Development Kit are set to default. For more details about the Development Kit refer to Arria 

10 GX FPGA Development Kit. 

Furthermore, make sure to set MSEL pins to the Active Serial Programming; failing to do so 

will lead to system error of not being able to write to EPCQ flash. 

 

6.1 Generate programming files 

First, follow the steps on Design Store webpage to prepare the design template in Quartus 

Prime software. The master files are provided together with the design example. You may 

proceed to program the EPCQ flash and run the design without any recompilation or 

programming file generation. The default programming file “master_image\output_file.jic” 

consists of “Application image 1 A” and “Application image 2 A”. If you intend to create your 

own JIC file that consists of other application images, this section will demonstrate on how to 

generate the programming files manually. Please note that the generated files need to be in 

“Big endian” format. You can do this from Options/Boot info. 

To generate the programming file for EPCQ flash, perform the following steps: 

1. Open the “Convert Programming Files…” from “File” menu in Quartus Prime software. 

2. Under “Output programming file” section, set the following items: 

a. Programming file type: JTAG Indirect Configuration File (.jic) 

b. Configuration device: EPCQL1024 (select according to your EPCQ type) 

c. Mode: Active Serial 

d. File name: You may select your preferred path for the output file (.jic). By default, 

this is generated under your project root directory. 

3. Check the checkbox for “Create config data RPD (Generate output_file_auto.rpd)”. 

4. Under “Input files to convert” section, perform the following steps: 

https://www.altera.com/products/boards_and_kits/dev-kits/altera/kit-a10-gx-fpga.html
https://www.altera.com/products/boards_and_kits/dev-kits/altera/kit-a10-gx-fpga.html
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a. Select “Flash Loader”, then “Add Device” to select “10AX115S2” device in “Arria 

10” device family. 

b. For Factory image, 

i. Select “Page_0” of “SOF Data” and click “Properties”. 

ii. Set the “Address mode for selected pages” to “Start”. 

iii. Set “Start address” to “0x00001000” and click “OK”. 

iv. Click “Add File…” and open “factory_image\A10_BUP_DESIGN.sof”. 

v. Select the added SOF file and click “Properties”. 

vi. Check the “Compression” checkbox and click “OK”. 

c. For Application 1 image, 

i. Click “Add Sof Page”. 

ii. Select “Page_1” of “SOF Data” and click “Properties”. 

iii. Set the “Address mode for selected pages” to “Start”. 

iv. Set “Start address” to “0x02000000” and click “OK”. 

v. Click “Add File…” and open 

“application_image\application_1\app1_hw.sof”. 

vi. Select the added SOF file and click “Properties”. 

vii. Check the “Compression” checkbox and click “OK”. 

d. For Factory software, 

i. Click “Add Hex Data”. 

ii. Select “Absolute addressing”, you should see it “0x01600000”. 

iii. Open the HEX file “factory_image\factory_sw.hex” and click “OK”. 

e. For Application 1 software, 

i. Click “Add Hex Data”. 

ii. Select “Absolute addressing”. 

iii. Open the HEX file “application_image\application_1\app1_sw_vA.hex” 

and click “OK”. This step loads “Application image 1 A”. If you intend to 

load other application images, please open the desired HEX file 

accordingly. 

f. For Zipfs html web content, 

i. Click “Add Hex Data”. 

ii. Select “Absolute addressing”. 

iii. Open the HEX file “factory_image\zipfs\ html.hex” and click “OK”. 

5. Click “Generate” to generate the JIC programming file. 

Note that for Factory image, the Nios II processor is using “Execute-In-Place” boot option; while 

for Application image, the Nios II processor is using “Boot Copier” boot option. You may refer 

to AN736: Nios II Processor Booting From Altera Serial Flash (EPCQ) for details on Nios II 

processor boot options. 
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Figure 2: Convert Programming File window 

 

To generate the RPD (Raw Programming Data) files for new design upload, perform the 

following steps: 

1. Use any binary/hexadecimal file editor to open the RPD file 

“master_image\output_file_auto.rpd”. The steps described below are based on “HxD 

– Hexeditor” where you can download it here. 

2. Select the block data by going to “Edit > Select block…” in “HxD – Hexeditor”. 

3. For Application 1 software, 

a. Set “Start-offset” to “Application Start offset” and set “End-offset” to “Application 

End Offset”, then click “OK”. In this case, the application start offset is 

“0x03600000” and the application end offset is “0x03604CE3”. 

https://mh-nexus.de/en/hxd/


8 
 

 

Figure 3: Select block window 

 

b. Right-click on the selected block and click “Copy”. 

c. Create a new file by going to “File > New”. 

d. Paste the copied content into the new file by going to “Edit > Paste insert”. 

e. Save the new file in RPD format by going to “File > Save as…”. 

4. Repeat step 2 and 3 to generate RPD files for Application  hardware and software.  

5. Make sure the generated RPD files are having correct file size. 

 

6.2 Program hardware image and Nios II firmware into EPCQ 

To program the hardware image and Nios II firmware into EPCQ flash, perform the following 

steps: 

1. Connect the USB Blaster cable from PC to the on-board USB Blaster II connector and 

power up the board. 

2. Open the “Programmer” in Quartus Prime software, then click “Hardware Setup…” and 

select “USB-BlasterII”. 

3. Click “Auto Detect” and select “10AX115S2”. 

4. Right-click on the selected device “10AX115S2” and select “Change File”. 
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5. Open the programming file “master_image\full_image.jic”. 

6. Check the “Program/Configure” checkbox for “10AX115S2” and “EPCQL1024” devices. 

7. Click “Start” to start programming. 

8. Make sure the download is successful. 

9. Power cycle the board. 

 

Figure 4: Programmer window 

 

6.3 Run the design 

Once you have programmed the hardware image and Nios II firmware into the EPCQ flash, 

the design is ready to be executed. Before you proceed, ensure that you have the following: 

 A PC with a connection to a DHCP enabled network 

 On-board Ethernet port connected to the same network with the PC. 

To connect to the Board Update Portal web page, perform the following steps: 

1. After powering up, the board connects to the LAN’s gateway router and obtains an IP 

address. The LCD on the board displays the IP address. If you managed to see the IP 

address displayed on the LCD, skip step 2 and proceed to step 3, otherwise follow 

instructions in step 2. Please note the default application used in this design uses the 

static IP mode. If you need to change it, you can modify webserver.h file 

2. For first time board power up, perform the following steps: 

a. In the Nios II command shell, type the following Nios II EDS command:  

nios2-terminal ↵ 

b. Follow the instructions in the terminal window to generate unique MAC address 

for the Ethernet port. 
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c. Power cycle the board. Proceed to step 3 after the LCD on the board displays 

the IP address. 

3. Launch a web browser on a PC that is connected to the same network and enter the IP 

address from the LCD into the browser address bar. The Board Update Portal web page 

loaded in the browser. 

4. The IP address may change from time to time, if you power cycle the board, do make 

sure that you load the latest IP address on the browser. 

 

 

Figure 5: Board Update Portal web page 

 

To trigger reconfiguration to application images, perform the following steps: 

1. Load the Board Update Portal web page in a web browser. 

2. Click “Trigger reconfiguration” button in “Application 1” field. The board will be 

reconfigured to the Application 1 image. Take a look on the board, you should be able 

to see running RED LEDs . 

3. Power cycle the board to return to factory image. 
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4. Reload the Board Update Portal web page in the web browser. This step is important to 

make sure the web page is connected to the board after the power cycle. 

5. The default programming file “master_image\output_file.jic” consists of “Application 

image 1”. If you programmed your own JIC file that consists of other application images, 

you may observe different LED behavior after the reconfiguration. You can use 

Application Image 2 provided with the design as a second application image to replace 

Application image 1. Application image 2 has a different LED pattern, you should see 

GREEN blinking LEDs. 

 

To upload new designs, perform the following steps: 

1. Load the Board Update Portal web page in a web browser. 

2. To upload a new design for Application 1 software, click “Choose File” button in 

“Application 1 Software File Name” and select the generated application rpd file. 

3. Click “Upload” button to upload the design. The progress bar indicates the 

percentage of completion. Note that the process will take a few minutes or more, 

depending on the RPD file size.  

4. Once the upload has been completed, press push button “CPU RESET (S4)” to 

reset the board. 

Figure 6: Location of CPU RESET (S4)  

5. Reload the Board Update Portal web page in the web browser. 

6. To check if the upload is successful, click “Trigger reconfiguration” button in 

“Application 1” field. You should be able to see  LED0 through LED5 blinking on 

the board. You may also upload a new design for Application 1 hardware or  

software by repeating step 2 to step 6 but open the correct RPD file in dedicated 

field and leave other fields blank. 
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7. Modifying the Design Example 

First, follow the steps on Design Store webpage to prepare the design template in Quartus 

Prime software. This design example consists of one Factory image and one Application image 

with pre-fixed address offsets. Depends on your application design complexity, you may need 

to change the pre-fixed address offsets in this design example to work with your system. 

This section provides some guidelines on how to modify the design example to cater a different 

set of address offset for application hardware and software. You are required to have 

knowledge in instantiating and developing a system with a Nios II processor as step-by-step 

instructions will not be provided in this section. 

 

To setup the environment for Nios II software modification and recompilation, perform the 

following steps: 

1. Extract archive files “software\BUP_Software.zip” to folder “software\BUP_APP” and 

“software\ BUP_APP_bsp”. 

2. Open the “Nios II Software Build Tools for Eclipse” from “Tools” menu in Quartus Prime 

software. 

3. Go to “File >  Import…”, then select “Import Nios II Software Build Tools Project” in “Nios 

II Software Build Tools Project” folder and click Next. 

4. Browse to “software\ BUP_APP” folder in “Project location” field. 

5. Enter “BUP_APP” in “Project name” field, then click “Finish”. 

6. Repeat step 3 to step 5, but change the “Project location” to “software\ BUP_APP_bsp” 

folder and change the “Project name” to “BUP_APP_bsp”. 

7. Repeat steps 2 to 6 for Application_1 and Application_2 folders. 

8. You should see the “BUP_APP” and “BUP_APP_bsp” directory in “Project Explorer” as 

shown in Figure 7. The environment is now ready for modification. 
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Figure 7: Project Explorer window 

To change the address offset for application hardware and software, perform the following 

steps: 

1. Open the file “software\ BUP_APP \src\reconfig_utils.h”. 

2. Change the offsets in the header file to new desired offsets. Note that the offsets here 

are referring to start address of the block. 
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Figure 8: Location of address offsets in example code 

 

3. Save your changes and rebuild the project. Refer to AN736: Nios II Processor Booting 

From Altera Serial Flash (EPCQ) for details on software compilation and HEX file 

generation. 

To change the address for Zipfs html web content, perform the following steps: 

1. Open the file “software\ BUP_APP \src\reconfig_utils.h”. 

2. Change the “RO_ZIPFS_OFFSET” to new desired start address. 

3. Go to “Software Packages” tab in “BSP Editor” and select “altera_ro_zipfs”. 

4. Change “ro_zipfs_offset” to new desired start address. Note that the “ro_zipfs_base” 

refers to base address of EPCQ controller, where you can get it in Qsys. 

5. Save your changes and rebuild the project. Refer to AN736: Nios II Processor Booting 

From Altera Serial Flash (EPCQ) for details on software compilation and HEX file 

generation. 
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Besides address offsets, the web page content can also be modified. The web page content 

is stored as Read-Only Zip File System in the design example. For more details, refer to Nios 

II Gen2 Software Developer’s Handbook. 

If you have made modification on the web content file “factory_image\zipfs\html.zip”, 

perform the following steps to convert the ZIP file to HEX file: 

1. Use “bin2flash” tool in Nios II Command Shell to convert the archive ZIP file to FLASH file. 

Note that the “--location=” refers to “ro_zipfs_offset” as defined in BSP editor. 

2. Use “nios2-elf-objcopy” tool in Nios II Command Shell to convert the FLASH file to HEX file. 

 

 

Figure 9: Nios II Command Shell window to convert ZIP to HEX 

 

The contents of this chapter provide a simple guideline on modifying the design example. You 

should always refer to the provided link for more information. 

 

 

 

8. Revision History 

Date Revision Description 

10 December 2016 1.0 Initial Release 

23 March 2017 1.1 Adding the “Big endian” file type 

 


