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This document shows the Custom instruction for NIOS Il design example for the MAX 10 DE10
— Lite.

About tom Instructions in NIOS 11:

When a design includes an Altera Nios Il embedded processor, the design can accelerate time-critical
software algorithms by adding custom instructions to the Nios Il processor instruction set. Custom
instructions allow the user to reduce a complex sequence of standard instructions to a single instruction
implemented in hardware. This feature can be used for a variety of applications, for example, to optimize

Software inner loops for digital signal processing (DSP), packet header processing, and computation-
intensive applications. In Qsys, each custom instruction is a separate component in the Qsys system. The
user can add as many as 256 custom instructions to your system.

Refer to Nios Il Custom Instruction User Guide for further information.

A his Design Exampl

This design example shows how to implement the cyclic redundancy check (CRC) algorithm as a Nios Il
custom instruction. The CRC algorithm detects the corruption of data during transmission. The CRC
calculation consists of an iterative algorithm involving XOR and shift operations. These operations are
carried out concurrently in hardware and iteratively in software. Since the operations are carried out
concurrently, the execution is much faster in hardware. This example demonstrates the way to implement
an extended multi-cycle Nios Il custom instruction.

This design Example performs the following:

1) Computation of CRC using the custom instruction

2) Computation of CRC using a software C code.

3) Computation of CRC using a optimized software C code.

Steps to Run the Program
The steps to run the Custom Instruction for the MAX 10 DE10 are:

1. Extract all the files from the de10_custom_inst.par by following the instructions on the design
store.

The extracted files have the following the file structure:
i) Crc_hw folder consists of the 2 Verilog files CRC_Componentv and

CRC_Custom_Instruction.v for the custom instruction.
iii) The software/src folder contains all the .c files

crc_main.c : is the main file which calls all the other files.

crc.c: contains the software implementation and the optimized software implementation of
CRC function.

ci_crc.c: is the .c file for executing the built in function for the custom instruction.

ci_crc.h: hex file related to custom instruction
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crc.h: hex file related to the software implementation.
iv) It also contains platform/nios_setup which contains files related to the gsys setup.
v) Also the top level file custom_inst.v, the sdc file custom_inst.sdc is included

2. Open the newly created project and compile it in Quartus.
3. After compilation completes:
i) Go to Tools>Programmer.
ii) Click on Hardware Setup. A hardware Setup dialog box will open.
iii) Select USB Blaster under currently selected hardware. Click on close.
iv) Use the Add file tab to navigate to the output_files folder and select the .sof file.
v) Select the checkbox Program/Configure and Verify.
vi) Click on start. This starts the downloading of the .sof file on to the DE10.

4. We are using the Nios terminal to display the results. To open the command shell go to:
Start->All Programs > Altera->Nios Il EDS - Nios Il Command Shell in Windows or <Nios Il
EDS install path>/nios2_command_shell.sh in Unix.

5. In the Nios Il command shell type the command: nios2-terminal.

The results of the CRC operation will be displayed.

Recr h fil

If you want to edit the project, follow the below procedure:

Hardware

1) Launch Quartus Il and open the .gpf project

2) Compile the project (Processing -> Start Compilation).

3) Program the .Joutput_files/ <project name>.sof to the board using Quartus 11
Programmer (Tools -> Programmer - > Add File -> <project name>.sof -> OK -> Start).

Software
1) Open Tools->Nios Il Software build tools from Quartus Il. This launches the NIOS Il Eclipse IDE
where you can modify your C Code.

2) Select the workspace for Nios Il Eclipse. Then select File->New->Nios Il application and BSP from
Template

3) In the Window which opens, select the nios_setup.sopcinfo file in your Quartus project folder . The
.sopcinfo file contains information about the Qsys system, each module instantiated in the project, and
parameter names and values contained in the project.



4) Give the name to your nios project as cust_inst, select hello world small as the project template and
click finish. You can see that cust_inst and cust_inst_bsp is created on your workspace.

5) Now, we have to replace the contents of hello_world.c source with our source code. First Remove the
helloworld.c file from the project. To do this right click on ‘hello_world_small.c’ and click delete.
(screenshot attached below).

Next the 5 files in the software/src folder.
This can be done in 2 ways:
1) Directly Copy and Paste the required Files: Directly copy (Ctrl C) the files from the software/src
folder. In the Eclipse tool right click on the custom_inst project and click Paste.
2) Import the required Files: Right Click on the custom_inst project. Click Import. A new Import
popup will open.

a. Inthis double click on General and the File System.

b. Select Browse and then browse to the directory software/src and select ok. All the
contents of this folder, the 5 .c files are shown in the right. Check the checkboxes for all
the 5 files. Click on finish.

Now all the files are present in the folder.
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6)Since the Qsys contains the timer, this needs to be added here as the timestamp timer. For this right
click on the custom_inst_bsp and select NIOS Il - BSP Editor. A BSP Editor window will open. Here
select the timestamp timer as timer 0 and click on generate.

- Nios I BSP Editor - settings.bsp =& = |
File Edit Tools Help

Main 1 Software Packages I Drivers I Linker Script | Enable File Generation l Target BSP Directory

SOPC Information file: ..\..\nios_setup.sopcinfo
CPU name: nios2_gen2_0
Operating system: Altera HAL Version: }default - ]
BSP target directory: C:\altera\14.0_new\custom_inst\software\final_1_bsp

E-Settings » || nal =
= g ot
=-hal sys_clk_timer: none v
sys_clk_timer i t i - |
- timestamp_timer NDESIIDD GIIGE timer_0 |
~stdin = r 5
~stdout Sl jtag_uart 0 v =
~-stderr 3 : r .
H = stdout: v
+~enable_small_c_library \tag_uart 0 ~
~enable_gprof stderr: e
--enable_reduced_device_drivers dtag-uart-0;;| |
~enable_sim_optimze [¥] enable_small_c_library
E-linker
| -enable_exception_stack [7] enable_gprof

~exception_stack_size | 5
exception_stack_memory_region_r
~enable_interrupt_stack [T] enable_sim_optimize

interrupt_stack_size

enable_reduced_device_drivers

s 2 hal.linker
interrupt_stack_memory_region_nz ~
<1 1) -, [l anahla finn_ctark 2
Information | problems | Processing
@ Setting "hal.linker.exception_stack_memory_region_name” set to "onchip_memory2_0". -

@ Loading drivers from ensemble report.

@ Mapped module: "nios2_gen2_0" to use the default driver version.

@ Mapped module: “performance_counter_0" to use the default driver version.

(@ Mapped module: "timer_0" to use the default driver version.

@ Mapped module: “jtag_uart_0" to use the default driver version.

@ Finished loading drivers from ensemble report.

@ Loading BSP settings from settings file.

@ Finished loading SOPC Builder system info file *..\..\nios_setup.sopcinfo [relative to settings file]”

4 [m]

Generate | | Exit

7) Right Click on the custom_inst and Select Build Project to build the project. The initial build may take
some time.

8) Once the build is finished, to run the project, right click on the project and select Run As -> Run
Configurations.

9) Double click on Nios Il Hardware, and new configuration opens on the right pane . Make sure you select
the project name as custom_inst and .elf file as custom_inst.elf .

10) Select Target Connection Tab . Then Check the following two check boxes
Ignore mismatched system ID
Ignore mismatched system timestamp

Next Click Apply and Run.



%5 Debugger| &/ Source| 5] Common|

Processors:

Cable Device Device ID Instance ID Name Architecture

USB-Blasterll on localhost...

Byte Stream Devices:

Cable Device Device ID Instance ID Name Version

USB-BlasterIl on localhost... 1

|| Disable 'Nios II Console' view

Quartus Project File name:|< Using default .sopcinfo & .jdi files extracted from ELF >

System ID checks
| 7] Ignore mismatched system ID
Ignore mismatched system timestamp

Download

Download ELF to selected target system

[7] Start processor
< m

11) The following output is observed:



""" |B-— Problems | 7 Tasks] = Console] = Properties |51 Nios I C

{final_1 Nios II Hardware configuration - cable: USB-BlasterIIonlocahost[USB 1]devme[D 1instance ID: 0 name: jtaguart_0

+ — +

Comparison between software and custom instruction CRC32

+ — +

System specification

Size of each buffer =

System clock speed = 50 MHz
Number of buffer locations = 32
256 bytes

Initializing all of the buffers with pseudo-random data

Initialization ccmpleted

Running the software CRC

Completed

Running the optimized software CRC

Completed

Running the custom instruction CRC

Completed

Validating the CRC results from all implementations

A1l CRC implementations produced the same results

Processing time for each implementation

Software CRC = 59 ms
Optimized software CRC
Custom instruction CRC

= 08 ms
= 01 ms

Processing throughput for each implementation

Custom instruction CRC

Speedup ratio

Custom instruction CRC
Custom instruction CRC
Optimized scftware CRC

The user can modify the
observe the results.

Software CRC = 949 Mbps
Optimized scftware CRC =

9362 Mbps
= 1285 Mbps

vs software CRC = 86
vs cptimized software CRC = 56
vs software CRC= 1

number of buffer locations and size of the buffers and run the program to



NOTE:

The current project extracted from the .qar already contains the custom component added and
working.

However, the steps to add this custom component and generate the Qsys system are shown below
for user’s reference.

1) Open Qsys from Quartus. From the IP catalogue New component is selected. A new component
window will open. The new component’s name and display name is entered.

— — ~- - - - - 5

| & |

[

A Component Editor - CRC_hw.tcl*

File Templates View

ComponentType &2 | Files 22 | Parameters &2 | Signals 2% | Interfaces &2 - m|

» About Component Type

Name: CRC

Display name: | cr|

Version: 1.0

Group: &
Description:

| Created by:

Icon: D

Documentation: Title URL

e

2) Click on Next. The Files Tab is displayed. The folder crc_hw contains the Verilog files,
CRC_Component.v and CRC_Custom_Instruction.v for the custom instruction. These files need to be
added here.

Next, we have to set the top level entity. For this, double click on the attributes section of the
CRC_Custom_Instruction.v  file and check the top Ilevel file option. This sets the
CRC_Custom_Instruction.v file as the top level entity.

Next click on the analyze and synthesize files. This will report compilation errors if any in the .v files.



File Templates View

Component Type &% [Fis 23] Parameters 2% | Signals &2 | Interfaces &2

» About Files

Synthesis Files
These files describe this component’s implementation, and will be created when a Quartus II synthesis model is generated.
The parameters and signals found in the topevel module will be used for this component's parameters and signals.

Output Path Source File Type Attributes

CRC_Component.v custom_inst/crc_hw/CRC_Component.v |Verilog HDL no attributes
CRC_Custom_Instruction.v custom_inst/arc_hw/CRC_Custom_In.., Verilog HDL Top-level File

[3 LAndyzze Synthesis Files ] ‘ Create Synthesis File from Signals |

Top-evel Module: | (Analyze files to select module) - |

Verilog Simulation Files
These files will be produced when a Verilog simulation model is generated.

Output Path Source File Type Attributes

(Mo files)

li[ [ Copy from Synthesis Files ]

VHDL Simulation Files
These files will be produced when a VHDL simulation model is generated.

Output Path Source File Type Attributes

(Mo Files)

}:! [ Copy from Synthesis Files ]

3) Click on the Next tab. Here the parameters present in the .v files will be displayed.

i Eile Templates View

Component Type &% | Files SS_Signals 2 | Interfaces 23'

» About Parameters

Name Default Value Edit... Type Group Tooltip
cre_width 32 integer -
b A metars: mymd_nd 4294967295 Iogacvef_. |
polynomial 79764919 logic vec... =
reflected_input |1 integer [
reflected_output |1 integer i
VSRR AN =l i) €3
[ Add Parameter | ‘ Remove Parameter l




4) Click on next. The signals tab is displayed. Here, for the 1* signal (the clock) in the interface section
select the “New Custom Instruction Slave”. After choosing this, the interface section will display the new
custom instruction slave as the nios_custom_instruction_slave.

In the interface section select nios_custom_instruction_slavefor all the signals.
In the Signal type select the same option as the signal name.
After selecting all the above the signals tab will have values as shown below.

~ Comp-o;ent'Edﬁor-éR& hw.tcl;‘ - - - — ()

File Templates View

ComponentType 2% | Files 22 | Parameters &2 - Interfaces &% - |

» About Signals

Name Interface Signal Type Width Direction
clk nios_custom_instruction_slave clk 1 input
reset nios_custom_instruction_slave reset 1 input
dataa nios_custom_instruction_slave dataa 32 input
n nios_custom_instruction_slave n 3 input
clk_en nios_custom_instruction_slave clk_en 1 input
start nios_custom_instruction_slave start ¢ input
done nios_custom_instruction_slave done 1 output
result nios_custom_instruction_slave result 32 output




5) Next Click on Interfaces. Click on Remove Interfaces with no signals

. In the Parameters options select

the number of operands as 1.
& Component Editor - CRC_hw.tcl* - -—— SRR
File Templates View

ComponentType &2 | Files 2% | Parameters &2 | Signals &2 _ e

» About Interfaces

Type: :Custom Instruction Slave

Name: nios_custom_instruction_slave

v

-~ "nios_custom_instruction_slave" (Custom Instruction Slave)

|

|~ Block Diagram

| [F Parameters

nios_custom_instruction_slave|
L8

nios_custom_instruction_slave

Clock cydes:  [g
Clock cycle type: |yvariable
Operands: [1

|~ Access Waveform
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M dataa )(oo
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Add Interface Remove Interfaces With No Signals

6)Next, Click on finish. Save the changes to CRC_hw.tcl on being prompted.

Now a new component CRC will appear under the new component category in the IP catalogue.

7) Add the other components, such as the Nios, On Chip Memory, Timer, Jtag Uart to the Qsys system

and connect the ports. The overall Qsys system looks as below:



< K 4PN E1X*

_ AddressMap 22 | Parameters 5% | Device Family &% I i = | |
Use  Connections Name Description Export Clock Base End
= ck 0 Clock Source
C— dk_in Clock Input clk exported
(we] ck_in_reset Reset Input reset
—— dk Clock Output ck_0
—_————— dk_reset Reset Output
B onchip_memory2_0 |On-Chip Memory (RAM or ROM)
dk1 Clock Input clk_0
s1 \Avalon Memory Mapped Slave [ck1] 0x0000_8000 0x0000_£££f
resetl Reset Input [ck1]
= nios2_gen2_0 Nios I Gen2 Processor (Preview)
dk Clock Input clk_0
reset Reset Input [clk]
e E— data_master \Avalon Memory Mapped Master [clk]
— instruction_master \Avalon Memory Mapped Master [ck]
—> irq Interrupt Receiver [ck] IRQ 0 IRQ 31
e debug_reset_request |Reset Output [ck]
debug_mem_slave ‘Avalon Memory Mapped Slave [clk] 0x0001_0800 0x0001_0fff
— custom_instruction_m... |Custom Instruction Master
B timer_0 Interval Timer
dk (Clock Input clk_0
reset Reset Input [ck]
s1 /Avalon Memory Mapped Slave [clk] 0x0001_1000 0x0001_101£
irq Interrupt Sender [clk]
[ jtag_uart_0 JTAG UART
dk (Clock Input clk_0
reset Reset Input [ck]
avalon_jtag_slave ‘Avalon Memory Mapped Slave [clk] 0x0001_1020 0x0001_1027
irq Interrupt Sender [clk]
B crc_0 e
>— nios_custom_instructi... (Custom Instruction Slave Opcode 0 Opceode 0




