
User Guide Simulation Section (SV) 

(Example below is based on Quartus Prime 15.1. Tested working with Modelsim-se 10.4d, and 

vcsmx/2014.12-SP1) 

1. File>New Project Wizard 

2. In New Project Wizard, click Next.  

3. Then, provide the working directory as well as the name of the project.  For example, use “top” 

as the project name. Click Next.  

4. Then click Next again.  

5. Select Stratix V as the Device Family. Select targeted device part number if applicable. Click Next. 

6. Enter the appropriate EDA Tool Settings. For example, in the Simulation section, select 

Modelsim-Altera as tool name. Click Next. 

7. Click Finish. 

Instantiating ALTDQ_DQS2 

1. Tools>MegaWizard Plug-in Manager>Create a new custom megafunction variation. Click Next. 

2. On the left menu, select I/O> ALTDQ_DQS2 v15.1. Example of the output file is 

“bidir_hardFIFO_dqdqs2”. Then click Next. 

3. Follow settings below. Then click Finish. Then click Exit when done. 



 
 

 

 



Note 1: the memory frequency is less than the DLL min frequency. Thus the DLL needs to be driven by 

a 2x frequency (2x250MHz = 500MHz). 

Note 2: since the DLL is driven at doubled frequency, the effective DQS delay is only half of the 

memory frequency. In this case, to achieve 90 degree shift for memory frequency, the closest setting 

is 135degree in the ALTDQ_DQS2 GUI (which is effectively only 135 degree of 500MHz, or 67.5 degree 

of 250MHz).     

Note 3: Due to the settings above enables free-running read and write clock, DQS enable block is not 

needed.  

Note 4: If user requires bidirectional strobe, DQS enable block must be used (by checking “Use 

Capture strobe enable block”). In such case, the timing of the capture strobe enable block requires 

knowledge of the arrival time of the capture strobe which typically requires round-trip delay 

information. The use of this block requires run-time calibration which is not included as part of the 

ALTDQ_DQS2. 

 

  



Instantiating Altera PLL 15.1 

1. Tools>MegaWizard Plug-in Manager>Create a new custom megafunction variation. Click Next. 

2. On the left menu, select PLL>Altera PLL v15.1. Example of the output file is “alterapll”. Then click 

Next. 

3. Follow settings below. Then click Finish. Then click Exit when done. 

 

  



4. Information of the clock settings are as below (users may merge the similar frequency counters 

in their design, or the fitter will handle this automatically): 

  outclk_0 = 600 MHz (used as 2x frequency if necessary) 

  outclk_1 = 300 MHz (used as strobe/dqs clock) 

  outclk_2 = 300MHz, 270degree phase shifted (used as data/dq clock) 

  outclk_3 = 150MHz (used as half rate clock) 

  outclk_4 = 300MHz (used to drive the ALTDLL. Note that 300MHz is ALTDLL’s minimum 

frequency for StratixV devices) 

  outclk_5 = 300MHz (used to drive the Full Rate core clock) 

  outclk_6 = 150 MHz (used to drive the Half Rate core clock) 

  outclk_7 = 25 MHz (used as config_clk) 

Note:  If the memory frequency is less than the ALTDLL minimum frequency, the ALTDLL needs to be 

driven at 2x or 4x of the memory frequency. Relatively, the DQS phase settings shrinks as well. For more 

information, refer to the EMIF Chapter….   

 

  



Instantiating ALTOCT 

1. Tools>MegaWizard Plug-in Manager>Create a new custom megafunction variation. Click Next. 

2. On the left menu, select I/O>ALTOCT. Example of the output file is “altoct”. Then click Next. 

3. Follow settings below. Then click Finish. Then click Finish when done. 

 

  



Instantiating ALTDLL 

1. Tools>MegaWizard Plug-in Manager>Create a new custom megafunction variation. Click Next. 

2. On the left menu, select I/O>ALTDLL. Example of the output file is “altdll”. Then click Next. 

3. Follow settings below. Then click Finish. Then click Finish when done. 

 

Putting all megawizards together. In this example design, this is done in top.v. 

  



To setup the Nativelink and Simulation settings, follow the instructions below:  

1. In Quartus Prime Main Window, Go to Tools>Options. An example of settings are shown as 

below. 

 

  



2. In Quartus Prime Main Window, go to Assignments>Settings>Simulation. Create a new test 

bench called “tb” and include all necessary files. An example of settings are shown as below. 

 

 

 



 

3. Run Analysis and Synthesis.  

4. To see simulation results, go to Tools>Run Simulation Tool>RTL Simulation. See “Understanding 

Simulation Results” Section for more technical information. 

a. For successful simulation, user may need to manually change “alterapll.vo” to 

“alterapll.v” in the auto-generated “top_run_msim_rtl_verilog.do” file. 

  



5. Prior to running the fitter, ensure that following settings are done in the Assignment Editor.  

a. I/O Standard 

b. Input Termination 

c. Output Termination 

d. DQ Group 

e. Location assignment for strobe pin – this helps the fitter to fit the related DQ pins in the 

appropriate I/O sub-banks. Users can then back-annotate the locations if desired. 

An example setting in Assignment Editor, as well as the resulted Pin Planner is shown as below: 

 

 

6. Run Fitter, Timing Analysis and Assembler. See “SDC Brief Walkthrough” Section for more 

elaboration on the SDC Constraints example included in this design. 

 

  



“Understanding Simulation Results - SV Example Design” 

In this SV example design, a generic test bench is used to test the write and read operations in the 

ALTDQ_DQS2. In this test bench, DQSDriver which acts like the host controller, sends read/write 

commands to ALTDQ_DQS2. DQSAgent acts like an external memory device. DQSDriver also compares 

data read back from DQSAgent to what it should be. DQSDriver/DQSAgent has a side channel 

communicating directly with each other, bypassing ALTDQ_DQS2. These are called “Side Reads/Writes”. 

The data in the Side Reads/Writes will be used to compare with the data sent/received from the 

ALTDQ_DQS2.   

Note: Random data is generated and used in the test bench. Thus user may see other data values if 

different operating system, seeds and so on is used. 

Note: Descriptions below are all referring to the waveform generated after executing 

“top_run_msim_rtl_verilog.do”as shown below, unless specified. 

  

  



All ports are in reset mode until reset_n is asserted at 70ns time mark. Shortly after that, the major 

clocks (core_clk_fr and core_clk_hr) started toggling. Agent_reset_n_to_dqs is asserted at 91ns time 

mark to reset the ALTDQ_DQS2 block which resides in top_inst.  

Dynamic Configuration 

At 100ns time mark, there is a high pulse on beginscan. During the period when agent_output_enable is 

pulled low, some internal calibration is being carried out. Dynamic configuration is the main feature 

used. At 18.675ms time mark, enable_driver is asserted. This marks that the internal calibration is 

completed, and the control is now passed on to the host controller (in this case is the DQSdriver) to 

perform the normal read/write operation. Refer to “config_controller.sv” for the RTL related to dynamic 

reconfiguration operations executed in this example design.  

Through ALTDQ_DQS2’s dynamic configuration feature, you can override the static values at runtime 

with a scan chain. This helps counter challenging static timing closure. Each I/O and the DQS logic 

contain its own scan chain block (shift registers). This mini section shows how to serially scan 

configuration bits into each scan chain block, happening between 100ns and 18.675ms time mark. 

Detailed dynamic configuration simulation can be viewed in the waveform generated after executing 

“topwave.do”, in between the high pulses of beginscan and scandone as shown in the figure below. 

Note that there is a pulse between 18.035ms and 18.075ms on config_data_in, this is due to DQS 

Configuration’s dqsinputphasesetting is set to 2'b01 in the test bench. We shall see the results of this 

setting in “DQS Delay Chain” section later. For more descriptions, refer to “Dynamic Reconfiguration for 

ALTDQ_DQS2 Megafunction” section in the User Guide. 

 

Since enable_driver is asserted at 18.675ms time mark, following read and write operations will be 

executed by DQSDriver per stated in dqsdriver.sv. (The driver_clk is running at the same rate as the core.)  

  



DQS Write Operation 

See waveform captured below. At 18.803ms time mark, Write Operation is started by the driver 

asserting dqs_enable. Dqs_write is asserted at 18.811ms. This set ALTDQ_DQS2’s write_oe_in to high, 

getting ready to send out data to the DQSAgent. Note that as the data are first written to DQSDriver’s 

dqs_writedata, and then were reflected on the ALTDQ_DQS2’s dq. The data written out from the 

DQSDriver is also stored in check_fifo. Before and after this operation, dq is in Hi-Z mode, so that any 

unwanted glitch on this bidirectional port is filtered accordingly. On the other hand, notice that the 

write clock dqs_ios_to_agent (which is connected to ALTDQ_DQS2’s output_strobe_out) is a free 

running clock. Dqs_write deasserts at 18.851ms and dqs_enable deasserts at 18.859ms. Outgoing data 

from the ALTDQ_DQS2 (dq) is centre aligned to the write clock (dqs_ios_to_agent) as per expected. 

 

After executing “topwave.do”, if look into more details the DQS write operation as shown in wave 

captured below, write_oe_in is held high throughout the 5 sets of valid write_data_in, which is 

between 18.811ms and 18.851ms. Centre aligned output data appears on read_write_data_io between 

18.822ms and 18.862ms. Output_strobe_out is a free running clock while the read_write_data_io is 

driven at Hi-Z when there is no data transaction.  

 

Side Read Operation 

Consequently, Side Read operation was performed between 18.923ms and 18.963ms, where the data is 

output from DQSAgent to DQSDriver via side_readdata. Data validation is carried out in parallel, by 

comparing the side_readdata against the content of the check_fifo(data which was written out during 

DQS Write). Error message will be displayed if there is any mismatch. Waveform below shows the Side 

Read process. 

  

  



Side Write Operation 

Then, Side Write operation takes place between 19.011ms and 19.067ms. The data written out from the 

DQSDriver is also stored in check_fifo. Waveform below shows the Side Write process. 

 

Side Write is followed by DQS Read. Data validation is done by comparing data received by the 

ALTDQ_DQS2 core (read_data_out) against the check_fifo’s content, executed between 19.227ms and 

19.275ms when the dqs_readdata_valid is held high.   

Take note that the incoming data at dq is edge-aligned to the dqs_agent_to_ios as per expected.  

DQS Read Operation 

As DQS Read is usually the most challenging part for an external memory interface design, detailed 

elaboration will be covered in this section. In StratixV, user can choose to enable the Hard Read FIFO or 

not. The Read FIFO is on every input-data path and it handles only conversion between FR-HR. This 

example design utilizes the Hard Read FIFO. The test bench determines the timing to assert the Write 

Enable and Read Enable ports via vfifo_qvld and lfifo_rden respectively. In actual application, users 

should design their own logic to do so. As a reference, users may refer to the VFIFO and LFIFO concept, 

which is hardened in AV and CV ALTDQ_DQS2.    

DQS Read is initiated by the DQSDriver when dqs_read is asserted at 19.139ms, for the entire length of 

the desired read burst, which in this case is 12 full-rate cycles. At this time, the DQSAgent also received 

the read command, and is getting ready to send out data as per requested. After a specified latency, 

agent_output_enable is asserted from 19.167ms to 19.219ms. During this period, the DQSAgent drives 

the external memory interface’s clock and data lines. Oct_enable is asserted between 19.155ms and 

19.211ms. Notice the incoming data (dq) which is received edge-aligned to the clock (dqs_agent_to_ios) 

as per expected. 

 

Following will discuss how the data is captured in the FPGA before it is made available in the core.  

  



DQS Delay Chain 

Since DQS Enable block is not applicable for this example design, dqsenable is held at Hi-Z at all time. 

(Refer to AV example design for simple DQS Enable Control application.) Dqsbusout is the delayed dqsin 

signal that drives onto the dedicated DQS clock network to clock the DQ capture registers, so that data is 

captured at the center of the eye. Take note that if dynamic configuration is not enabled, the user 

should see a 67.5 degree phase shift (or ~735ps) between dqsin and dqsbusout, as per expected due to 

the settings in the ALTDQ_DQS2 as explained when instatiating the ALTDQ_DQS2 Megafunction in the 

beginning of this chapter. Take note that phasectrlin is held at Hi-Z in this case, as shown in waveform 

below.  

 

However, when dynamic configuration is enabled, the phase applied to the dqsbusout output will be 

determined by phasectrlin, which is set via dqsinputphasesetting port of the DQS Config, instead of the 

phase setting parameter in the ALTDQ_DQS2. Observe the following waveform. Prior to dynamic 

configuration completion, phasectrlin was set to 2'b00 and the shift between dqsin and dqsbusout is 

about 245ps. Meanwhile after the dynamic configuration execution, phasectrlin was set to 2'b11 and 

the shift between dqsin and dqsbusout is about 980ps. Note that the differences between 2’b11 (135 

degree) and 2’b00 (0 degree) is also 735ps (effectively 67.5degree).This is consistent as per expectation 

based on our settings in the ALTDQ_DQS2 GUI in this example design.  

  

 

  



Hard Read FIFO 

As seen in the waveform below, the incoming read data is available on read_write_data_io between 

19.171ms and 19.219ms. The capture DDIO block captures input data (DQ) on the rising and falling 

edges of the capture clock (DQS). For Stratix V devices, the capture DDIO block feeds the hard read FIFO 

or bypasses the hard read FIFO and goes directly to the core. The data transfer from the capture DDIO 

block and the next stage is referred to as zero-cycle transfer. This means that the transfer must happen 

on the same clock edge. (Note that a set_multicycle SDC command line will be required to ensure 

correct timing analysis.)  

In this example design, hard read FIFO is used. Note that when the first data is available at 19.174ms, 

the vfifo_qvld is asserted. This signal passes through the write_enable_ctrl DDIO OUT before driving the 

Read FIFO’s Read Enable port. Data is written to the Read FIFO between 19.174ms and 19.222ms as the 

Read FIFO’s we signal is asserted. Lfifo_rden which is connected to the Read FIFO’s Read Enable port 

through a fifo_enable block, is then being asserted between 19.219ms and 19.267ms. Read data  is 

available in the core between 19.179ms and 19.275ms on read_data_out. Users may further optimize 

the timing to read the Read FIFO (by adjusting the lfifo_rden) to create sufficient space between read 

and write pointers in the Read FIFO to maximize the throughput.  

 

  



 

Simulation Results 

Below is the printed result (showing successful simulation) which you may find in the message panel. If 

the simulation was not successful, it is due to the data sent/received at the ALTDQ_DQS2 is not the 

same as the expected ones.   

 

 

  



SDC Brief Walkthrough 

When starting a new SDC file, the first thing to do is constrain the clocks coming into the FPGA with 
create_clock. Following command create the base clock for the input clock port driving the PLL.  
create_clock -name refclk -period 10.000 [get_ports {refclk}] 

Next, create the generated clocks for the PLL. 

derive_pll_clocks 

Then, call derive_clock_uncertainty to apply inter-clock, intra-clock and I/O interface uncertainties 
based on timing model characterization. This command calculates and applies setup and hold clock 
uncertainties for each clock-to-clock transfer found in the design.  
derive_clock_uncertainty 

Following commands constraint the virtual input clock (for incoming DQS strobe) and the strobe_io port. 
Incoming data is edge aligned to the DQS strobe, min/max input delay is assumed to be +/- 0.3ns in this 
ref design. Use the -add option to add the user-defined clock uncertainty values in set_input_delay to 
the derived ones. 
#for 250MHz input clock 

create_clock -name virtual_dqs_in -period 4.000 -waveform {0 2.000} 

create_clock -name dqs_in -period 4.000 -waveform {0 2.000} [get_ports {capture_strobe_in}] 

  



Following set_false_path commands ensure that we are analyzing only the same edge transfers, by 

removing the opposite edge transfers. Multicycle commands decide that we are analyzing the correct 

transfer cycle. 

#for incoming edge aligned data  

set_false_path -setup -rise_from [get_clocks {virtual_dqs_in}] -fall_to [get_clocks {dqs_in}] 

set_false_path -setup -fall_from [get_clocks {virtual_dqs_in}] -rise_to [get_clocks {dqs_in}] 

set_false_path -hold -rise_from [get_clocks {virtual_dqs_in}] -rise_to [get_clocks {dqs_in}] 

set_false_path -hold -fall_from [get_clocks {virtual_dqs_in}] -fall_to [get_clocks {dqs_in}] 

set_multicycle_path -rise_from [get_clocks {virtual_dqs_in}] -rise_to [get_clocks {dqs_in}] -setup -end 0 

set_multicycle_path -fall_from [get_clocks {virtual_dqs_in}] -fall_to [get_clocks {dqs_in}] -setup -end 0 

 

set_input_delay -clock {virtual_dqs_in} -max -add_delay 0.300 [get_ports {read_write_data_io[*]}]                         

set_input_delay -clock {virtual_dqs_in} -min -add_delay -0.300 [get_ports {read_write_data_io[*]}]             

set_input_delay -clock {virtual_dqs_in} -clock_fall -max -add_delay 0.300 [get_ports 

{read_write_data_io[*]}]  

set_input_delay -clock {virtual_dqs_in} -clock_fall -min -add_delay -0.300 [get_ports 

{read_write_data_io[*]}] 

 

 



Following SDC constraints the outgoing DQS strobe. Note that we need to have –add option for the 

create_generated_clock command for the strobe_io port since it is bidirectional. Outgoing data is 

centre-aligned to the DQS strobe, min/max input delay is assumed to be +/- 0.25ns in this ref design. 

Use the -add option to add the user-defined clock uncertainty values in set_output_delay to the derived 

ones. 

#For outgoing centre aligned data 

create_generated_clock -name dqs_out -source [get_pins 

{pll_inst|alterapll_inst|altera_pll_i|general[1].gpll~PLL_OUTPUT_COUNTER|divclk}] -phase 0 [get_ports 

{output_strobe_out}] 

 

set_output_delay -clock { dqs_out } -max 0.150 [get_ports {read_write_data_io[*]}] -add_delay 

set_output_delay -clock { dqs_out } -max 0.150 -clock_fall [get_ports {read_write_data_io[*]}] -

add_delay 

set_output_delay -clock { dqs_out } -min -0.150 [get_ports {read_write_data_io[*]}] -add_delay 

set_output_delay -clock { dqs_out } -min -0.150 -clock_fall [get_ports {read_write_data_io[*]}] -

add_delay 

 

  



Following set_false_path commands ensure that we are analyzing only the same edge transfers, by 

removing the opposite edge transfers.  

set_false_path -setup -rise_from [get_clocks 

{pll_inst|alterapll_inst|altera_pll_i|general[2].gpll~PLL_OUTPUT_COUNTER|divclk}] -fall_to [get_clocks 

{dqs_out}] 

set_false_path -setup -fall_from [get_clocks 

{pll_inst|alterapll_inst|altera_pll_i|general[2].gpll~PLL_OUTPUT_COUNTER|divclk}] -rise_to [get_clocks 

{dqs_out}] 

set_false_path -hold -rise_from [get_clocks 

{pll_inst|alterapll_inst|altera_pll_i|general[2].gpll~PLL_OUTPUT_COUNTER|divclk}] -rise_to [get_clocks 

{dqs_out}] 

set_false_path -hold -fall_from [get_clocks 

{pll_inst|alterapll_inst|altera_pll_i|general[2].gpll~PLL_OUTPUT_COUNTER|divclk}] -fall_to [get_clocks 

{dqs_out}] 

Following multicycle lines ensure that the correct transfer between the DDIO and Read FIFO is analyzed. 

#Zero cycle transfer  from DDIO to Read FIFO 

set_multicycle_path -from 

{*|altdq_dqs2_stratixv:altdq_dqs2_inst|input_path_gen[*].capture_reg~HIGH_DFF} -to 

{*|altdq_dqs2_stratixv:altdq_dqs2_inst|input_path_gen[*].read_fifo_hr~INPUT_DFF_*} -setup -end 0 

set_multicycle_path -from 

{*|altdq_dqs2_stratixv:altdq_dqs2_inst|input_path_gen[*].capture_reg~LOW_DFF} -to 

{*|altdq_dqs2_stratixv:altdq_dqs2_inst|input_path_gen[*].read_fifo_hr~INPUT_DFF_*} -setup -end 0 

FIFO control algorithm is necessary. User may consider designing some soft FIFOs for this purpose. For 

more examples, refer to how the hard data valid FIFO and hard latency shifter FIFO work in AV and CV, 

as described in the User Guide, FIFO Control Section. 

#Paths below can ONLY be set to false path or multicycled if there is calibration algorithm in the system  

#to ensure correct functionalities 

set_false_path -from 

{*|altdq_dqs2_stratixv:altdq_dqs2_inst|input_path_gen[*].read_fifo_hr~WRITE_LOAD_DFF_*} -to 

{*|altdq_dqs2_stratixv:altdq_dqs2_inst|input_path_gen[*].read_fifo_hr~READ_LOAD_DFF_*} 


