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This document shows the Custom instruction for NIOS Il design example for the MAX 10 DECA
Development Kit.

About Custom Instructions in NIOS 11:

When a design includes an Altera Nios Il embedded processor, the design can accelerate time-critical
software algorithms by adding custom instructions to the Nios Il processor instruction set. Custom
instructions allow the user to reduce a complex sequence of standard instructions to a single instruction
implemented in hardware. This feature can be used for a variety of applications, for example, to optimize
Software inner loops for digital signal processing (DSP), packet header processing, and computation-
intensive applications. In Qsys, each custom instruction is a separate component in the Qsys system. The
user can add as many as 256 custom instructions to your system.

Refer to Nios Il Custom Instruction User Guide for further information.

About this Design Example

This design example shows how to implement the cyclic redundancy check (CRC) algorithm as a Nios Il
custom instruction. The CRC algorithm detects the corruption of data during transmission. The CRC
calculation consists of an iterative algorithm involving XOR and shift operations. These operations are
carried out concurrently in hardware and iteratively in software. Since the operations are carried out
concurrently, the execution is much faster in hardware. This example demonstrates the way to implement
an extended multi-cycle Nios Il custom instruction.

This design Example performs the following:

1) Computation of CRC using the custom instruction

2) Computation of CRC using a software C code.

3) Computation of CRC using a optimized software C code.

Steps to Run the Program

The steps to run the Custom Instruction for the DECA MAX 10 Kit are:

1. Extract all the files from the custom_inst. DECA.par by following the instructions on the design
store.

The extracted files have the following the file structure:

i) Crc_hw folder consists of the 2 Verilog files CRC_Component.v and
CRC_Custom_Instruction.v for the custom instruction.

i) The master_image folder consists of the custom_inst.sof and custom_inst.pof file which can
be directly used by the user to program the board. It also contains the custom_inst.hex file
which can be used to directly run the program from the Nios terminal.

iii) The software/src folder contains all the .c files
crc_main.c : is the main file which calls all the other files.
crc.c: contains the software implementation and the optimized software implementation of
CRC function.
ci_crc.c: is the .c file for executing the built in function for the custom instruction.


http://www.altera.com/literature/ug/ug_nios2_custom_instruction.pdf

ci_crc.h: hex file related to custom instruction

crc.h: hex file related to the software implementation.
iv) It also contains platform folder which contains files related to the gsys setup.
v) Also the top level file custom_inst.v, the sdc file custom_inst.sdc is included

2. Launch Quartus, Go to File ->Open Project and open the top.qgpf file to open the project.
After quartus launches:

i) Go to Tools=>Programmer.

ii) Click on Hardware Setup. A hardware Setup dialog box will open.

iii) Select USB Blaster under currently selected hardware. Click on close.

iv) Use the Add file tab to navigate to the master/images folder and select the custom_inst.sof
file.

V) Select the checkbox Program/Configure and Verify.

vi) Click on start. This starts the downloading of the .pof file on to the Eval Kit.

3. We are using the Nios terminal to display the results. To open the command shell go to:
Start->All Programs - Altera->Nios Il EDS - Nios Il Command Shell in Windows or <Nios Il
EDS install path>/nios2_command_shell.sh in Unix.

4. Here, make sure that the reset pin on the Kit is in the OFF position. The reset pin is assigned to
SWO switch. The switch should be pointing down (please find image attached).

This is the reset switch. This switch should
be in off position as shown initially.

5. Inthe Nios Il command shell type the command: nios2-terminal.
The results of the CRC operation will be displayed.



Below is a screen shot of results which are observed on the NIOS Il terminal.

% nios2—terminal

niozZ2—terminal: connected to hardware target uwusing JTAG UART on cahle
nios2—terminal: "“"UEB-BlasterII [USB-11". device 1, instance @
nioz2—terminal: <lUsze the IDE stop button or Ctrl-C to terminatel

i Comparison hetween software and custom instruction CRC32

System specification

System clock speed = 58 MH=
Mumher of bhuffer locations = 32
Size of each bhuffer = 256 hytes

Initializing all of the buffers with pseudo—random data

Initialization completed

Running the optimized software CRC

Completed

Running the custom instruction CRC

Completed

Validating the CRC resultsz from all implementations

A1l CRC implementations produced the same results

Processzing time for each implementation

Software CRC = 77 ms
Optimized software CRC 17 m=
Custom instruction CRC Bl ms

Proceszing throughput for each implementation

Software CRC = 4681 Mhps
Optimized software CRC 1213 HMbps
Custom instruction CRC 292 HMhps

Speedup ratio

Cuztom instruction CRC vs software CRC = 83
Custom instruction CRC vs optimized software CRC = 52
Optimized software CRC vs szoftware CRC= 1

nios2—terminal: exiting due to “C on host




Steps to Recreate the output files:

If you want to edit the project, follow the below procedure:
Hardware

1) Launch Quartus Il and open the top.gpf project

File -> Open Project -> top.qpf

2) Compile the project (Processing -> Start Compilation).

3) Program the .Joutput_files/top.sof to the board using Quartus Il Programmer (Tools ->
Programmer - > Add File -> top.sof -> OK -> Start).

Software
1) Open Tools->Nios Il Software build tools from Quartus Il. This launches the NIOS Il Eclipse IDE
where you can modify your C Code.

2) Select the workspace for Nios Il Eclipse. Then select File->New->Nios Il application and BSP from
Template

3) In the Window which opens, select the nios_setup.sopcinfo file in your Quartus project folder This
file in included along with the package and is present in the root directory. The .sopcinfo file contains
information about the Qsys system, each module instantiated in the project, and parameter hames and
values contained in the project.

4) Give the name to your nios project as cust_inst, select hello world small as the project template and
click finish. You can see that cust_inst and cust_inst_bsp is created on your workspace.

5) Now, we have to replace the contents of hello_world.c source with our source code. First Remove the
helloworld.c file from the project. To do this right click on ‘hello world small.c’ and click delete.
(screenshot attached below).

Next the 5 files in the software/src folder.
1) Import the required Files: Right Click on the custom_inst project. Click Import. A new Import
popup will open.

a. Inthis double click on General and the File System.

b. Select Browse and then browse to the directory software/src and select ok. All the
contents of this folder, the 5 .c files are shown in the right. Check the checkboxes for all
the 5 files. Click on finish.

Now all the files are present in the folder.



= Import

File system
Import resources from the local file system,

From directony:  Ycustom_script_editedodyssey_custom_inst\software\src - Browse...
[ src [€ ci_cre.c
[£] ci_cre.h
[€] cre_main.c
€] cre.c
[£] cre.h
Filter Types... | | SelectAll || DeselectAl
Into folder:  custorn_inst Browse...
Options

' Orverwrite existing resources without warning

Create top-level folder

@ <Back | MNed> |  Finish || Cancel




Attached below is a screenshot of the project explorer after importing the files.

[y Project Explorer &3 = B

-

=i

4 [=% cust_inst

» [ap! Includes

4 [~ system

£ templatexml

. [ ci_eree

. [ ci_ereh

. [ ere_main.c

o [& crec

. [ erch

|=| create-this-app
Makefile
£ readmetd

.= cust_inst_bsp [nios_setup]

6)Since the Qsys contains the timer, this needs to be added here as the timestamp timer. For this right
click on the custom_inst_bsp and select NIOS Il > BSP Editor. A BSP Editor window will open. Here
select the timestamp timer as timer 0 and click on generate.



- Nios II BSP Editor - settings.bsp E=EIRE
File Edit Tools Help

Main | spftware Packages | Drivers | Linker Script | Enable File Generation | Target BSP Directory

SOPC Information file: ..\..\nios_setup.sopcinfo
CPUname: nios2_gen2_0
Operating system:  Altera HAL Version: |default -
BSP target directory: C:\altera\14.0_new\custom_inst\software\final_1_bsp

[=-Settings || hal o
=8 common_| I : : P
-hal sys_clk_timer: none v
-sys_clk_timer X o - :
timestamp_timer timestamp_timer: timer_0 v
~stdin . : ! 1
-stdout stdin: jftag_uart 0 - | =
~stderr - - I .
S stdout: -
~-enable_small_c_library [ftag_uart 0 ~
~enable_gprof stderr ‘tag vart 0 |
~enable_reduced_device_drivers [Eagsuag ) L
enable_sim_optimize enable_small_c_library
=-linker
-enable_exception_stack [] enable_gprof
-exception_stack_size

b | enable_reduced_device_drivers
-exception_stack_memory_region_r - - -

-enable_interrupt_stack [7] enable_sim_optimize
interrupt_stack_size
-interrupt_stack_memory_region_nz ~
4 ([0 | 3

hallinker

[Fl ananla tark S2

Information |Problems Prncessing‘

@ Setting hal.linker.exception_stack_memory_region_name” set to "onchip_memory2_07,

@ Loading drivers from ensemble report.

@ Mapped module: "nios2_gen2_0" to use the default driver version.

(@ Mapped module: "performance_counter_07 to use the default driver version,

@ Mapped module: "timer_0" to use the default driver version.

@ Mapped module: “jtag_uart_0" to use the default driver version.

(@ Finished loading drivers from ensemble report,

@ Loading BSP settings from settings file.

@ Finished loading SOPC Builder system info file ™. .. \nios_setup.sopcinfo [relative to settings file]”

|

Generate ] [ Exit ]

7) Right Click on the custom_inst and Select Build Project to build the project. The initial build may take
some time.

8) Once the build is finished, to run the project, right click on the project and select Run As -> Run
Configurations.

9) Double click on Nios Il Hardware, and new configuration opens on the right pane . Make sure you
select the project name as custom_inst and .elf file as custom_inst.elf .

10) Select Target Connection Tab . Then Check the following two check boxes
Ignore mismatched system ID
Ignore mismatched system timestamp

Next Click Apply and Run.



Project l Target Connection %5 Debugger| & Source| = Common |

Connections

Processors:

Cable Device Device ID Instance ID

JSB-Blasterll on localhost... 10MOBS(A...

Architecture

Nica

MName

nics2 0

Byte Stream Devices:

Cable Device Instance ID

JSB-Blasterll on localhost... 10MOBS(A...

MName Version

jtagquart 0 1

Disable 'Mios II Console' view

Quartus Project File name:|< Using default .sopdnfo & .jdi files extracted from ELF =

System ID checks
Ignore mismatched system ID
Ignore mismatched system timestamp

Download

Download ELF to selected target system
[#] Start processar

4 [ 1

I d

m

11) The following output is observed:



H. Problems | ¥ Tasks | = Console | E Properties i
final_1 Mios II Hardware configuration - cable: USB-Blasterll on localhost [USBE-1] device ID: 1instance ID: 0 name: jtaguart_0

System clock speed = 50 MHz
Humker of buffer locaticons = 32
Size of each buffer = 256 bytes

Initializing all of the buffers with pseudo-random data

Initialization completed

Running the software CRC

Completed

Bunning the optimized socftware CRC

Completed

Running the custom instructicon CRC

Completed

Walidating the CRC results from all implementations

211 CRC implementations produced the same results

Processing time for each implementation
Software CRC = 59 ms

Optimized software CRC = 08 ms

Custom instruction CRC = 01 ms

Processing throughput for each implementation
Software CRC = 949 Mbps

Optimized software CRC = 9362 Mbps

Custom instruction CRC = 12585 Mbps

Speedup ratioc

Custom instruction CRC w3 software CRC = 86

Custom instruction CRC w3 optimized software CRC = 56
Optimized software CRC w3 software CRC= 1

The user can modify the number of buffer locations and size of the buffers and run the program to
observe the results.



NOTE:

The current project extracted from the .qar already contains the custom component added and
working.

However, the steps to add this custom component and generate the Qsys system are shown below
for user’s reference.

1) Open Qsys from Quartus. From the IP catalogue New component is selected. A new component
window will open. The new component’s name and display name is entered.

L Component Editor - CRC_hw.tcl* |_§3 J

File Templates View

Component Type &% | Files &% | Parameters &% | Signals &% | Interfaces &4 - |

»  About Component Type

MName: CREC
Display name: | cRe|
Version: 1.0
Group: -
Description:
| || Created by:
Icon: E
Documentation: Title URL
-

2) Click on Next. The Files Tab is displayed. The folder crc_hw contains the Verilog files,
CRC_Component.v and CRC_Custom_Instruction.v for the custom instruction. These files need to be
added here.

Next, we have to set the top level entity. For this, double click on the attributes section of the
CRC_Custom_Instruction.v  file and check the top level file option. This sets the
CRC_Custom_Instruction.v file as the top level entity.

Next click on the analyze and synthesize files. This will report compilation errors if any in the .v files.



|E|Ie Templates View
i

Component Type & [ Files Kgl Parameters K§| Signals 53| Interfaces K§| - |

b About Files

Synthesis Files
These files describe this component's implementation, and will be created when a Quartus II synthesis model is generated.
The parameters and signals found in the topdevel module will be used for this component's parameters and signals.

Cutput Path Source File Type Attributes

CRC_Component.v custom_inst/cre_hw/CRC_Component.v (Verilog HDL no attributes
CRC_Custom_Instruction.v custom_instfcre_hw/CRC_Custom_In... Verilog HDL Top-level File

B ’ Analyze Synthesis Files l | Create Synthesis File from Signals |

Top-evel Module: | (Analyze files to select module) |

Verilog Simulation Files
These files will be produced when a Verilog simulation model is generated.

Cutput Path Source File Type Attributes
(Mo files)

I:l [ Copy from Synthesis Files

VHDL Simulation Files
These files will be produced when a YHDL simulation model is generated.

Cutput Path Source File Type Attributes

(Mo files)

I:| ’ Copy from Synthesis Files

3) Click on the Next tab. Here the parameters present in the .v files will be displayed.

L4 CompunentEdilnr-CHE_hw.% —— o —— —— ] | P |

Eile Templates View

Component Type 33| Files &3 _ Signals  #% | Interfaces IE |

+  About Parameters

Mame Default Value Edit... Type Group Tooltip
cre_width 32 integer -
barameters: polynom!al_mml 4294967295 Iug_t:w:l:_
polynomial 79764919 logic vec... E
reflected_input |1 integer
reflected_output |1 integer
y——y FLT. . LY. [=al L ) 74
| Add Parameter | | Remove Parameter |

Preview the GUL...




4) Click on next. The signals tab is displayed. Here, for the 1* signal (the clock) in the interface section
select the “New Custom Instruction Slave”. After choosing this, the interface section will display the new
custom instruction slave as the nios_custom_instruction_slave.

In the interface section select nios_custom_instruction_slavefor all the signals.
In the Signal type select the same option as the signhal name.

After selecting all the above the signals tab will have values as shown below.

A Component Editor - CRC_hwetc® - - | = |

File Templates Yiew

Component Type &% | Files &2 | Parameters 232 - Interfaces &2 - |

b About Signals

MName Interface Signal Type Width Direction
clk nios_custom_instruction_slave clk 1 input
reset nios_custom_instruction_slave reset i input
dataa nios_custom_instruction_slave dataa 32 input
n nios_custom_instruction_slave n 3 input
clk_en nios_custom_instruction_slave clk_en 1 input
start nios_custom_instruction_slave start 1 input
done nios_custom_instruction_slave done 1 output
result nios_custom_instruction_slave result 32 output




5) Next Click on Interfaces. Click on Remove Interfaces with no signals. In the Parameters options select
the number of operands as 1.

L Component Editor - CRC_hwitel* - - - - — = ]

File Templates Yiew

Component Type &% | Fles #% | Parameters #% | Signals 53 _ - |

b About Interfaces

* "pios_custom_instruction_slave" (Custom Instruction Slave)

Name: |nios_custom_instruction_slave

Type: .Custorn Instruction Slave -

A
[ Block Diagram || [* Parameters
Clock cycles: 0
nios_custom_instruction_slave Clock cydle type: |variable
: ) i Operands:
nios_custom_instruction_slave = 1
Ik
clk [* Access Waveform
eset
ataa[31..0] reset
2.0] s ek 1L LT T LT
i lk_en olk_en clk_en /
Bt start start /! A\
ne
done
sul[31..0] st done /
n :l:ﬂ
nul dataa ¥ oo
4| 1 |y result )R |
4 L 2

Add Interface Remove Interfaces With No Signals

6)Next, Click on finish. Save the changes to CRC_hw.tcl on being prompted.
Now a new component CRC will appear under the new component category in the IP catalogue.

7) Add the other components, such as the Nios, On Chip Memory, Timer, Jtag Uart to the Qsys system
and connect the ports. The overall Qsys system looks as below:



_ Address Map 51(| Parameters ﬁi| Device Family ﬁi|

<4 K4 X+

=
@
n

Connections

-n’n|

Name

I L]
dk_in
dk_in_reset
dk
dk_reset

B enchip_memory2_0
dk1
sl
resetl

=l nios2_gen2_0
dk
reset
data_master
instruction_master
irg
debug_reset_request
debug_mem_slave

custom_instruction_m...

= timer_0
dk
reset
s1
irg

B jtag_uart_0
dk
reset
avalon_jtag_slave
irq

= erc_0

nios_custom_instructi...

Description

Clock Source

Clock Input

Reset Input

Clock Qutput

Reset Output

On-Chip Memory (RAM or ROM)
Clock Input

Avalon Memory Mapped Slave
Reset Input

Mios II Gen2 Processor (Preview)
Clock Input

Reset Input

Avalon Memory Mapped Master
Avalon Memory Mapped Master
Interrupt Receiver

Reset Output

Avalon Memory Mapped Slave
Custom Instruction Master
Interval Timer

Clock Input

Reset Input

Avalon Memory Mapped Slave
Interrupt Sender

JTAG UART

Clock Input

Reset Input

Avalon Memory Mapped Slave
Interrupt Sender

crc

Custom Instruction Slave

Export

clk

Clodk

Base

0x0000_2000

0x0001_08S00

0x0001_1000

0x0001_1020

Opcode 0

IRG O

End

0x0000_£££5

0x0001_Offf

0x0001_101f

0x0001_1027

Opcode 0

IRQ 31




