Server Products
Intel® Modular Server Systems
Creating a Multi-Port Trunk with an External Switch

You can optimize your external port usage by linking a group of ports together to form a single Link Aggregation Group (LAG). Aggregating ports multiplies the bandwidth between the devices, increases port flexibility, and provides link redundancy.

The Intel® Modular Server supports both static LAGs and Link Aggregation Control Protocol (LACP) LAGs.

Configure the switch
Enter Advanced Configuration on the switch
Open Layer 2 - Interface - LAG Configuration
Edit LAG1

Add a Description. For this example, we will be connecting to a Cisco* switch.
It is best to leave the other settings at their defaults.

Be sure to click Apply before clicking Close.
Open Layer 2 - Interface - LAG Membership
Edit ToCisco

Add the first four external ports

Configure your external switch

Please consult your switch documentation for exact commands. For a Cisco* Catalyst 2900 XL Series Switch, the commands might be:

interface FastEthernet0/1
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 1 mode active
channel-protocol lacp interface FastEthernet0/2
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 1 mode active
channel-protocol lacp interface FastEthernet0/3
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 1 mode active
channel-protocol lacp interface FastEthernet0/4
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 1 mode active
channel-protocol lacp interface Port-channel2
description database
switchport trunk allowed vlan 1
switchport mode trunk

For a Cisco* Catalyst 3500 XL Series Switch, the commands might be:

interface GigabitEthernet0/1
description Database
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 2 mode active interface GigabitEthernet0/2
description Database
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 2 mode active interface GigabitEthernet0/3
description Database
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 2 mode active interface GigabitEthernet0/4
description Database
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 2 mode active

Please note that these commands are examples only. Consult your switch documentation for the exact commands

This applies to:

Intel® Compute Module MFS2600KI
Intel® Compute Module MFS5000SI
Intel® Compute Module MFS5520VIR
Intel® Modular Server System MFSYS25
Intel® Modular Server System MFSYS25V2
Intel® Modular Server System MFSYS35

Solution ID: CS-031681
Last Modified: 24-Oct-2014
Date Created: 27-Jun-2010
Back to Top