The browser version you are using is not recommended for this site.
Please consider upgrading to the latest version of your browser by clicking one of the following links.

Support

Creating a Multi-port Trunk with an External Switch for Intel® Modular Server


Last Reviewed: 20-Jan-2017
Article ID: 000007392

You can optimize your external port usage by linking a group of ports together to form a single Link Aggregation Group (LAG). Aggregating ports multiplies the bandwidth between the devices, increases port flexibility, and provides link redundancy. 

The Intel® Modular Server supports both static LAGs and Link Aggregation Control Protocol (LACP) LAGs.

Configure the switch
Enter Advanced Configuration on the switch
Open Layer 2 - Interface - LAG Configuration
Edit LAG1

Advanced Configuration

Add a Description. For this example, we will be connecting to a Cisco* switch.
It is best to leave the other settings at their defaults.

LAG Configuration settings

Be sure to click Apply before clicking Close.
Open Layer 2 - Interface - LAG Membership
Edit ToCisco

LAG membership

Add the first four external ports

LAG membership settings example 1

LAG membership settings example 2

LAG membership settings example 3

Configure your external switch

Please consult your switch documentation for exact commands. For a Cisco* Catalyst 2900 XL Series Switch, the commands might be:

interface FastEthernet0/1
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 1 mode active
channel-protocol lacp interface FastEthernet0/2
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 1 mode active
channel-protocol lacp interface FastEthernet0/3
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 1 mode active
channel-protocol lacp interface FastEthernet0/4
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 1 mode active
channel-protocol lacp interface Port-channel2
description database
switchport trunk allowed vlan 1
switchport mode trunk

For a Cisco* Catalyst 3500 XL Series Switch, the commands might be:

interface GigabitEthernet0/1
description Database
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 2 mode active interface GigabitEthernet0/2
description Database
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 2 mode active interface GigabitEthernet0/3
description Database
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 2 mode active interface GigabitEthernet0/4
description Database
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
channel-group 2 mode active

Please note that these commands are examples only. Consult your switch documentation for the exact commands